~ubuntu-branches/ubuntu/intrepid/nethack/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/06_x11_data.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Joshua Kwan
  • Date: 2004-04-28 22:20:28 UTC
  • Revision ID: james.westby@ubuntu.com-20040428222028-ir8ahbbxi1jcot2d
Tags: 3.4.3-5
* Add Catalan translation (Closes: #248734)
* Patch work:
  - 91_enh_menucolors: Fix Pasi Kallinen's email address. pk -> pkalli
  - 19_gnome_ext_events (new): Fix a problem in Gnomehack where mouse click
    events in the extended menu would not be handled (thus a certain
    choice might be chosen, but a different one 'picked' by the code).
    (Closes: #246265)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 06_x11_data.dpatch by Joshua Kwan <joshk@triplehelix.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Add optional tiles to the X11 build.
 
6
 
 
7
if [ $# -ne 1 ]; then
 
8
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
9
    exit 1
 
10
fi
 
11
case "$1" in
 
12
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
 
13
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
 
14
    *)
 
15
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
16
        exit 1;;
 
17
esac
 
18
 
 
19
exit 0
 
20
 
 
21
--- a/sys/unix/Makefile.top~    2003-10-06 22:00:18.000000000 -0700
 
22
+++ b/sys/unix/Makefile.top     2003-10-06 22:00:55.000000000 -0700
 
23
@@ -40,7 +40,7 @@
 
24
 SHELLDIR = $(PREFIX)/games
 
25
 
 
26
 # per discussion in Install.X11 and Install.Qt
 
27
-VARDATND = 
 
28
+# VARDATND = 
 
29
 # VARDATND = x11tiles NetHack.ad pet_mark.xbm
 
30
 # VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
 
31
 # for Atari/Gem
 
32
@@ -48,7 +48,7 @@
 
33
 # for BeOS
 
34
 # VARDATND = beostiles
 
35
 # for Gnome
 
36
-# VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
 
37
+VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
 
38
 
 
39
 VARDATD = data oracles options quest.dat rumors
 
40
 VARDAT = $(VARDATD) $(VARDATND)