~ubuntu-branches/ubuntu/intrepid/plplot/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/50_check-for-octave2.1.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rafael Laboissiere
  • Date: 2006-11-04 10:19:34 UTC
  • mfrom: (2.1.8 edgy)
  • Revision ID: james.westby@ubuntu.com-20061104101934-mlirvdg4gpwi6i5q
Tags: 5.6.1-10
* Orphaning the package
* debian/control: Changed the maintainer to the Debian QA Group

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 50_check-for-octave2.1.dpatch by Rafael Laboissiere <rafael@debian.org>
 
3
##
 
4
## DP: Abort toggle_plplot_use if not using Octave 2.1
 
5
 
 
6
@DPATCH@
 
7
 
 
8
--- plplot-5.6.0.rc1.5.6.1.orig/bindings/octave/PLplot/toggle_plplot_use.m
 
9
+++ plplot-5.6.0.rc1.5.6.1/bindings/octave/PLplot/toggle_plplot_use.m
 
10
@@ -20,6 +20,11 @@
 
11
 
 
12
 1;
 
13
 
 
14
+## Abort if not using Octave 2.1
 
15
+if (split (version , '.') (1, 1) != '2' || split (version , '.') (2, 1) != '1')
 
16
+  error ("This version of octave-plplot only works with Octave 2.1\n");
 
17
+endif
 
18
+
 
19
 if ! exist ("use_plplot_state")
 
20
   global use_plplot_state
 
21
   use_plplot_state = "on";