~ubuntu-branches/ubuntu/intrepid/ruby1.9/intrepid-updates

« back to all changes in this revision

Viewing changes to debian/patches/904_linux_target_os.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2007-09-04 16:01:17 UTC
  • mfrom: (1.1.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20070904160117-i15zckg2nhxe9fyw
Tags: 1.9.0+20070830-2ubuntu1
* Sync from Debian; remaining changes:
  - Add -g to CFLAGS.
* Fixes build failure on ia64.
* Fixes build failure with gcc-4.2 on lpia.
* Robustify check for target_os, fixing build failure on lpia.
* Set Ubuntu maintainer address.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 904_linux_target_os.dpatch.dpatch by Matthias Klose <doko@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Robustify check for target_os
 
6
 
 
7
@DPATCH@
 
8
--- ./configure.in~     2007-09-04 17:20:41.000000000 +0200
 
9
+++ ./configure.in      2007-09-04 17:34:11.000000000 +0200
 
10
@@ -90,7 +90,7 @@
 
11
 fi
 
12
 
 
13
 AC_CANONICAL_TARGET
 
14
-target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnu/linux-/'`
 
15
+target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnulp$/linux/;s/linux-gnu/linux-/'`
 
16
 ac_install_sh='' # unusable for extension libraries.
 
17
 
 
18
 dnl checks for fat-binary