~ubuntu-branches/ubuntu/jaunty/awstats/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/02_redirect_to_STDERR.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard, Jonas Smedegaard, Charles Fry
  • Date: 2006-01-15 22:35:07 UTC
  • mfrom: (1.2.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20060115223507-jtn0gtvack1n8qj2
Tags: 6.5-1
[ Jonas Smedegaard ]
* New upstream release.
  + Recognizes GNUTLS from lynx User-Agent header. Closes: #306130
    (thanks to Dmitry Baryshkov <mitya@school.ioffe.ru>).
  + Geoip shows countries for resolved hostnames. Closes: #317310
    (thanks to Administrator <azhrarn@underhanded.org>).
* Simplify watch file to better work with parser used at qa.d.o.
* Improve cdbs rules:
  + Use quilt (rather than cdbs-internal patch system).
  + Add and enable new local snippets copyright-check and auto-update.
  + Update local snippet buildinfo (fixing its namespace).
* Auto-update debian/control:
  + Tightened build-dependency on cdbs.
  + Added build-dependencies on patchutils and quilt.
* Package is now team-maintained:
  + New maintainer: Debian AWStats Team
    <pkg-awstats-devel@lists.alioth.debian.org>.
  + Add myself as uploader.

[ Charles Fry ]
* Use qa.debian.org SF redirector in watch file.
* Use Homepage instead of Website in debian/control, per DDR 6.2.4.
* Removed patches integrated upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- awstats-6.4.orig/tools/awstats_buildstaticpages.pl
2
 
+++ awstats-6.4/tools/awstats_buildstaticpages.pl
3
 
@@ -75,7 +75,7 @@
4
 
 # Return:              None
5
 
 #------------------------------------------------------------------------------
6
 
 sub error {
7
 
-       print "Error: $_[0].\n";
8
 
+       print STDERR "Error: $_[0].\n";
9
 
     exit 1;
10
 
 }
11
 
 
12
 
@@ -95,7 +95,7 @@
13
 
 #              print "$messagestring<br>\n";
14
 
 #      }
15
 
 #      else {
16
 
-               print "$messagestring\n";
17
 
+               print STDERR "$messagestring\n";
18
 
 #      }
19
 
 #      }
20
 
 }
21
 
--- awstats-6.4.orig/tools/awstats_configure.pl
22
 
+++ awstats-6.4/tools/awstats_configure.pl
23
 
@@ -87,7 +87,7 @@
24
 
 # error
25
 
 #-------------------------------------------------------
26
 
 sub error {
27
 
-       print "Error: $_[0].\n";
28
 
+       print STDERR "Error: $_[0].\n";
29
 
     exit 1;
30
 
 }
31
 
 
32
 
--- awstats-6.4.orig/tools/awstats_exportlib.pl
33
 
+++ awstats-6.4/tools/awstats_exportlib.pl
34
 
@@ -93,8 +93,8 @@
35
 
        my $thirdmessage=shift||"";
36
 
        my $donotshowsetupinfo=shift||0;
37
 
        if ($Debug) { debug("$message $secondmessage $thirdmessage",1); }
38
 
-       print "$message";
39
 
-       print "\n";
40
 
+       print STDERR "$message";
41
 
+       print STDERR "\n";
42
 
        exit 1;
43
 
 }
44
 
 
45
 
--- awstats-6.4.orig/tools/awstats_updateall.pl
46
 
+++ awstats-6.4/tools/awstats_updateall.pl
47
 
@@ -36,7 +36,7 @@
48
 
 # Return:              None
49
 
 #------------------------------------------------------------------------------
50
 
 sub error {
51
 
-       print "Error: $_[0].\n";
52
 
+       print STDERR "Error: $_[0].\n";
53
 
     exit 1;
54
 
 }
55
 
 
56
 
--- awstats-6.4.orig/tools/logresolvemerge.pl
57
 
+++ awstats-6.4/tools/logresolvemerge.pl
58
 
@@ -96,7 +96,7 @@
59
 
 # Return:              None
60
 
 #------------------------------------------------------------------------------
61
 
 sub error {
62
 
-       print "Error: $_[0].\n";
63
 
+       print STDERR "Error: $_[0].\n";
64
 
     exit 1;
65
 
 }
66
 
 
67
 
@@ -125,7 +125,7 @@
68
 
 sub warning {
69
 
        my $messagestring=shift;
70
 
        if ($Debug) { debug("$messagestring",1); }
71
 
-       print "$messagestring\n";
72
 
+       print STDERR "$messagestring\n";
73
 
 }
74
 
 
75
 
 #-----------------------------------------------------------------------------
76
 
--- awstats-6.4.orig/tools/maillogconvert.pl
77
 
+++ awstats-6.4/tools/maillogconvert.pl
78
 
@@ -56,7 +56,7 @@
79
 
 #-------------------------------------------------------
80
 
 
81
 
 sub error {
82
 
-       print "Error: $_[0].\n";
83
 
+       print STDERR "Error: $_[0].\n";
84
 
     exit 1;
85
 
 }
86