~ubuntu-branches/ubuntu/jaunty/awstats/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/1002_redirect_to_STDERR.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard, Charles Fry, Jonas Smedegaard
  • Date: 2006-05-09 23:10:43 UTC
  • Revision ID: james.westby@ubuntu.com-20060509231043-1anmscca1fvenh8u
Tags: 6.5-2
[ Charles Fry ]
* Require AWSTATS_ENABLE_CONFIG_DIR environmental variable in order to
  enable configdir. Closes: #365910 (thanks to Hendrik Weimer
  <hendrik@enyo.de>)
* Integrated security patches from upstream:
  + Decode QueryString. Closes: #364443 (thanks to Micah Anderson
    <micah@debian.org>)
  + Sanitize migrate parameter. Closes: #365909 (thanks to Hendrik Weimer
    <hendrik@enyo.de>)
* Indent Homepage in long description, per debian reference guideline

[ Jonas Smedegaard ]
* Update local cdbs snippet copyright-check.mk:
  + Broaden scan to also look for "(c)" by default.
  + Make egrep options configurable.
* Semi-auto-update debian/control:
  + Bump up versioned build-dependency on debhelper.
* Semi-auto-update debian/copyright_hints (nothing remarkable).
* Set urgency=high as this upload fixes security-related bugs
  (bug#365909: CVE-2006-2237).
* Fix including a couple of example shell scripts ignored by mistake.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -urNad awstats~/tools/awstats_buildstaticpages.pl awstats/tools/awstats_buildstaticpages.pl
2
 
--- awstats~/tools/awstats_buildstaticpages.pl  2005-08-23 15:56:35.000000000 -0400
3
 
+++ awstats/tools/awstats_buildstaticpages.pl   2006-01-04 00:58:20.490613529 -0500
4
 
@@ -75,7 +75,7 @@
5
 
 # Return:              None
6
 
 #------------------------------------------------------------------------------
7
 
 sub error {
8
 
-       print "Error: $_[0].\n";
9
 
+       print STDERR "Error: $_[0].\n";
10
 
     exit 1;
11
 
 }
12
 
 
13
 
@@ -95,7 +95,7 @@
14
 
 #              print "$messagestring<br />\n";
15
 
 #      }
16
 
 #      else {
17
 
-               print "$messagestring\n";
18
 
+               print STDERR "$messagestring\n";
19
 
 #      }
20
 
 #      }
21
 
 }
22
 
diff -urNad awstats~/tools/awstats_configure.pl awstats/tools/awstats_configure.pl
23
 
--- awstats~/tools/awstats_configure.pl 2005-04-22 13:34:05.000000000 -0400
24
 
+++ awstats/tools/awstats_configure.pl  2006-01-04 00:58:24.987002812 -0500
25
 
@@ -87,7 +87,7 @@
26
 
 # error
27
 
 #-------------------------------------------------------
28
 
 sub error {
29
 
-       print "Error: $_[0].\n";
30
 
+       print STDERR "Error: $_[0].\n";
31
 
     exit 1;
32
 
 }
33
 
 
34
 
diff -urNad awstats~/tools/awstats_exportlib.pl awstats/tools/awstats_exportlib.pl
35
 
--- awstats~/tools/awstats_exportlib.pl 2003-12-05 18:53:38.000000000 -0500
36
 
+++ awstats/tools/awstats_exportlib.pl  2006-01-04 00:58:30.769217454 -0500
37
 
@@ -93,8 +93,8 @@
38
 
        my $thirdmessage=shift||"";
39
 
        my $donotshowsetupinfo=shift||0;
40
 
        if ($Debug) { debug("$message $secondmessage $thirdmessage",1); }
41
 
-       print "$message";
42
 
-       print "\n";
43
 
+       print STDERR "$message";
44
 
+       print STDERR "\n";
45
 
        exit 1;
46
 
 }
47
 
 
48
 
diff -urNad awstats~/tools/awstats_updateall.pl awstats/tools/awstats_updateall.pl
49
 
--- awstats~/tools/awstats_updateall.pl 2005-04-22 13:34:05.000000000 -0400
50
 
+++ awstats/tools/awstats_updateall.pl  2006-01-04 00:58:34.910654953 -0500
51
 
@@ -36,7 +36,7 @@
52
 
 # Return:              None
53
 
 #------------------------------------------------------------------------------
54
 
 sub error {
55
 
-       print "Error: $_[0].\n";
56
 
+       print STDERR "Error: $_[0].\n";
57
 
     exit 1;
58
 
 }
59
 
 
60
 
diff -urNad awstats~/tools/logresolvemerge.pl awstats/tools/logresolvemerge.pl
61
 
--- awstats~/tools/logresolvemerge.pl   2005-12-04 16:10:46.000000000 -0500
62
 
+++ awstats/tools/logresolvemerge.pl    2006-01-04 00:58:38.552160356 -0500
63
 
@@ -104,7 +104,7 @@
64
 
 # Return:              None
65
 
 #------------------------------------------------------------------------------
66
 
 sub error {
67
 
-       print "Error: $_[0].\n";
68
 
+       print STDERR "Error: $_[0].\n";
69
 
     exit 1;
70
 
 }
71
 
 
72
 
@@ -133,7 +133,7 @@
73
 
 sub warning {
74
 
        my $messagestring=shift;
75
 
        if ($Debug) { debug("$messagestring",1); }
76
 
-       print "$messagestring\n";
77
 
+       print STDERR "$messagestring\n";
78
 
 }
79
 
 
80
 
 #-----------------------------------------------------------------------------
81
 
diff -urNad awstats~/tools/maillogconvert.pl awstats/tools/maillogconvert.pl
82
 
--- awstats~/tools/maillogconvert.pl    2005-04-22 13:34:05.000000000 -0400
83
 
+++ awstats/tools/maillogconvert.pl     2006-01-04 00:58:42.465628823 -0500
84
 
@@ -56,7 +56,7 @@
85
 
 #-------------------------------------------------------
86
 
 
87
 
 sub error {
88
 
-       print "Error: $_[0].\n";
89
 
+       print STDERR "Error: $_[0].\n";
90
 
     exit 1;
91
 
 }
92