~ubuntu-branches/ubuntu/jaunty/firefox-3.5/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_no_app_updates.patch

  • Committer: Bazaar Package Importer
  • Author(s): Fabien Tassin
  • Date: 2009-03-30 19:00:40 UTC
  • Revision ID: james.westby@ubuntu.com-20090330190040-bi1fyb3vw34x1030
Tags: 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
* New upstream snapshot, needed to initiate the firefox 3.1->3.5 transition (LP: #352995)
* Add libstartup-notification0-dev to build-deps as it now seems to be
  mandatory on lpia
  - update debian/control
* Fix the mozclient include to really use the local configuration
  - update debian/rules
* Update MOZCLIENT_GETDATE to make it use pushlog so it is not confused by merges with
  dates in the past
  - update debian/mozclient/firefox-3.5.conf

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
---
 
3
 browser/components/preferences/advanced.js |    8 +++-----
 
4
 1 file changed, 3 insertions(+), 5 deletions(-)
 
5
 
 
6
Index: mozilla/browser/components/preferences/advanced.js
 
7
===================================================================
 
8
--- mozilla.orig/browser/components/preferences/advanced.js
 
9
+++ mozilla/browser/components/preferences/advanced.js
 
10
@@ -382,50 +382,48 @@
 
11
   {
 
12
     var aus = 
 
13
         Components.classes["@mozilla.org/updates/update-service;1"].
 
14
         getService(Components.interfaces.nsIApplicationUpdateService);
 
15
 
 
16
     var enabledPref = document.getElementById("app.update.enabled");
 
17
     var enableAppUpdate = document.getElementById("enableAppUpdate");
 
18
 
 
19
-    enableAppUpdate.disabled = !aus.canUpdate || enabledPref.locked;
 
20
+    enableAppUpdate.disabled = true;
 
21
   },
 
22
 
 
23
   /**
 
24
    * Enables/disables UI for "when updates are found" based on the values,
 
25
    * and "locked" states of associated preferences.
 
26
    */
 
27
   updateAutoItems: function () 
 
28
   {
 
29
     var enabledPref = document.getElementById("app.update.enabled");
 
30
     var autoPref = document.getElementById("app.update.auto");
 
31
     
 
32
     var updateModeLabel = document.getElementById("updateModeLabel");
 
33
     var updateMode = document.getElementById("updateMode");
 
34
     
 
35
-    var disable = enabledPref.locked || !enabledPref.value ||
 
36
-                  autoPref.locked;
 
37
+    var disable = true;
 
38
     updateModeLabel.disabled = updateMode.disabled = disable;
 
39
   },
 
40
 
 
41
   /**
 
42
    * Enables/disables the "warn if incompatible extensions/themes exist" UI
 
43
    * based on the values and "locked" states of various preferences.
 
44
    */
 
45
   updateModeItems: function () 
 
46
   {
 
47
     var enabledPref = document.getElementById("app.update.enabled");
 
48
     var autoPref = document.getElementById("app.update.auto");
 
49
     var modePref = document.getElementById("app.update.mode");
 
50
     
 
51
     var warnIncompatible = document.getElementById("warnIncompatible");
 
52
     
 
53
-    var disable = enabledPref.locked || !enabledPref.value || autoPref.locked ||
 
54
-                  !autoPref.value || modePref.locked;
 
55
+    var disable = true;
 
56
     warnIncompatible.disabled = disable;
 
57
   },
 
58
 
 
59
   /**
 
60
    * Stores the value of the app.update.mode preference, which is a tristate
 
61
    * integer preference.  We store the value here so that we can properly
 
62
    * restore the preference value if the UI reflecting the preference value
 
63
    * is in a state which can represent either of two integer values (as