~ubuntu-branches/ubuntu/jaunty/gnome-do-plugins/jaunty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/00_dfsg_autofoo.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane, Daniel T Chen, Iain Lane
  • Date: 2009-03-18 00:40:51 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20090318004051-ujn1ja3kiu3ky7ru
Tags: 0.8.1.3+dfsg-0ubuntu1
[ Daniel T Chen ]
* New upstream release (LP: #344578)
  + Banshee plugin goes crazy if banshee isn't loaded first
    (LP: #289802)
  + gnome-do gCalculate plugin fails to display "times" symbol
    (LP: #274252)
  + Banshee-1 fails to build in Mono 2.0 (LP: #309188)
  + Pidgin 2.5.4 has incompatible dbus interface. s/uint/int/
    (LP: #314927)
  + Pidgin plugin hangs opening a chat if pidgin is unresponsive
    (LP: #315565)
  + twitter plugin still reports friend updates even when
    deactivated (LP: #317674)
  + Misspelling in microblogging plugin confirmation message
    (LP: #319433)
  + make install uses mdtool, but configure doesn't check for it
    (LP: #322951)
  + Virtualbox Icon in 2.10 are broken because of a new
    specification (LP: #323902)
  + Google Maps Plugin shouldn't always use route (LP: #324271)
  + Fix for Google Maps when using newlines and other special
    characters (LP: #324667)
  + VirtualBox failed to load icon (LP: #325712)
  + 'Read Man Pages' plugin makes Gnome-Do unresponsive
    (LP: #325935)
  + Search returns broken URLs (LP: #327855)
  + Default action for SSH hosts is "open" (LP: #328236)
  + Files and Folders Configuration doesn't use standard buttons
    (LP: #328236)
  + Window manager maximize action should focus if window is not
    currently focused (LP: #258893)
  + Locate plugin has no error message (LP: #262360)
  + Wishlist: Let user specify files and folders to ignore
    (LP: #263177)
  + ts-client plugin doesn't index subdirectories (LP: #322352)
  + Max 3000 items in Files and Folders plugin (LP: #324105)
  + putty cannot find host when running from gnome do
    (LP: #324282)
  + locate plugin with globbing (LP: #334798)
  + Twitter plugin encountered an error in UpdateFriends
    (LP: #317575)
  + gnome-terminal profiles no longer work (LP: #321977)
  + Creating a task using Remember the Milk plugin can fail if
    no task list is specified (LP: #324066)
  + bundled libraries makefile needs destdir (LP: #324704)
  + Typographical error in del.icio.us plugin (LP: #330525)
  + ImageShack fails to upload (LP: #337324)
* debian/copyright
  + Refresh for new upstream version; new plugins added.
* debian/patches/00_dfsg_autofoo.dpatch
  + Update for new upstream version
  + Don't build the YouTube plugin due to removal of shipped
    exes and dlls causing FTBFS
* debian/patches/02_ssh_respect_exec_arg.dpatch
  debian/patches/03_buildsystem_respect_mcs.dpatch
  debian/patches/04_fix_pidgin_dbus_ints.dpatch
  + Drop; fixed upstream

[ Iain Lane ]
* debian/rules: Update repackaging to not delete *.dll; upstream now ships
  source copies of google-gdata meaning we can now enable the Google and
  Youtube plugins.
* debian/patches/00_dfsg_autofoo: Drop, fixed by including and building
  these libs now. 
* debian/copyright: Update with information for google-gdata. 
* debian/patches/04_fix_pidgin_dbus_ints.dpatch: Add left out piece of patch
* debian/control: Bump gnome-do build-dep to require current version. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 00_dfsg_autofoo.dpatch by Christopher James Halse Rogers <raof@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Don't build plugins that depend on the binary DLLs that we strip from
6
 
## DP: the tarball.
7
 
 
8
 
@DPATCH@
9
 
diff -urNad gnome-do-plugins-0.8.0.2+dfsg~/BundledLibraries/Makefile.am gnome-do-plugins-0.8.0.2+dfsg/BundledLibraries/Makefile.am
10
 
--- gnome-do-plugins-0.8.0.2+dfsg~/BundledLibraries/Makefile.am 2009-02-05 11:11:42.000000000 +1100
11
 
+++ gnome-do-plugins-0.8.0.2+dfsg/BundledLibraries/Makefile.am  2009-02-17 11:09:34.002731510 +1100
12
 
@@ -1,18 +1,12 @@
13
 
 bundledir = ${datadir}/gnome-do/plugins
14
 
 
15
 
-GOOGLE_LIBS = \
16
 
-       Google.GData.AccessControl.dll \
17
 
-       Google.GData.Calendar.dll \
18
 
-       Google.GData.Client.dll \
19
 
-       Google.GData.Contacts.dll \
20
 
-       Google.GData.Documents.dll \
21
 
-       Google.GData.Extensions.dll 
22
 
+GOOGLE_LIBS =
23
 
 
24
 
 bundle_DATA = \
25
 
        $(addprefix $(srcdir)/,$(GOOGLE_LIBS)) \
26
 
        $(BANSHEE_INDEXER_DLL)
27
 
 
28
 
-EXTRA_DIST=$(GOOGLE_LIBS) gmcs.exe
29
 
+EXTRA_DIST=$(GOOGLE_LIBS)
30
 
 
31
 
 # Copy these to the build dir; some things require the dlls to be present
32
 
 # during build - particularly mautil.
33
 
diff -urNad gnome-do-plugins-0.8.0.2+dfsg~/Makefile.am gnome-do-plugins-0.8.0.2+dfsg/Makefile.am
34
 
--- gnome-do-plugins-0.8.0.2+dfsg~/Makefile.am  2009-02-05 11:10:20.000000000 +1100
35
 
+++ gnome-do-plugins-0.8.0.2+dfsg/Makefile.am   2009-02-17 11:08:37.061584246 +1100
36
 
@@ -25,9 +25,6 @@
37
 
        GNOME-Session \
38
 
        GNOME-Terminal \
39
 
        GoogleCalculator \
40
 
-       GoogleCalendar \
41
 
-       GoogleContacts \
42
 
-       GoogleDocs \
43
 
        GoogleMaps \
44
 
        GoogleSearch \
45
 
        ImageShack \
46
 
@@ -47,7 +44,6 @@
47
 
        Quote \
48
 
        RememberTheMilk \
49
 
        Rhythmbox \
50
 
-       Riptide \
51
 
        RSS \
52
 
        Shelf \
53
 
        Skype \
54
 
diff -urNad gnome-do-plugins-0.8.0.2+dfsg~/configure.ac gnome-do-plugins-0.8.0.2+dfsg/configure.ac
55
 
--- gnome-do-plugins-0.8.0.2+dfsg~/configure.ac 2009-02-05 11:35:53.000000000 +1100
56
 
+++ gnome-do-plugins-0.8.0.2+dfsg/configure.ac  2009-02-17 11:08:37.061584246 +1100
57
 
@@ -140,9 +140,6 @@
58
 
 GNOME-Session/Makefile
59
 
 GNOME-Terminal/Makefile
60
 
 GoogleCalculator/Makefile
61
 
-GoogleCalendar/Makefile
62
 
-GoogleContacts/Makefile
63
 
-GoogleDocs/Makefile
64
 
 GoogleMaps/Makefile
65
 
 GoogleSearch/Makefile
66
 
 ImageShack/Makefile
67
 
@@ -162,7 +159,6 @@
68
 
 Quote/Makefile
69
 
 RememberTheMilk/Makefile
70
 
 Rhythmbox/Makefile
71
 
-Riptide/Makefile
72
 
 RSS/Makefile
73
 
 Shelf/Makefile
74
 
 Skype/Makefile