~ubuntu-branches/ubuntu/jaunty/gravitywars/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/010_data_paths.diff

  • Committer: Bazaar Package Importer
  • Author(s): Sam Hocevar (Debian packages)
  • Date: 2006-05-16 03:57:51 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060516035751-dc9fuuhdeym8b0nv
Tags: 1.102-30
* Moved packaging to the Debian Games Team.
* Use quilt for patch management.
* debian/control:
  + Set policy to 3.7.2.
  + Build-depend on quilt.
  + Enhanced the long description and clarified that Gravity Wars is merely
    inspired by, not based on, Gravity Force, and that there is no longer
    an upstream website for it (Closes: #348278).
  + Removed deprecated suidmanager conflict.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: gravitywars-1.102/GravityWars101.c
 
2
===================================================================
 
3
--- gravitywars-1.102.orig/GravityWars101.c     2006-05-16 06:32:02.000000000 +0200
 
4
+++ gravitywars-1.102/GravityWars101.c  2006-05-16 06:34:01.000000000 +0200
 
5
@@ -59,27 +59,31 @@
 
6
   short baselevel;
 
7
   char filename[128];
 
8
   
 
9
-  char firstlevel[20]="levels/level01";
 
10
+  char firstlevel[80]="levels/level01";
 
11
   char buf[128];
 
12
-  
 
13
+
 
14
   levelnum=1;
 
15
   
 
16
   if (readlink(arg[0],buf,128)==-1) 
 
17
     strcpy(buf,arg[0]);
 
18
-  
 
19
+
 
20
+/*  
 
21
   n=strlen(buf);
 
22
   while(n>=0)                       
 
23
     if (buf[n--]=='/') break;
 
24
   if (n<0) {
 
25
-    strcpy(gamename,"./");
 
26
-    gamenamelen=2;
 
27
+    strcpy(gamename,"/");
 
28
+    gamenamelen=1;
 
29
   }  
 
30
   else {
 
31
     strcpy(gamename,buf);
 
32
     gamename[n+2]=0;
 
33
     gamenamelen=strlen(gamename);
 
34
   }
 
35
-  
 
36
+*/
 
37
+
 
38
+       strcpy(gamename,"/usr/share/games/gravitywars/");
 
39
+       gamenamelen=strlen(gamename);
 
40
 
 
41
   if (n_args>1) {
 
42
     n=0;