~ubuntu-branches/ubuntu/jaunty/mawk/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/06_parse.y-semicolons.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): James Troup
  • Date: 2003-05-30 15:24:50 UTC
  • Revision ID: james.westby@ubuntu.com-20030530152450-5ewsjdg0t4hu8c7q
Tags: 1.3.3-11
* 08_fix-for-gcc3.3.dpatch: grossly hack configure to work around
  gcc-3.3 providing a builtin log() function which broke the configure
  tests.  Thanks to Daniel Schepler <schepler@math.berkeley.edu> for the
  report.  Closes: #195371

* debian/control: add build-depends on gcc (>= 3:3.3-1) for hppa.
* debian/rules: remove de-optimization hack for hppa.  Thanks to LaMont
  Jones <lamont@smallone.fc.hp.com> and Matthias Klose
  <doko@cs.tu-berlin.de>.  Closes: #105816

* debian/control (Standards-Version): bump to 3.5.10.0.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 06_parse.y-semicolons.dpatch by Paul Eggert <eggert@twinsun.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fix missing semicolons in parse.y to keep recent versions of bison happy.
 
6
 
 
7
if [ $# -ne 1 ]; then
 
8
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
9
    exit 1
 
10
fi
 
11
case "$1" in
 
12
       -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
 
13
       -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
 
14
        *)
 
15
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
16
                exit 1;;
 
17
esac
 
18
 
 
19
exit 0
 
20
 
 
21
diff -urNad 06.mawk.tmp/parse.y 06.mawk/parse.y
 
22
--- 06.mawk.tmp/parse.y 1995-06-11 23:55:31.000000000 +0100
 
23
+++ 06.mawk/parse.y     2003-04-09 22:34:10.000000000 +0100
 
24
@@ -274,6 +274,7 @@
 
25
                        code1(_PUSHINT) ; code1(0) ;
 
26
                        code2(_PRINT, bi_print) ;
 
27
                      }
 
28
+       ;
 
29
 
 
30
 statement_list :  statement
 
31
         |  statement_list   statement
 
32
@@ -482,6 +483,7 @@
 
33
 /* an empty production to store the code_ptr */
 
34
 mark : /* empty */
 
35
          { $$ = code_offset ; }
 
36
+       ;
 
37
 
 
38
 /* print_statement */
 
39
 statement :  print mark pr_args pr_direction separator
 
40
@@ -540,6 +542,7 @@
 
41
                 { patch_jmp(code_ptr) ; 
 
42
                  patch_jmp(CDP($4)) ; 
 
43
                }
 
44
+       ;
 
45
 
 
46
 
 
47
 /*  LOOPS   */
 
48
@@ -883,7 +886,7 @@
 
49
                  } 
 
50
                }
 
51
              }
 
52
-                
 
53
+       ;                
 
54
 
 
55
 
 
56
 /* exit_statement */
 
57
@@ -892,12 +895,14 @@
 
58
                       code1(_EXIT0) ; }
 
59
                |  EXIT   expr  separator
 
60
                     { $$ = $2 ; code1(_EXIT) ; }
 
61
+       ;
 
62
 
 
63
 return_statement :  RETURN   separator
 
64
                     { $$ = code_offset ;
 
65
                       code1(_RET0) ; }
 
66
                |  RETURN   expr  separator
 
67
                     { $$ = $2 ; code1(_RET) ; }
 
68
+       ;
 
69
 
 
70
 /* getline */
 
71
 
 
72
@@ -931,7 +936,7 @@
 
73
           }
 
74
        ;
 
75
 
 
76
-getline :   GETLINE  { getline_flag = 1 ; }
 
77
+getline :   GETLINE  { getline_flag = 1 ; } ;
 
78
 
 
79
 fvalue  :   lvalue  |  field  ;
 
80