~ubuntu-branches/ubuntu/jaunty/monodevelop/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/nunit_2.4_port.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mirco Bauer
  • Date: 2008-08-09 20:31:49 UTC
  • mfrom: (1.1.10 lenny)
  • Revision ID: james.westby@ubuntu.com-20080809203149-vc61woqqhcc34e4a
Tags: 1.0+dfsg-3
* debian/control:
  + Removed libxul-dev from build-dependencies, as monodevelop is not using
    it anymore. (Closes: #480797)
  + Build against libmono-nunit2.2-cil instead of libnunit2.2.6-cil.
  + Added mono-2.0-devel to recommends and mono-1.0-devel to suggests, as
    monodevelop invokes resgen(2) and al(2) when needed for *.resx files.
    (Closes: #485797)
  + Updated debhelper build-dependency to >= 7.
  + Updated cli-common-dev build-dependency to >= 0.5.7
    (needed for cli.make)
* debian/patches/link_system_mono-nunit.dpatch:
  + Link against mono-nunit instead of bundled nunit.
* debian/rules:
  + Include /usr/share/cli-common/cli.make
  + Migrated to debhelper v7 minimalistic style.
* debian/compat:
  + Bumped to 7

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## nunit_2.4_port.dpatch by Mirco Bauer <meebey@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad monodevelop-1.0+dfsg~/src/addins/NUnit/Services/ExternalTestRunner.cs monodevelop-1.0+dfsg/src/addins/NUnit/Services/ExternalTestRunner.cs
 
9
--- monodevelop-1.0+dfsg~/src/addins/NUnit/Services/ExternalTestRunner.cs       2008-06-28 15:03:19.000000000 +0200
 
10
+++ monodevelop-1.0+dfsg/src/addins/NUnit/Services/ExternalTestRunner.cs        2008-06-28 15:03:19.000000000 +0200
 
11
@@ -36,6 +36,7 @@
 
12
 using MonoDevelop.Core;
 
13
 using MonoDevelop.Core.Execution;
 
14
 using NUnit.Core;
 
15
+using NUnit.Core.Filters;
 
16
 using NF = NUnit.Framework;
 
17
 
 
18
 namespace MonoDevelop.NUnit
 
19
@@ -47,7 +48,7 @@
 
20
                StringWriter stdout = new StringWriter ();
 
21
                StringWriter stderr = new StringWriter ();
 
22
                
 
23
-               public TestResult Run (EventListener listener, IFilter filter, string path, string suiteName)
 
24
+               public TestResult Run (EventListener listener, ITestFilter filter, string path, string suiteName)
 
25
                {
 
26
                        TestSuite rootTS = LoadTestSuite (path, suiteName);
 
27
                        if (rootTS == null)
 
28
@@ -180,11 +181,11 @@
 
29
                        get { return runningTest; }
 
30
                }
 
31
                
 
32
-               void EventListener.RunStarted (Test [] tests)
 
33
+               void EventListener.RunStarted (string name, int testCount)
 
34
                {
 
35
                }
 
36
 
 
37
-               void EventListener.RunFinished (TestResult [] results)
 
38
+               void EventListener.RunFinished (TestResult result)
 
39
                {
 
40
                }
 
41
 
 
42
@@ -196,12 +197,12 @@
 
43
                {
 
44
                }
 
45
 
 
46
-               void EventListener.TestStarted (TestCase testCase)
 
47
+               void EventListener.TestStarted (TestName testName)
 
48
                {
 
49
                        if (singleTestRun)
 
50
                                return;
 
51
                        
 
52
-                       UnitTest t = GetLocalTest (testCase);
 
53
+                       UnitTest t = GetLocalTest (testName);
 
54
                        if (t == null)
 
55
                                return;
 
56
                        
 
57
@@ -234,12 +235,12 @@
 
58
                        runningTest = null;
 
59
                }
 
60
 
 
61
-               void EventListener.SuiteStarted (TestSuite suite)
 
62
+               void EventListener.SuiteStarted (TestName testName)
 
63
                {
 
64
                        if (singleTestRun)
 
65
                                return;
 
66
                        
 
67
-                       UnitTest t = GetLocalTest (suite);
 
68
+                       UnitTest t = GetLocalTest (testName);
 
69
                        if (t == null)
 
70
                                return;
 
71
                        
 
72
diff -urNad monodevelop-1.0+dfsg~/src/addins/NUnit/Services/NUnitAssemblyTestSuite.cs monodevelop-1.0+dfsg/src/addins/NUnit/Services/NUnitAssemblyTestSuite.cs
 
73
--- monodevelop-1.0+dfsg~/src/addins/NUnit/Services/NUnitAssemblyTestSuite.cs   2008-06-28 15:03:19.000000000 +0200
 
74
+++ monodevelop-1.0+dfsg/src/addins/NUnit/Services/NUnitAssemblyTestSuite.cs    2008-06-28 15:03:19.000000000 +0200
 
75
@@ -37,6 +37,7 @@
 
76
 using MonoDevelop.Projects;
 
77
 using MonoDevelop.Core;
 
78
 using NUnit.Core;
 
79
+using NUnit.Core.Filters;
 
80
 
 
81
 namespace MonoDevelop.NUnit
 
82
 {
 
83
@@ -257,7 +258,7 @@
 
84
                        ExternalTestRunner runner = (ExternalTestRunner) Runtime.ProcessService.CreateExternalProcessObject (typeof(ExternalTestRunner), false);
 
85
                        LocalTestMonitor localMonitor = new LocalTestMonitor (testContext, runner, test, suiteName, testName != null);
 
86
                        
 
87
-                       IFilter filter = null;
 
88
+                       ITestFilter filter = null;
 
89
                        
 
90
                        if (testName != null) {
 
91
                                filter = new TestNameFilter (testName);
 
92
@@ -266,7 +267,10 @@
 
93
                                if (categoryOptions.EnableFilter && categoryOptions.Categories.Count > 0) {
 
94
                                        string[] cats = new string [categoryOptions.Categories.Count];
 
95
                                        categoryOptions.Categories.CopyTo (cats, 0);
 
96
-                                       filter = new CategoryFilter (cats, categoryOptions.Exclude);
 
97
+                                       filter = new CategoryFilter (cats);
 
98
+                                       if (categoryOptions.Exclude) {
 
99
+                                               filter = new NotFilter (filter);
 
100
+                                       }
 
101
                                }
 
102
                        }
 
103
                        
 
104
@@ -413,28 +417,32 @@
 
105
                }
 
106
                
 
107
                [Serializable]
 
108
-               public class TestNameFilter: IFilter
 
109
+               public class TestNameFilter: ITestFilter
 
110
                {
 
111
                        string name;
 
112
                        
 
113
+                       public bool IsEmpty {
 
114
+                               get { return false; }
 
115
+                       }
 
116
+
 
117
                        public TestNameFilter (string name)
 
118
                        {
 
119
                                this.name = name;
 
120
                        }
 
121
                        
 
122
-                       public bool Pass (TestSuite suite)
 
123
+                       public bool Pass (ITest test)
 
124
                        {
 
125
                                return true;
 
126
                        }
 
127
                        
 
128
-                       public bool Pass (TestCase test)
 
129
+                       public bool Pass (TestName test)
 
130
                        {
 
131
                                return test.Name == name;
 
132
                        }
 
133
 
 
134
-                       public bool Exclude
 
135
+                       public bool Match(ITest test)
 
136
                        {
 
137
-                               get { return false; }
 
138
+                               return true;
 
139
                        }
 
140
                }
 
141
        }