~ubuntu-branches/ubuntu/jaunty/ndiswrapper/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/modules-build.diff

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2008-11-21 14:17:35 UTC
  • mfrom: (1.2.11 upstream) (2.1.3 lenny)
  • Revision ID: james.westby@ubuntu.com-20081121141735-hzymcfoy3up8hego
Tags: 1.53-2ubuntu1
* Merge with Debian; remaining changes:
  - Build for lpia.
  - debian/control:
    + Update description to point out that the kernel source package is
      not required with the standard Ubuntu kernel.
    + Change the Maintainer address.
  - debian/control:
    + Drop ndiswrapper-source.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
(r2670) Sat Jul 12 02:12:23 2008 UTC by proski
 
2
 
 
3
Replace extra-y hacks with proper dependencies
 
4
 
 
5
Patch based on https://bugs.launchpad.net/ndiswrapper/+bug/241547
 
6
--- a/driver/Makefile   2008/05/28 03:30:28     2666
 
7
+++ b/driver/Makefile   2008/07/12 02:12:23     2670
 
8
@@ -139,7 +139,7 @@
 
9
 %_exports.h: %.c $(obj)/mkexport.sh FORCE
 
10
        $(call if_changed,mkexport)
 
11
 
 
12
-extra-y := $(EXPORTS)
 
13
+$(addprefix $(obj)/,$(EXPORTS:_exports.h=.o)): %.o: %_exports.h
 
14
 
 
15
 ifeq ($(CONFIG_X86_64),y)
 
16
 quiet_cmd_mkstubs = MKSTUBS $@
 
17
@@ -148,7 +148,7 @@
 
18
 $(obj)/win2lin_stubs.h: $(addprefix $(src)/,$(STUB_SRCS)) FORCE
 
19
        $(call if_changed,mkstubs)
 
20
 
 
21
-extra-y += win2lin_stubs.h
 
22
+$(obj)/win2lin_stubs.o: $(obj)/win2lin_stubs.h
 
23
 OBJS += win2lin_stubs.o
 
24
 else
 
25
 OBJS += divdi3.o
 
26