~ubuntu-branches/ubuntu/jaunty/pvm/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/20-fix-kfreebsd-ftbfs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steinar H. Gunderson
  • Date: 2008-07-02 23:16:11 UTC
  • mfrom: (4.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080702231611-1f29qb9o1o29771f
Tags: 3.4.5-11
In debian/rules, pick out the version number from the changelog instead of
from the current directory name; fixes FTBFS if the directory has been
renamed for some reason. Baed on patch from Simon McVittie and Peter Green.
(Closes: #483328)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: pvm-3.4.5/src/host.c
 
2
===================================================================
 
3
--- pvm-3.4.5.orig/src/host.c
 
4
+++ pvm-3.4.5/src/host.c
 
5
@@ -1005,7 +1005,11 @@ iflist(alp, np)
 
6
                }
 
7
                /* On some FreeBSD systems: */
 
8
                /* if (IFF_UP & req.ifr_flags) { */
 
9
+#ifdef __FreeBSD_kernel__
 
10
+               if (IFF_UP & req.ifr_flags) {
 
11
+#else          
 
12
                if (IFF_UP & req.ifr_ifru.ifru_flags) {
 
13
+#endif         
 
14
                        if (nip > 0 && !(nip % 10))
 
15
                                iplist = TREALLOC(iplist, (nip + 10), struct in_addr);
 
16
                        iplist[nip++] =