~ubuntu-branches/ubuntu/jaunty/python-docutils/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/14_distutils_setup.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Simon McVittie
  • Date: 2008-07-24 10:39:53 UTC
  • mfrom: (1.1.4 upstream) (3.1.7 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080724103953-8gh4uezg17g9ysgy
Tags: 0.5-2
* Upload docutils 0.5 to unstable
* Update rst.el to upstream Subversion r5596, which apparently fixes
  all its performance problems (17_speed_up_rst_el.dpatch, closes: #474941)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 14_distutils_setup.dpatch by Simon McVittie <smcv@ianadd.pseudorandom.co.uk>
 
2
## 14_distutils_setup.dpatch by Simon McVittie <smcv@debian.org>
3
3
##
4
4
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Split roman.py setup into a separate script
 
5
## DP: Package roman separately
6
6
 
7
7
@DPATCH@
8
 
diff -urNad docutils-0.4~/setup.py docutils-0.4/setup.py
9
 
--- docutils-0.4~/setup.py      2006-07-02 17:22:09.542140332 +0100
10
 
+++ docutils-0.4/setup.py       2006-07-02 17:22:10.018137952 +0100
11
 
@@ -23,9 +23,6 @@
 
8
 
 
9
From 203c8112ee6ad9c9fca788a9b065fa27224504c0 Mon Sep 17 00:00:00 2001
 
10
From: Simon McVittie <smcv@debian.org>
 
11
Date: Thu, 17 Jul 2008 11:22:01 +0100
 
12
Subject: [PATCH] [debian-specific?] Package roman separately
 
13
 
 
14
---
 
15
 setup.py       |   30 ++----------------------------
 
16
 setup_roman.py |   20 ++++++++++++++++++++
 
17
 2 files changed, 22 insertions(+), 28 deletions(-)
 
18
 create mode 100644 setup_roman.py
 
19
 
 
20
diff --git a/setup.py b/setup.py
 
21
index 1ce8763..f0af2e8 100755
 
22
--- a/setup.py
 
23
+++ b/setup.py
 
24
@@ -6,7 +6,7 @@ import sys
 
25
 import os
 
26
 import glob
 
27
 try:
 
28
-    from distutils.core import setup
 
29
+    from setuptools import setup
 
30
     from distutils.command.build_py import build_py
 
31
     from distutils.command.install_data import install_data
 
32
 except ImportError:
 
33
@@ -39,9 +39,6 @@ class smart_install_data(install_data):
12
34
 
13
35
 def do_setup():
14
36
     kwargs = package_data.copy()
17
39
-        kwargs['py_modules'] = extras
18
40
     if sys.hexversion >= 0x02030000:    # Python 2.3
19
41
         kwargs['classifiers'] = classifiers
20
 
     else:
21
 
@@ -53,7 +50,7 @@
22
 
     'author_email': 'goodger@users.sourceforge.net',
 
42
         # Install data files properly.  Note that we use a different
 
43
@@ -77,7 +74,7 @@ what-you-see-is-what-you-get plaintext markup syntax.""", # wrap at col 60
 
44
     'author_email': 'goodger@python.org',
23
45
     'license': 'public domain, Python, BSD, GPL (see COPYING.txt)',
24
46
     'platforms': 'OS-independent',
25
47
-    'package_dir': {'docutils': 'docutils', '': 'extras'},
27
49
     'packages': ['docutils',
28
50
                  'docutils.languages',
29
51
                  'docutils.parsers',
30
 
@@ -84,6 +81,7 @@
31
 
                      ['docutils/writers/s5_html/themes/README.txt']),]
32
 
                    + s5_theme_files),
33
 
     'scripts' : ['tools/rst2html.py',
34
 
+                 'tools/rstpep2html.py',
35
 
                  'tools/rst2s5.py',
36
 
                  'tools/rst2latex.py',
37
 
                  'tools/rst2newlatex.py',
38
 
@@ -120,29 +118,6 @@
 
52
@@ -147,29 +144,6 @@ classifiers = [
39
53
 """Trove classifiers for the Distutils "register" command;
40
54
 Python 2.3 and up."""
41
55
 
65
79
 class dual_build_py(build_py):
66
80
 
67
81
     """
68
 
diff -urNad docutils-0.4~/setup_roman.py docutils-0.4/setup_roman.py
69
 
--- docutils-0.4~/setup_roman.py        2006-07-02 17:20:58.000000000 +0100
70
 
+++ docutils-0.4/setup_roman.py 2006-07-02 17:22:10.018137952 +0100
71
 
@@ -0,0 +1,21 @@
 
82
diff --git a/setup_roman.py b/setup_roman.py
 
83
new file mode 100644
 
84
index 0000000..d7cc28f
 
85
--- /dev/null
 
86
+++ b/setup_roman.py
 
87
@@ -0,0 +1,20 @@
72
88
+#!/usr/bin/python
73
 
+# $Id: setup.py,v 1.9 2002/12/12 02:45:53 goodger Exp $
74
89
+
75
90
+from distutils.core import setup
76
91
+
80
95
+          description = 'Python Roman-numbers library',
81
96
+          #long_description = '',
82
97
+          url = 'http://docutils.sourceforge.net/',
83
 
+          version = '0.2+',
 
98
+          version = '1.4',
84
99
+          author = 'Mark Pilgrim',
85
100
+          author_email = 'f8dy@diveintopython.org',
86
101
+          license = 'Python',
87
102
+          package_dir = {'': 'extras'},
88
 
+                 py_modules = ['roman'])
 
103
+          py_modules = ['roman'])
89
104
+    return dist
90
105
+
91
106
+if __name__ == '__main__' :
92
107
+    do_setup()
 
108
-- 
 
109
1.5.6.2
 
110