~ubuntu-branches/ubuntu/jaunty/quassel/jaunty-backports

« back to all changes in this revision

Viewing changes to debian/patches/quassel_10_fixing-memleak.patch

  • Committer: Bazaar Package Importer
  • Author(s): Harald Sitter
  • Date: 2008-11-17 15:22:46 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20081117152246-3lwlpnr4r08910kv
Tags: 0.3.1-0ubuntu1
* New upstream release (LP: #271403)
* Drop all patches originated from upstream (quassel_*)
* Compile with non-builtin quassel icons
  + Introduce new quassel-data package
  + quassel and quassel-client depend on quassel-data
  + Don't manually enforce icon installation for desktop files in debian/rules
  + Add quassel_01_fix_iconloader.patch
* Drop perl build dependency, I have no clue why it was added in the first
  place. Neither changelog nor Bazaar knows, and since quassel compiles just
  fine without it, removing it should be save.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: quassel-0.3.0/src/qtui/chatlinemodelitem.cpp
2
 
===================================================================
3
 
--- quassel-0.3.0.orig/src/qtui/chatlinemodelitem.cpp   2008-09-11 08:34:48.236452200 +0200
4
 
+++ quassel-0.3.0/src/qtui/chatlinemodelitem.cpp        2008-09-11 08:34:54.072896193 +0200
5
 
@@ -59,6 +59,10 @@
6
 
   _contents.formatList = m.contents.formatList;
7
 
 }
8
 
 
9
 
+ChatLineModelItem::~ChatLineModelItem() {
10
 
+  delete _data;
11
 
+}
12
 
+
13
 
 QVariant ChatLineModelItem::data(int column, int role) const {
14
 
   const ChatLinePart *part = 0;
15
 
 
16
 
Index: quassel-0.3.0/src/qtui/chatlinemodelitem.h
17
 
===================================================================
18
 
--- quassel-0.3.0.orig/src/qtui/chatlinemodelitem.h     2008-09-11 08:34:48.268450779 +0200
19
 
+++ quassel-0.3.0/src/qtui/chatlinemodelitem.h  2008-09-11 08:34:54.072896193 +0200
20
 
@@ -31,7 +31,7 @@
21
 
 class ChatLineModelItem : public MessageModelItem {
22
 
 public:
23
 
   ChatLineModelItem(const Message &);
24
 
-
25
 
+  ~ChatLineModelItem();
26
 
   virtual QVariant data(int column, int role) const;
27
 
   virtual inline bool setData(int column, const QVariant &value, int role) { Q_UNUSED(column); Q_UNUSED(value); Q_UNUSED(role); return false; }
28