~ubuntu-branches/ubuntu/jaunty/quassel/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/quassel_07_Bring-back-the-workaround-to-not-reserve-space-for-t.patch

  • Committer: Bazaar Package Importer
  • Author(s): Harald Sitter
  • Date: 2008-11-17 15:22:46 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20081117152246-3lwlpnr4r08910kv
Tags: 0.3.1-0ubuntu1
* New upstream release (LP: #271403)
* Drop all patches originated from upstream (quassel_*)
* Compile with non-builtin quassel icons
  + Introduce new quassel-data package
  + quassel and quassel-client depend on quassel-data
  + Don't manually enforce icon installation for desktop files in debian/rules
  + Add quassel_01_fix_iconloader.patch
* Drop perl build dependency, I have no clue why it was added in the first
  place. Neither changelog nor Bazaar knows, and since quassel compiles just
  fine without it, removing it should be save.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: quassel-0.3.0/src/qtui/chatview.cpp
2
 
===================================================================
3
 
--- quassel-0.3.0.orig/src/qtui/chatview.cpp    2008-09-01 15:00:38.707838950 +0200
4
 
+++ quassel-0.3.0/src/qtui/chatview.cpp 2008-09-01 15:00:56.742362245 +0200
5
 
@@ -50,7 +50,7 @@
6
 
   setAlignment(Qt::AlignBottom);
7
 
   setInteractive(true);
8
 
 
9
 
-  _scene = new ChatScene(filter, filter->idString(), viewport()->width(), this);
10
 
+  _scene = new ChatScene(filter, filter->idString(), viewport()->width() - 2, this); // see below: resizeEvent()
11
 
   connect(_scene, SIGNAL(sceneHeightChanged(qreal)), this, SLOT(sceneHeightChanged(qreal)));
12
 
   setScene(_scene);
13
 
 
14
 
@@ -59,9 +59,8 @@
15
 
 }
16
 
 
17
 
 void ChatView::resizeEvent(QResizeEvent *event) {
18
 
-//   scene()->setWidth(event->size().width() - 2);  // FIXME figure out why we have to hardcode the -2 here
19
 
   QGraphicsView::resizeEvent(event);
20
 
-  scene()->setWidth(viewport()->width());
21
 
+  scene()->setWidth(viewport()->width() - 2);  // FIXME figure out why we have to hardcode the -2 here -> Qt-Bug most probably
22
 
   verticalScrollBar()->setValue(verticalScrollBar()->maximum());
23
 
 }
24