~ubuntu-branches/ubuntu/jaunty/thunderbird/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/bz399589_fix_missing_symbol_with_new_nss.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack
  • Date: 2008-02-27 13:19:09 UTC
  • mfrom: (1.2.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20080227131909-pg79o71vhbynkxdt
Tags: 2.0.0.14+nobinonly-0ubuntu1
* 2.0.0.14 security/stability update (USN-605-1)
* don't force gcc/g++ 4.2 as compiler anymore (4.3 is now in intrepid)
  and drop the versioned build-depends accordingly.
  - update debian/rules
  - update debian/control
* drop patches applied upstream:
  - delete debian/patches/bz399589_fix_missing_symbol_with_new_nss.patch
  - update debian/patches/series

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
---
2
 
 security/manager/ssl/src/nsKeygenHandler.cpp |   19 +++++++++----------
3
 
 1 file changed, 9 insertions(+), 10 deletions(-)
4
 
 
5
 
# Fix a FTBFS with new system libnss. See Mozilla bug 399589
6
 
# by Fabien Tassin <fta@sofaraway.org>
7
 
 
8
 
Index: seamonkey-1.1.4/security/manager/ssl/src/nsKeygenHandler.cpp
9
 
===================================================================
10
 
--- seamonkey-1.1.4.orig/security/manager/ssl/src/nsKeygenHandler.cpp
11
 
+++ seamonkey-1.1.4/security/manager/ssl/src/nsKeygenHandler.cpp
12
 
@@ -70,16 +70,25 @@
13
 
 
14
 
 //All possible key size choices.
15
 
 static SECKeySizeChoiceInfo SECKeySizeChoiceList[] = {
16
 
     { nsnull, 2048 },
17
 
     { nsnull, 1024 },
18
 
     { nsnull, 0 }, 
19
 
 };
20
 
 
21
 
+DERTemplate SECAlgorithmIDTemplate[] = {
22
 
+    { DER_SEQUENCE,
23
 
+         0, NULL, sizeof(SECAlgorithmID) },
24
 
+    { DER_OBJECT_ID,
25
 
+         offsetof(SECAlgorithmID,algorithm), },
26
 
+    { DER_OPTIONAL | DER_ANY,
27
 
+         offsetof(SECAlgorithmID,parameters), },
28
 
+    { 0, }
29
 
+};
30
 
 
31
 
 DERTemplate CERTSubjectPublicKeyInfoTemplate[] = {
32
 
     { DER_SEQUENCE,
33
 
           0, nsnull, sizeof(CERTSubjectPublicKeyInfo) },
34
 
     { DER_INLINE,
35
 
           offsetof(CERTSubjectPublicKeyInfo,algorithm),
36
 
           SECAlgorithmIDTemplate, },
37
 
     { DER_BIT_STRING,
38
 
@@ -90,26 +99,16 @@
39
 
 DERTemplate CERTPublicKeyAndChallengeTemplate[] =
40
 
 {
41
 
     { DER_SEQUENCE, 0, nsnull, sizeof(CERTPublicKeyAndChallenge) },
42
 
     { DER_ANY, offsetof(CERTPublicKeyAndChallenge,spki), },
43
 
     { DER_IA5_STRING, offsetof(CERTPublicKeyAndChallenge,challenge), },
44
 
     { 0, }
45
 
 };
46
 
 
47
 
-DERTemplate SECAlgorithmIDTemplate[] = {
48
 
-    { DER_SEQUENCE,
49
 
-         0, NULL, sizeof(SECAlgorithmID) },
50
 
-    { DER_OBJECT_ID,
51
 
-         offsetof(SECAlgorithmID,algorithm), },
52
 
-    { DER_OPTIONAL | DER_ANY,
53
 
-         offsetof(SECAlgorithmID,parameters), },
54
 
-    { 0, }
55
 
-};
56
 
-
57
 
 const SEC_ASN1Template SECKEY_PQGParamsTemplate[] = {
58
 
     { SEC_ASN1_SEQUENCE, 0, NULL, sizeof(PQGParams) },
59
 
     { SEC_ASN1_INTEGER, offsetof(PQGParams,prime) },
60
 
     { SEC_ASN1_INTEGER, offsetof(PQGParams,subPrime) },
61
 
     { SEC_ASN1_INTEGER, offsetof(PQGParams,base) },
62
 
     { 0, }
63
 
 };
64