~ubuntu-branches/ubuntu/jaunty/trousers/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/01_makefiles.diff

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Baumann
  • Date: 2008-01-23 22:03:00 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20080123220300-fhtqja3c0oq0gp6z
Tags: 0.3.1-4
* Added patch from Aaron M. Ucko <ucko@debian.org> to allow trousers to
  build successfully on amd64, and presumably also other 64-bit
  architectures (Closes: #457400).
* Including udev rule for /dev/tpm from William Lima
  <wlima.amadeus@gmail.com> as suggested by David Smith <dds@google.com>
  (Closes: #459682).
* Added lintian overrides.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- trousers-0.2.9.1.orig/dist/Makefile.am      2007-04-18 16:53:28.000000000 -0300
2
 
+++ trousers-0.2.9.1/dist/Makefile.am   2007-04-18 16:58:17.000000000 -0300
3
 
@@ -1,15 +1,15 @@
4
 
 
5
 
 install: install-exec-hook
6
 
        if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
7
 
-       /bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf
8
 
+       #/bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf
9
 
        /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
10
 
 
11
 
 install-exec-hook:
12
 
-       /usr/sbin/groupadd tss || true
13
 
-       /usr/sbin/useradd -r tss -g tss || true
14
 
-       /bin/chown tss:tss ${DESTDIR}/@sbindir@/tcsd
15
 
+       #/usr/sbin/groupadd tss || true
16
 
+       #/usr/sbin/useradd -r tss -g tss || true
17
 
+       #/bin/chown tss:tss ${DESTDIR}/@sbindir@/tcsd
18
 
        /bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
19
 
-       /bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm
20
 
+       #/bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm
21
 
        /bin/chmod 0700 ${DESTDIR}/@localstatedir@/lib/tpm
22
 
 
23
 
 uninstall-hook:
24
 
--- trousers-0.2.9.1.orig/dist/Makefile.in      2007-04-18 16:53:28.000000000 -0300
25
 
+++ trousers-0.2.9.1/dist/Makefile.in   2007-04-18 16:59:06.000000000 -0300
26
 
@@ -326,15 +326,15 @@ uninstall-am: uninstall-info-am
27
 
 
28
 
 install: install-exec-hook
29
 
        if test ! -e ${DESTDIR}/@sysconfdir@/tcsd.conf; then mkdir -p ${DESTDIR}/@sysconfdir@ && cp tcsd.conf ${DESTDIR}/@sysconfdir@; fi
30
 
-       /bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf
31
 
+       #/bin/chown tss:tss ${DESTDIR}/@sysconfdir@/tcsd.conf
32
 
        /bin/chmod 0600 ${DESTDIR}/@sysconfdir@/tcsd.conf
33
 
 
34
 
 install-exec-hook:
35
 
-       /usr/sbin/groupadd tss || true
36
 
-       /usr/sbin/useradd -r tss -g tss || true
37
 
-       /bin/chown tss:tss ${DESTDIR}/@sbindir@/tcsd
38
 
+       #/usr/sbin/groupadd tss || true
39
 
+       #/usr/sbin/useradd -r tss -g tss || true
40
 
+       #/bin/chown tss:tss ${DESTDIR}/@sbindir@/tcsd
41
 
        /bin/sh -c 'if [ ! -e ${DESTDIR}/@localstatedir@/lib/tpm ];then mkdir -p ${DESTDIR}/@localstatedir@/lib/tpm; fi'
42
 
-       /bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm
43
 
+       #/bin/chown tss:tss ${DESTDIR}/@localstatedir@/lib/tpm
44
 
        /bin/chmod 0700 ${DESTDIR}/@localstatedir@/lib/tpm
45
 
 
46
 
 uninstall-hook: