~ubuntu-branches/ubuntu/jaunty/xulrunner-1.9.1/jaunty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bzXXX_fix_python_dom_pyxultest.patch

  • Committer: Bazaar Package Importer
  • Author(s): Fabien Tassin, Alexander Sack, Fabien Tassin
  • Date: 2009-01-21 20:17:32 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20090121201732-p451dvaazr24oi5y
Tags: 1.9.1~b3~hg20090117r22878+nobinonly-0ubuntu1
[ Alexander Sack ]
* don't version pkgconfig files; in turn conflict with xulrunner-1.9-dev
  package
  - update debian/control
  - delete debian/patches/install_pkgconfig_files_with_version.patch
  - update debian/patches/series
* upstream lockPref everywhere patch
  - rename debian/patches/bzXXX_deb469020_lockPref_everywhere.patch =>
      debian/patches/bz467738_att351145_lockPref_everywhere.patch
  - update debian/patches/series
* upstream xre part for debian sysplugin location
  - rename debian/patches/bzXXX_sysplugin_support_xre_part.patch =>
      debian/patches/bz467751_att351167_sysplugin_xre_part.patch
  - update debian/patches/series
* upstream patch to prevent loss of some user prefs on first start after
  upgrade
  - rename debian/patches/bzXXX-dont-reset-user-prefs-on-upgrade.patch =>
      debian/patches/bz467766_att351173-dont-reset-user-prefs-on-upgrade.patch
  - update debian/patches/series

[ Fabien Tassin ]
* Build the test suite according to the WANT_UNIT_TESTS variable and
  store the results into the xulrunner-1.9.1-testsuite package.
  - update debian/rules
  - update debian/control
  - udpate debian/xulrunner-1.9.1-dev.install
  - update debian/xulrunner-1.9.1.install
  - add debian/xulrunner-1.9.1-testsuite.install
  - add debian/xulrunner-1.9.1-testsuite-dev.install
* Fix test suite to avoid bashisms (breaking dash)
  - add debian/patches/bzXXX_fix_test_suite_bashisms.patch
  - update debian/patches/series
* Run make check at build time in a non fatal way for now
  - update debian/rules
* Bundle test results (_leaktest, _profile, _tests & tools/test-harness) into
  the -testsuite package as test-results.tar.gz
  - update debian/rules
* Temporarily disable some tests depending on UTF-8 at build time
  - add debian/patches/testsuite_skip_tests_depending_on_utf8.patch
  - update debian/patches/series
* Make the -dev package conflicts with xulrunner-1.9.2-dev as we now have
  unversionned pkgconfig files
  - update debian/control
* Fix permissions in the -dev package (LP: #303940)
  - update debian/rules
* As some files are only available on some arches, introduce a mechanism
  to create *.install.arch files dynamically allowing includes
  - update debian/rules
* Use a slightly shorter path in the install files to make the merge
  with the 1.9.2 branch easier
  - update debian/*.install, debian/*.install.*.pp
* Move header files from JIT to arch specific install files as they are not
  available on 64bit platforms
  - update debian/xulrunner-1.9.1-dev.install
  - add debian/xulrunner-1.9.1-dev.install.i386.pp
  - add debian/xulrunner-1.9.1-dev.install.lpia.pp
* Fix preinst script to better handle the /etc/gre.d clean-up
  - update debian/xulrunner-1.9.1.preinst.in
* Bump Standards-Version to 3.8.0
  - update debian/control
* Install missing files detected by 'compare'
  - update debian/xulrunner-1.9.1.install
* Move mozclient project files from mozilla-descripts to this package
  and update the upstream branch now that it has moved to 1.9.2
  - add debian/mozclient/xulrunner-1.9.1.conf
  - add debian/mozclient/xulrunner-1.9.1.mk
  - update debian/rules
* Add support for Python xpcom and dom. Fixes contributed by Alexander
  - update debian/rules
  - add debian/patches/bzXXX_fix_python_dom_hidden_symbols.patch
  - add debian/patches/bzXXX_fix_python_dom_pyxultest.patch
  - add debian/patches/bzXXX_fix_python_xpcom.patch
  - update debian/patches/series
* Update diverged patches:
  - update debian/patches/bz467766_att351173-dont-reset-user-prefs-on-upgrade.patch
  - update debian/patches/bzXXX_pc_honour_system_nspr_nss.patch
  - update debian/patches/system_path_launch_child.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
 extensions/python/dom/test/pyxultest/Makefile.in     |    3 +++
 
3
 extensions/python/dom/test/pyxultest/application.ini |    6 +++---
 
4
 2 files changed, 6 insertions(+), 3 deletions(-)
 
5
 
 
6
Index: mozilla/extensions/python/dom/test/pyxultest/Makefile.in
 
7
===================================================================
 
8
--- mozilla.orig/extensions/python/dom/test/pyxultest/Makefile.in
 
9
+++ mozilla/extensions/python/dom/test/pyxultest/Makefile.in
 
10
@@ -49,14 +49,17 @@
 
11
 
 
12
 ifdef MOZ_XULRUNNER
 
13
 XPI_NAME               = pyxultest
 
14
 # Do I really want these?
 
15
 #USE_EXTENSION_MANIFEST = 1
 
16
 #NO_JAR_AUTO_REG        = 1
 
17
 #INSTALL_EXTENSION_ID   = pyxultest@mozilla.org
 
18
 #XPI_PKGNAME            = pyxultest-$(MOZ_APP_VERSION)
 
19
+GRE_MILESTONE   = $(shell $(PYTHON) $(topsrcdir)/config/printconfigsetting.py $(LIBXUL_DIST)/bin/platform.ini Build Milestone)
 
20
+GRE_BUILDID     = $(shell $(PYTHON) $(topsrcdir)/config/printconfigsetting.py $(LIBXUL_DIST)/bin/platform.ini Build BuildID)
 
21
+DEFINES        += -DGRE_MILESTONE=$(GRE_MILESTONE) -DGRE_BUILDID=$(GRE_BUILDID)
 
22
 DIST_FILES      = application.ini
 
23
 endif
 
24
 
 
25
 PREF_JS_EXPORTS = $(srcdir)/pyxultest-prefs.js
 
26
 
 
27
 include $(topsrcdir)/config/rules.mk
 
28
Index: mozilla/extensions/python/dom/test/pyxultest/application.ini
 
29
===================================================================
 
30
--- mozilla.orig/extensions/python/dom/test/pyxultest/application.ini
 
31
+++ mozilla/extensions/python/dom/test/pyxultest/application.ini
 
32
@@ -10,26 +10,26 @@
 
33
 ; This field specifies your application's name.  This field is required.
 
34
 Name=pyxultest
 
35
 
 
36
 ; This field specifies your application's version.  This field is required.
 
37
 Version=1.0
 
38
 
 
39
 ; This field specifies your application's build ID (timestamp).  This field is
 
40
 ; required.
 
41
-BuildID=@BUILD_ID@
 
42
+BuildID=@GRE_BUILDID@
 
43
 
 
44
 ; This field specifies a compact copyright notice for your application.  This
 
45
 ; field is optional.
 
46
 Copyright=Copyright (c) 2006 Mozilla.org
 
47
 
 
48
 ; This ID is just an example.  Every XUL app ought to have it's own unique ID.
 
49
 ID={67da7954-ecd3-4153-be0f-1c02284296ce}
 
50
 
 
51
 [Gecko]
 
52
 ; This field is required.  It specifies the minimum Gecko version that this
 
53
 ; application requires.
 
54
-MinVersion=@MOZILLA_VERSION_U@
 
55
+MinVersion=@GRE_MILESTONE@
 
56
 
 
57
 ; This field is optional.  It specifies the maximum Gecko version that this
 
58
 ; application requires.  It should be specified if your application uses
 
59
 ; unfrozen interfaces.
 
60
-; MaxVersion=@MOZILLA_VERSION_U@
 
61
+; MaxVersion=@GRE_MILESTONE@