~ubuntu-branches/ubuntu/jaunty/xulrunner-1.9/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/bzr423334_att310581_leak_initparser.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack, Fabien Tassin, Alexander Sack
  • Date: 2008-07-18 17:36:30 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20080718173630-13ky1jpruf7z22l2
Tags: 1.9.0.1+build1+nobinonly-0ubuntu1
* LP: #247494 - new upstream stability/security release (v1.9.0.1 build1)
  - see USN-626-1

[ Fabien Tassin <fta@sofaraway.org>]
* Add a build-system for xulrunner application inside the SDK.
  mozilla-devscripts is able to make use of this
  - add debian/create-build-system.sh
  - update debian/rules
* Rename the ld.so.conf.d file to xulrunner-1.9.conf as it seems
  extension matters
  - update debian/rules
  - update debian/xulrunner-1.9.postinst
* Get DEB_MOZ_VERSION and DEB_MOZ_VERSION from changelog and make more use
  of variables to make the merge with the 1.9.1 branch easier
  - update debian/rules
  - update debian/xulrunner-1.9.postinst
  - update debian/xulrunner-1.9.postrm
* Make EM_TRANSLATION_VERSION follow upstream version now that strings are
  hard frozen and bump EM_TRANSLATION_MAX_VERSION to 1.9.0.*
  - update debian/rules

[ Alexander Sack <asac@ubuntu.com> ]
* borrow lockPref patch from debian xulrunner (Debbugs: #469020)
  - add debian/patches/bzXXX_deb469020_lockPref_everywhere.patch
  - update debian/patches/series
* Debian compatibility patch that is supposed to make xulrunner also
  consider /usr/lib/mozilla/plugins/ in sid as of xulrunner 1.9~rc2-4
  - add debian/patches/bzXXX_sysplugin_support.patch
  - update debian/patches/series
* prepatch fix for bmo: #120380 - 'needsterminal flag in mailcap
  must be respected'
  - add debian/patches/bz120380_att326044.patch
  - update debian/patches/series
* add xre part missed by debian for sysplugin support
  - add debian/patches/bzXXX_sysplugin_support_xre_part.patch
  - update debian/patches/series
* drop patches applied upstream
  - delete debian/patches/bz428848_att319775_fix_venkman_chrome_access.patch
  - update debian/patches/series
* housekeeping for debian/patches directory; remove obsolete patches from
  debian/patches/ and drop commented patches from series
  - delete debian/patches/bz384304_fix_recursive_symlinks.patch
  - delete debian/patches/bzr423334_att310581_leak_initparser.patch
  - debian/patches/drop_bz418016.patch
  - update debian/patches/series
* (disabled in intrepid) fix "jemalloc not enabled in --with-xul-sdk= builds": we
  fix this by building libjemalloc as a static lib and linking xulrunner-bin and
  xulrunner-stub against it.
  - add debian/patches/jemalloc_in_xul.patch
  - add debian/patches/jemalloc_static.patch
  - update debian/patches/series
  - update debian/rules
  - update debian/xulrunner-1.9.postinst
* link nss/nspr include directories to xulrunner-1.9 sdk in order to
  allow upstream extensions to be built against ubuntu xulrunner.
  - add debian/xulrunner-1.9-dev.links
* add empty xulrunner-dev package to ease sync/merge tasks for ubuntu
  by providing the package name used by debian.
  - update debian/control
* fix makefile style variable eval in xulrunner-1.9 prerm script and use
  proper sh'ish style
  - update debian/xulrunner-1.9.prerm
* add code/debug-support to disable -Bsymbolic-functions linkage - but keep
  it commented by default
  - update debian/rules
* hold back upgrade until firefox 3.0.1 is available; for that, we add a
  Breaks: firefox-3.0 (<< 3.0.1) to xulrunner-1.9 binary package 
  - update debian/control
* fix LP: #247132 - The Prism Refractor Extension (v0.2) causes file
  downloads to kill firefox 3; we fix this by introducing a NULL check
  in our bz368428 "XUL FastLoad cache corruption" patch
  - update debian/patches/bz368428_attachment_308130.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
---
2
 
 xulrunner/stub/nsXULStub.cpp |    5 ++++-
3
 
 1 file changed, 4 insertions(+), 1 deletion(-)
4
 
 
5
 
Index: mozilla/xulrunner/stub/nsXULStub.cpp
6
 
===================================================================
7
 
--- mozilla.orig/xulrunner/stub/nsXULStub.cpp
8
 
+++ mozilla/xulrunner/stub/nsXULStub.cpp
9
 
@@ -231,17 +231,20 @@
10
 
            iniPath);
11
 
 
12
 
   greFound = (access(greDir, R_OK) == 0);
13
 
 
14
 
   strncpy(lastSlash, "application.ini", sizeof(iniPath) - (lastSlash - iniPath));
15
 
 
16
 
 #endif
17
 
 
18
 
-  nsINIParser parser;
19
 
+  // Leak the INI parser intentionally, because it allocates memory using the
20
 
+  // libc malloc and, once we load libxul, would deallocate it using
21
 
+  // jemalloc free()
22
 
+  nsINIParser &parser = *new nsINIParser();
23
 
   rv = parser.Init(iniPath);
24
 
   if (NS_FAILED(rv)) {
25
 
     fprintf(stderr, "Could not read application.ini\n");
26
 
     return 1;
27
 
   }
28
 
 
29
 
   if (!greFound) {
30
 
     char minVersion[VERSION_MAXLEN];