~ubuntu-branches/ubuntu/karmic/agrep/karmic

« back to all changes in this revision

Viewing changes to debian/patches/02-manpage-hyphen.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jari Aalto
  • Date: 2008-10-20 17:52:00 UTC
  • Revision ID: james.westby@ubuntu.com-20081020175200-qpxy014g40y01pof
Tags: 4.17-7
* debian/debian-vars.mk:
  - Adjust MAKE_FLAGS check (FTBFS sparc; Closes: #502862).
* debian/patches/02-manpage-hyphen.dpatch:
  - New. Fix hyphens with \- (Lintian).
* debian/patches/03-manpage-fhs-dir-dict.dpatch:
  - New. Fix FHS /usr/share/dict/words (Lintian).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## /tmp/manpage-hyphen.patch.dpatch by  <jari.aalto@cante.net>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fix hyphens
 
6
 
 
7
@DPATCH@
 
8
 
 
9
diff --git a/agrep.1 b/agrep.1
 
10
index d1fba5f..0c17cc2 100644
 
11
--- a/agrep.1
 
12
+++ b/agrep.1
 
13
@@ -7,7 +7,7 @@ agrep \- search a file for a string or regular expression, with approximate matc
 
14
 .B \-#cdehiklnpstvwxBDGIS
 
15
 ]
 
16
 .I pattern 
 
17
-[ -f
 
18
+[ \-f
 
19
 .I patternfile 
 
20
 ]
 
21
 [
 
22
@@ -20,7 +20,7 @@ searches the input
 
23
 for records containing strings which either 
 
24
 \fIexactly\fP or \fIapproximately\fP match a pattern.  
 
25
 A record is by default a line, but it can be defined differently using
 
26
-the -d option (see below).
 
27
+the \-d option (see below).
 
28
 Normally, each record found is copied to the standard output.
 
29
 Approximate matching allows finding records that contain the pattern 
 
30
 with several errors including substitutions, insertions, and
 
31
@@ -28,7 +28,7 @@ deletions.
 
32
 For example, Massechusets matches Massachusetts with two errors
 
33
 (one substitution and one insertion).  Running 
 
34
 .B agrep
 
35
--2 Massechusets foo outputs all lines in foo containing any string with
 
36
+\-2 Massechusets foo outputs all lines in foo containing any string with
 
37
 at most 2 errors from Massechusets.
 
38
 .LP
 
39
 .B agrep 
 
40
@@ -46,7 +46,7 @@ Technical report #91-11, Department of Computer Science, University
 
41
 of Arizona, June 1991 (available by anonymous ftp from cs.arizona.edu
 
42
 in agrep/agrep.ps.1), and
 
43
 Wu and Manber,
 
44
-"Agrep -- A Fast Approximate Pattern Searching Tool",
 
45
+"Agrep \-\- A Fast Approximate Pattern Searching Tool",
 
46
 To appear in USENIX Conference 1992 January (available by anonymous ftp
 
47
 from cs.arizona.edu in agrep/agrep.ps.2).
 
48
 .LP
 
49
@@ -89,7 +89,7 @@ specifying the maximum number of errors
 
50
 permitted in finding the approximate matches (defaults to zero).
 
51
 Generally, each insertion, deletion, or substitution counts as one error.
 
52
 It is possible to adjust the relative cost of insertions,
 
53
-deletions and substitutions (see -I -D and -S options).
 
54
+deletions and substitutions (see \-I \-D and \-S options).
 
55
 .TP
 
56
 .B \-c
 
57
 Display only the count of matching records.
 
58
@@ -103,7 +103,7 @@ a line.
 
59
 a regular expression.
 
60
 Text between two \fIdelim\fP's, before the first \fIdelim\fP,
 
61
 and after the last \fIdelim\fP is considered as one record.
 
62
-For example, -d '$$' defines paragraphs as records and -d '^From\ '
 
63
+For example, \-d '$$' defines paragraphs as records and \-d '^From\ '
 
64
 defines mail messages as records.
 
65
 .B agrep
 
66
 matches each record separately.
 
67
@@ -135,14 +135,14 @@ Case-insensitive search \(em e.g., "A" and "a" are considered equivalent.
 
68
 .TP
 
69
 .B \-k
 
70
 No symbol in the pattern is treated as a meta character. 
 
71
-For example, agrep -k 'a(b|c)*d' foo will find  
 
72
+For example, agrep \-k 'a(b|c)*d' foo will find  
 
73
 the occurrences of a(b|c)*d in foo whereas agrep 'a(b|c)*d' foo
 
74
 will find substrings in foo that match the regular expression 'a(b|c)*d'.
 
75
 .TP
 
76
 .B \-l
 
77
 List only the files that contain a match.
 
78
 This option is useful for looking for files containing a certain pattern.
 
79
-For example, " agrep -l 'wonderful'  * " will list the names of those
 
80
+For example, " agrep \-l 'wonderful'  * " will list the names of those
 
81
 files in current directory that contain the word 'wonderful'.
 
82
 .TP
 
83
 .B \-n
 
84
@@ -179,7 +179,7 @@ characters.  The non-alphanumeric
 
85
 surround the match;  they cannot be counted as errors.
 
86
 For example, 
 
87
 .B agrep
 
88
--w -1 car will match cars, but not characters.
 
89
+\-w \-1 car will match cars, but not characters.
 
90
 .TP
 
91
 .B \-x
 
92
 The pattern must match the whole line.
 
93
@@ -289,37 +289,37 @@ or '|' is 4.
 
94
 .SH EXAMPLES
 
95
 .LP
 
96
 .TP
 
97
-agrep -2 -c ABCDEFG foo 
 
98
+agrep \-2 \-c ABCDEFG foo 
 
99
 gives the number of lines in file foo that contain ABCDEFG
 
100
 within two errors.
 
101
 .TP
 
102
-agrep -1 -D2 -S2 'ABCD#YZ' foo
 
103
+agrep \-1 \-D2 \-S2 'ABCD#YZ' foo
 
104
 outputs the lines containing ABCD followed, within arbitrary
 
105
 distance, by YZ, with up to one additional insertion
 
106
-(-D2 and -S2 make deletions and substitutions too "expensive").
 
107
+(\-D2 and \-S2 make deletions and substitutions too "expensive").
 
108
 .TP
 
109
-agrep -5 -p abcdefghij /usr/dict/words
 
110
+agrep \-5 \-p abcdefghij /usr/dict/words
 
111
 outputs the list of all words containing at least 5 of the first 10
 
112
 letters of the alphabet \fIin order\fR.  (Try it:  any list starting
 
113
 with academia and ending with sacrilegious must mean something!)
 
114
 .TP 
 
115
-agrep -1 'abc[0-9](de|fg)*[x-z]' foo
 
116
+agrep \-1 'abc[0-9](de|fg)*[x-z]' foo
 
117
 outputs the lines containing, within up to one error, the string
 
118
 that starts with abc followed by one digit, followed by zero or more
 
119
 repetitions of either de or fg, followed by either x, y, or z.
 
120
 .TP
 
121
-agrep -d '^From\ ' 'breakdown;internet' mbox
 
122
+agrep \-d '^From\ ' 'breakdown;internet' mbox
 
123
 outputs all mail messages (the pattern '^From\ ' separates mail messages
 
124
 in a mail file) that contain keywords 'breakdown' and 'internet'.
 
125
 .TP
 
126
-agrep -d '$$' -1 '<word1> <word2>' foo
 
127
+agrep \-d '$$' \-1 '<word1> <word2>' foo
 
128
 finds all paragraphs that contain word1 followed by word2 with one
 
129
 error in place of the blank.  
 
130
 In particular, if word1 is the last word in a line and word2
 
131
 is the first word in the next line, then the space will be
 
132
 substituted by a newline symbol and it will match.
 
133
 Thus, this is a way to overcome separation by a newline.
 
134
-Note that -d '$$' (or another delim which spans more than one line)
 
135
+Note that \-d '$$' (or another delim which spans more than one line)
 
136
 is necessary, because otherwise agrep searches
 
137
 only one line at a time.
 
138
 .TP