~ubuntu-branches/ubuntu/karmic/asterisk/karmic

« back to all changes in this revision

Viewing changes to debian/patches/bristuff/chan-capi

  • Committer: Bazaar Package Importer
  • Author(s): Faidon Liambotis, Tzafrir Cohen, Faidon Liambotis
  • Date: 2007-12-06 17:20:21 UTC
  • mfrom: (1.1.19 upstream)
  • Revision ID: james.westby@ubuntu.com-20071206172021-pd0wrjirz3os7hia
Tags: 1:1.4.15~dfsg-1
* New upstream release (Closes: #452054)
  - Fix a potential corrupt of voicemail.conf on simultaneous PIN updates
    (Closes: #353227)

[ Tzafrir Cohen ]
* Add some sample/reference config files as documentation.
* Provide asterisk-bristuff for upgrading from Etch.
* Move libc-client to not be last, so debian/backports/xorcom.etch would
  still work.

[ Faidon Liambotis ]
* Really enable the libcap/ToS functionality; the previous patch didn't
  enable the functionality, even though the code and the libcap.so
  dependency were there. (Closes: #454342)
* Fix a minor issue with init script's stop target when running with
  safe_asterisk.
* Add chan_vpb, adding support for VoiceTronix OpenSwitch and OpenLine
  cards. (Closes: #396499)
* Fix debian/watch by using a pkg-voip wrapper to avoid upstream's silly
  redirections. (Closes: #449706)
* Use DEBVERSION as asterisk's version string.
* Disable the MD5 build sum that breaks all out-of-tree plugins (duh!).
* Create /usr/local/share/asterisk/sounds to put all site-specific
  non-modifiable sounds.
* Add a note about bugs.debian.org to the banner.
* Add noload for res_config_* since loading them results in errors and
  doesn't provide any functionality.
* News entries were added but we never shipped the file; ship NEWS.Debian.
* Add an entry to NEWS.Debian warning users about app_voicemail_*.so
  (Closes: #452596)
* Provide options in /etc/default/asterisk for configuring safe_asterisk.
  (Closes: #381786)

[ Tzafrir Cohen ]
* Provide a custom sounds directory under /var/lib - user-modifieble at
  runtime and hence not under /usr. (Closes: #337209)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
--- /dev/null
2
 
+++ asterisk-1.4.8~dfsg/apps/app_capiCD.c
 
2
+++ b/apps/app_capiCD.c
3
3
@@ -0,0 +1,164 @@
4
4
+/*
5
5
+ * (CAPI*)
166
166
+
167
167
+AST_MODULE_INFO_STANDARD(ASTERISK_GPL_KEY, tdesc);
168
168
--- /dev/null
169
 
+++ asterisk-1.4.8~dfsg/apps/app_capiECT.c
 
169
+++ b/apps/app_capiECT.c
170
170
@@ -0,0 +1,214 @@
171
171
+/*
172
172
+ * (CAPI*)
383
383
+       return ASTERISK_GPL_KEY;
384
384
+}
385
385
--- /dev/null
386
 
+++ asterisk-1.4.8~dfsg/apps/app_capiNoES.c
 
386
+++ b/apps/app_capiNoES.c
387
387
@@ -0,0 +1,100 @@
388
388
+/*
389
389
+ * (CAPI*)
485
485
+{
486
486
+       return ASTERISK_GPL_KEY;
487
487
+}
488
 
--- asterisk-1.4.8~dfsg.orig/build_tools/menuselect-deps.in
489
 
+++ asterisk-1.4.8~dfsg/build_tools/menuselect-deps.in
 
488
--- a/build_tools/menuselect-deps.in
 
489
+++ b/build_tools/menuselect-deps.in
490
490
@@ -1,4 +1,5 @@
491
491
 ASOUND=@PBX_ALSA@
492
492
+CAPI=@PBX_CAPI@
494
494
 FREETDS=@PBX_FREETDS@
495
495
 GSM=@PBX_GSM@
496
496
--- /dev/null
497
 
+++ asterisk-1.4.8~dfsg/channels/chan_capi.c
 
497
+++ b/channels/chan_capi.c
498
498
@@ -0,0 +1,2888 @@
499
499
+/*
500
500
+ * (CAPI*)
3385
3385
+               .unload = unload_module,
3386
3386
+);
3387
3387
--- /dev/null
3388
 
+++ asterisk-1.4.8~dfsg/configs/capi.conf.sample
 
3388
+++ b/configs/capi.conf.sample
3389
3389
@@ -0,0 +1,44 @@
3390
3390
+;
3391
3391
+; CAPI config
3432
3432
+;controller=2
3433
3433
+;devices => 30
3434
3434
--- /dev/null
3435
 
+++ asterisk-1.4.8~dfsg/doc/README.chan_capi
 
3435
+++ b/doc/README.chan_capi
3436
3436
@@ -0,0 +1,146 @@
3437
3437
+(CAPI*) chan_capi a Common ISDN API 2.0 implementation for Asterisk
3438
3438
+(C) 2002, 2003, 2004, 2005 Junghanns.NET GmbH 
3581
3581
+
3582
3582
+
3583
3583
--- /dev/null
3584
 
+++ asterisk-1.4.8~dfsg/include/asterisk/chan_capi_app.h
 
3584
+++ b/include/asterisk/chan_capi_app.h
3585
3585
@@ -0,0 +1,30 @@
3586
3586
+/*
3587
3587
+ * (CAPI*)
3614
3614
+
3615
3615
+#endif
3616
3616
--- /dev/null
3617
 
+++ asterisk-1.4.8~dfsg/include/asterisk/chan_capi.h
 
3617
+++ b/include/asterisk/chan_capi.h
3618
3618
@@ -0,0 +1,276 @@
3619
3619
+/*
3620
3620
+ * (CAPI*)
3893
3893
+
3894
3894
+#endif
3895
3895
--- /dev/null
3896
 
+++ asterisk-1.4.8~dfsg/include/asterisk/xlaw.h
 
3896
+++ b/include/asterisk/xlaw.h
3897
3897
@@ -0,0 +1,1665 @@
3898
3898
+#ifndef _ASTERISK_XLAW_H
3899
3899
+#define _ASTERISK_XLAW_H
5560
5560
+#endif // CAPI_ULAW
5561
5561
+#endif
5562
5562
+
5563
 
--- asterisk-1.4.8~dfsg.orig/configure.ac
5564
 
+++ asterisk-1.4.8~dfsg/configure.ac
 
5563
--- a/configure.ac
 
5564
+++ b/configure.ac
5565
5565
@@ -171,6 +171,7 @@ AC_SUBST(AST_DEVMODE)
5566
5566
 # by the --with option name, to make things easier for the users :-)
5567
5567
 
5579
5579
 AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
5580
5580
 
5581
5581
 GSM_INTERNAL="yes"
5582
 
--- asterisk-1.4.8~dfsg.orig/configure
5583
 
+++ asterisk-1.4.8~dfsg/configure
 
5582
--- a/configure
 
5583
+++ b/configure
5584
5584
@@ -720,6 +720,9 @@ ALSA_LIB
5585
5585
 ALSA_INCLUDE
5586
5586
 ALSA_DIR