~ubuntu-branches/ubuntu/karmic/codelite/karmic

« back to all changes in this revision

Viewing changes to debian/patches/00_add-fPIC.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chow Loong Jin
  • Date: 2009-08-15 17:42:43 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20090815174243-nlb9ikgigbiybz12
Tags: 1.0.2893+dfsg-0ubuntu1
* debian/rules:
  + Tidy up get-orig-source rule
* debian/control:
  + Bump Standards-Version
  + Change Maintainer email address to @ubuntu.com
  + Drop cdbs build-dependency
* debian/copyright:
  + Update to DEP-5 format
* debian/patches/00_add-fPIC.patch:
  + Dropped, fix upstream
* Closes LP: #413992

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Add -fPIC to all invokations of gcc/g++ to fix FTBFS errors
2
 
Index: codelite-1.0.2759+dfsg/configure
3
 
===================================================================
4
 
--- codelite-1.0.2759+dfsg.orig/configure       2009-02-11 20:07:02.000000000 +0800
5
 
+++ codelite-1.0.2759+dfsg/configure    2009-02-11 20:17:53.000000000 +0800
6
 
@@ -16,14 +16,14 @@
7
 
 createVariables()
8
 
 {
9
 
        ## set the compiler name
10
 
-       compiler_name="g++ "
11
 
-       c_compiler_name="gcc "
12
 
+       compiler_name="g++ -fPIC "
13
 
+       c_compiler_name="gcc -fPIC "
14
 
        exe_name="Runtime/codelite"
15
 
        exe_name1="codelite"
16
 
        is_plugin=$1
17
 
        if [ "$is_64bit" = "yes" ]; then
18
 
-               compiler_name=${compiler_name}" -fPIC -DON_64_BIT "
19
 
-               c_compiler_name=${c_compiler_name}" -fPIC -DON_64_BIT "
20
 
+               compiler_name=${compiler_name}" -DON_64_BIT "
21
 
+               c_compiler_name=${c_compiler_name}" -DON_64_BIT "
22
 
        fi
23
 
 
24
 
        ## set the executable name