~ubuntu-branches/ubuntu/karmic/csound/karmic

« back to all changes in this revision

Viewing changes to debian/patches/1002-type-punning.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard
  • Date: 2008-06-21 23:12:05 UTC
  • mfrom: (3.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080621231205-3zn5a4jqvuy858j0
Tags: 1:5.08.0.dfsg2-8
Only warn about copyright-check.mk discoveries.  Closes: bug#487052.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
The swig generated files do not respect strict aliasing. Add flag to avoid
 
2
warnings and errors.
 
3
Index: csound-5.08.0.dfsg2/SConstruct
 
4
===================================================================
 
5
--- csound-5.08.0.dfsg2.orig/SConstruct 2008-05-09 22:05:36.000000000 -0400
 
6
+++ csound-5.08.0.dfsg2/SConstruct      2008-05-09 22:06:02.000000000 -0400
 
7
@@ -1072,6 +1072,7 @@
 
8
     if compilerGNU():
 
9
         # work around non-ANSI type punning in SWIG generated wrapper files
 
10
         env['CCFLAGS'].append('-fno-strict-aliasing')
 
11
+        env['CXXFLAGS'].append('-fno-strict-aliasing')
 
12
 
 
13
 def makePythonModule(env, targetName, srcs):
 
14
     if getPlatform() == 'darwin':
 
15
@@ -1223,6 +1224,7 @@
 
16
             csoundInterfacesEnvironment.Prepend(LIBS = pythonLibs)
 
17
         csoundInterfacesEnvironment.Append(CPPPATH = pythonIncludePath)
 
18
         csndPythonEnvironment = csoundInterfacesEnvironment.Copy()
 
19
+        fixCFlagsForSwig(csndPythonEnvironment)
 
20
         if getPlatform() == 'darwin':
 
21
             if commonEnvironment['dynamicCsoundLibrary'] == '1':
 
22
                 csndPythonEnvironment.Append(LIBS = ['_csnd'])