~ubuntu-branches/ubuntu/karmic/exmap/karmic

« back to all changes in this revision

Viewing changes to debian/patches/makefile_no_kernel.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Samuel Mimram
  • Date: 2006-07-07 08:30:12 UTC
  • Revision ID: james.westby@ubuntu.com-20060707083012-pqhuhi71rybcbh3k
Tags: 0.9-2
* Depend on linux-headers-2.6 | linux-source-2.6 instead of
  kernel-headers-2.6 | kernel-source-2.6, closes: #375256.
* Updated makefile_no_kernel.dpatch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## DP: Do not build the kernel module.
6
6
 
7
7
@DPATCH@
8
 
diff -urNad exmap-0.8.2~/Makefile exmap-0.8.2/Makefile
9
 
--- exmap-0.8.2~/Makefile       2006-05-22 11:12:53.000000000 +0000
10
 
+++ exmap-0.8.2/Makefile        2006-05-22 19:38:23.000000000 +0000
 
8
diff -urNad exmap-0.9~/Makefile exmap-0.9/Makefile
 
9
--- exmap-0.9~/Makefile 2006-07-07 08:28:07.000000000 +0000
 
10
+++ exmap-0.9/Makefile  2006-07-07 08:28:07.000000000 +0000
11
11
@@ -4,7 +4,7 @@
12
12
 
13
13
 # Note this is the build order, and reflects inter-subdir
17
17
 
18
18
 .PHONY: build clean test $(SUBDIRS)
19
19
 
20
 
diff -urNad exmap-0.8.2~/src/Makefile exmap-0.8.2/src/Makefile
21
 
--- exmap-0.8.2~/src/Makefile   2006-05-22 11:12:53.000000000 +0000
22
 
+++ exmap-0.8.2/src/Makefile    2006-05-22 19:38:06.000000000 +0000
23
 
@@ -1,7 +1,7 @@
 
20
diff -urNad exmap-0.9~/jutil/Makefile exmap-0.9/jutil/Makefile
 
21
--- exmap-0.9~/jutil/Makefile   2006-06-09 17:08:45.000000000 +0000
 
22
+++ exmap-0.9/jutil/Makefile    2006-07-07 08:28:38.000000000 +0000
 
23
@@ -15,7 +15,7 @@
 
24
 CXX=g++
 
25
 CXXFLAGS=-Wall -Werror -g -I.
 
26
 LD=g++
 
27
-LDFLAGS=-lpcre
 
28
+override LDFLAGS=-lpcre
 
29
 
 
30
 build: $(LIBS) $(EXES)
 
31
 
 
32
diff -urNad exmap-0.9~/src/Makefile exmap-0.9/src/Makefile
 
33
--- exmap-0.9~/src/Makefile     2006-07-07 08:28:07.000000000 +0000
 
34
+++ exmap-0.9/src/Makefile      2006-07-07 08:28:17.000000000 +0000
 
35
@@ -1,8 +1,8 @@
24
36
 CXX=g++
25
37
 LD=g++
26
38
 JUTILDIR=../jutil
27
39
-CXXFLAGS += `pkg-config --cflags gtkmm-2.4` -g -Wall -Werror -I$(JUTILDIR)
 
40
-LDFLAGS += `pkg-config --libs gtkmm-2.4` -lpcre -ljutil -L$(JUTILDIR)
28
41
+override CXXFLAGS += `pkg-config --cflags gtkmm-2.4` -g -Wall -I$(JUTILDIR)
29
 
 LDFLAGS += `pkg-config --libs gtkmm-2.4` -lpcre -ljutil -L$(JUTILDIR)
 
42
+override LDFLAGS += `pkg-config --libs gtkmm-2.4` -lpcre -ljutil -L$(JUTILDIR)
30
43
 
31
44
 #CXXFLAGS += -pg
 
45
 #LDFLAGS += -pg