~ubuntu-branches/ubuntu/karmic/frozen-bubble/karmic

« back to all changes in this revision

Viewing changes to debian/patches/nick-truncated-to-8-chars.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mario Bonino
  • Date: 2008-01-27 15:59:01 UTC
  • Revision ID: james.westby@ubuntu.com-20080127155901-skpa9n3j02emn8df
Tags: 2.1.0-2ubuntu2
* debian/rules, debian/control,
  debian/patches/00list:
  - added dpatch support
* debian/patches/fble_open_dialog.dpatch:
  - fixed level editor showing selected level (LP: #181933)
    (thanks to David Joham for the patch)
* debian/patches/nick-truncated-to-8-chars.dpatch:
  - included previous change

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## nick-truncated-to-8-chars.dpatch by Mario Bonino <mariobonino@ubuntu-it.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: In sanitize_nick, nick is truncated to 8 chars to avoid an error when starting a LAN server.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad frozen-bubble-2.1.0~/frozen-bubble frozen-bubble-2.1.0/frozen-bubble
 
9
--- frozen-bubble-2.1.0~/frozen-bubble  2008-01-26 12:10:53.000000000 +0100
 
10
+++ frozen-bubble-2.1.0/frozen-bubble   2008-01-26 12:11:13.000000000 +0100
 
11
@@ -3424,7 +3424,7 @@
 
12
 
 
13
 sub sanitize_nick {
 
14
     my ($nick) = @_;
 
15
-    $nick = substr($nick, 0, 10);
 
16
+    $nick = substr($nick, 0, 8);
 
17
     $nick =~ s/[^a-zA-Z0-9_-]//g;
 
18
     return $nick;
 
19
 }