~ubuntu-branches/ubuntu/karmic/gnome-power-manager/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/74-disable-quirks-reference.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2009-07-29 16:48:33 UTC
  • mfrom: (2.1.42 upstream)
  • Revision ID: james.westby@ubuntu.com-20090729164833-vyi35necqjjbu0oj
Tags: 2.27.2+git20090729-0ubuntu1
* Upgrade to current git (d585c3a4e5) to clean up our patch forest, drop
  DeviceKit in favor of gudev, and get the porting to the new PolicyKit-1
  API.
* 03-system-policy.patch, 07-bugreport-shebang.patch,
  25_sparc_char_to_int.patch, 22_xfce_desktop_files.patch,
  23_numlock_hotkey.patch: Committed upstream, drop.
* 09_lid_always_blanks.patch: Finally drop this (was already disabled
  before).
* Drop 26-notifications.patch. It was disabled before (due to not applying
  any more), and upstream fixed it in a better way.
* Drop 14_inhibit_tool.patch: This functionality moved to gnome-session.
* Add patch tag headers to our remaining patches and re-enumerate them.
* Disable 21_idle_key_removal.patch: It is unclear whether this is still
  actually an issue in the new world where we just read -evdev events
  instead of ACPI events from hal, is pretty hackish, and it potentially
  leads to dropping valid events.
* Update dependencies:
  - Drop libpolkit-* (not necessary with PK 1.0).
  - Drop libdevkit-gobject-dev (DeviceKit is not used any more).
  - Bump devicekit-power dependencies to >= 010 (which provides the backend
    porting to PK 1.0).
  - Add libpanel-applet2-dev, now required for new version.
* 01-disable-quirks-reference.patch: Drop original code patch, replace with
  changed default gconf value.
* Disable 02-notify-osd-support.patch for now, upstream rewrote the
  notification system and the patch needs to be re-done. See LP #406396.
* 03-remove-discharging-notify.patch: Adapt to new upstream version.
* debian/rules: gnome-power-cmd.sh is no more, drop installation.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-power-manager-2.27.2/src/gpm-notify.c
2
 
===================================================================
3
 
--- gnome-power-manager-2.27.2.orig/src/gpm-notify.c    2009-07-06 13:55:25.000000000 +0100
4
 
+++ gnome-power-manager-2.27.2/src/gpm-notify.c 2009-07-08 00:13:43.000000000 +0100
5
 
@@ -478,27 +478,6 @@
6
 
        gpm_notify_create (notify, title, msg, GPM_NOTIFY_TIMEOUT_NEVER, icon,
7
 
                           GPM_NOTIFY_URGENCY_CRITICAL);
8
 
 
9
 
-       /* add extra stuff */
10
 
-       notify->priv->do_not_show_gconf = GPM_CONF_NOTIFY_SLEEP_FAILED;
11
 
-       notify_notification_add_action  (notify->priv->libnotify,
12
 
-                                        "dont-show-again",
13
 
-                                        _("Do not show me this again"),
14
 
-                                        (NotifyActionCallback) notify_general_clicked_cb,
15
 
-                                        notify, NULL);
16
 
-
17
 
-       notify->priv->internet_url = g_strdup (QUIRK_WEBSITE);
18
 
-       /* Translator: Quirks refer to strange/weird/undocumented behaviour of
19
 
-        * hardware.  Because the manufacturers do not provide the necessary
20
 
-        * information for non-FOSS software support, it is up to the users to
21
 
-        * supply the info by following the procedures outlined in the "Quirks
22
 
-        * website" at http://people.freedesktop.org/~hughsient/quirk/.
23
 
-        */
24
 
-       notify_notification_add_action  (notify->priv->libnotify,
25
 
-                                        "visit-website",
26
 
-                                        _("Visit quirk website"),
27
 
-                                        (NotifyActionCallback) notify_general_clicked_cb,
28
 
-                                        notify, NULL);
29
 
-
30
 
        gpm_notify_show (notify);
31
 
        return TRUE;
32
 
 }