~ubuntu-branches/ubuntu/karmic/iaxmodem/karmic

« back to all changes in this revision

Viewing changes to debian/patches/10_replacement_spandsp_mmx_h.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Julien BLACHE
  • Date: 2006-06-12 17:49:03 UTC
  • Revision ID: james.westby@ubuntu.com-20060612174903-k5nzvmdzrcgzh1bn
Tags: 0.1.9.dfsg-1
* New upstream release.
* debian/patches/11_iax2_CORE-2006-0327.dpatch:
  + Removed; merged upstream.
* debian/patches/11_build_configure-stamp.dpatch:
  + Added; do not build libraries if configure-stamp exists (debian/rules
    takes care of that).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 10_replacement_spandsp_mmx_h.dpatch by  <jblache@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Replacement mmx.h header for spandsp; disables SSE2 and MMX.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad iaxmodem-0.1.1~/lib/spandsp/src/spandsp/mmx.h iaxmodem-0.1.1/lib/spandsp/src/spandsp/mmx.h
 
9
--- iaxmodem-0.1.1~/lib/spandsp/src/spandsp/mmx.h       1970-01-01 01:00:00.000000000 +0100
 
10
+++ iaxmodem-0.1.1/lib/spandsp/src/spandsp/mmx.h        2006-03-19 22:48:27.284526866 +0100
 
11
@@ -0,0 +1,14 @@
 
12
+/*
 
13
+ * Dummy mmx.h file for spandsp for Debian.
 
14
+ *
 
15
+ * GPL'd, fwiw.
 
16
+ */
 
17
+
 
18
+#ifndef __SPANDSP_MMX_H__
 
19
+#define __SPANDSP_MMX_H__
 
20
+
 
21
+/* disable MMX and SSE2 ... */
 
22
+#undef USE_MMX
 
23
+#undef USE_SSE2
 
24
+
 
25
+#endif /* !__SPANDSP_MMX_H__ */