~ubuntu-branches/ubuntu/karmic/labyrinth/karmic

« back to all changes in this revision

Viewing changes to debian/patches/missing-thought-fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Holbach
  • Date: 2008-03-06 12:44:21 UTC
  • Revision ID: james.westby@ubuntu.com-20080306124421-2381q2n61ovgedv4
Tags: 0.3-0ubuntu4
* debian/patches/missing-thought-fix.patch: thanks Luca Falavigna and Martin
  Schaaf for raising the issue and figuring out the upstream fix at
  http://code.google.com/p/labyrinth/issues/detail?id=69 (LP: #156451)
* debian/control: moved Homepage into its own section, bumped
  Standards-Version.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nur -x '*.orig' -x '*~' labyrinth-0.3/src/MMapArea.py labyrinth-0.3.new/src/MMapArea.py
 
2
--- labyrinth-0.3/src/MMapArea.py       2006-11-13 17:18:12.000000000 +0100
 
3
+++ labyrinth-0.3.new/src/MMapArea.py   2008-03-06 12:44:09.000000000 +0100
 
4
@@ -759,7 +759,8 @@
 
5
                                        child = t
 
6
                                if parent and child:
 
7
                                        break
 
8
-                       l.set_parent_child (parent, child)
 
9
+                       if parent is not None:
 
10
+                               l.set_parent_child (parent, child)
 
11
                        if not l.parent or not l.child:
 
12
                                del_links.append (l)
 
13
                for l in del_links: