~ubuntu-branches/ubuntu/karmic/libcairo-ruby/karmic

« back to all changes in this revision

Viewing changes to debian/patches/01_fix-st.h-ruby1.9-paths.diff

  • Committer: Bazaar Package Importer
  • Author(s): Paul van Tilburg, Gunnar Wolf, Paul van Tilburg
  • Date: 2009-05-05 12:14:31 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20090505121431-n803uyjz51je38l0
Tags: 1.8.0-1
[ Gunnar Wolf ]
* Changed section to Ruby as per ftp-masters' request

[ Paul van Tilburg ]
* New upstream release.
* debian/patches:
  - Dropped patch 01_fix-st.h-ruby1.9-paths: fixed by upstream. 
* debian/control:
  - Bumped standards version to 3.8.1; no changes required.
  - Added ${misc:Depends} to the depends of libcairo-ruby (binary).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Hi,
2
 
 
3
 
In <20080801130838.GA7296@power.luon.net>
4
 
  "Re: 2 rcairo issues" on Fri, 1 Aug 2008 15:08:38 +0200,
5
 
  Paul van Tilburg <paulvt@debian.org> wrote:
6
 
 
7
 
> My question is:  is this an error in extconf.rb or mkmf.rb, or is st.h
8
 
> in our ruby1.9 setup incorrectly installed (and shouldn't it have been
9
 
> put under a ruby/ subdir) or is this all a new convention and do we need
10
 
> to work around it in the code?
11
 
 
12
 
No. st.h should be installed in ruby/ sub directory since
13
 
1.9.
14
 
 
15
 
I've fixed it in HEAD.
16
 
 
17
 
Here is a patch:
18
 
 
19
 
Index: extconf.rb
20
 
===================================================================
21
 
RCS file: /cvs/cairo/rcairo/extconf.rb,v
22
 
retrieving revision 1.22
23
 
retrieving revision 1.23
24
 
diff -u -p -r1.22 -r1.23
25
 
--- extconf.rb  12 Jun 2008 14:28:35 -0000      1.22
26
 
+++ extconf.rb  2 Aug 2008 01:29:07 -0000       1.23
27
 
@@ -80,6 +80,7 @@ major, minor, micro = 1, 2, 0
28
 
 
29
 
 PKGConfig.have_package(pkg, major, minor, micro) or exit 1
30
 
 
31
 
+have_header("ruby/st.h") unless have_macro("HAVE_RUBY_ST_H", "ruby.h")
32
 
 have_func("rb_errinfo", "ruby.h")
33
 
 have_type("enum ruby_value_type", "ruby.h")
34
 
 
35
 
Index: src/rb_cairo_surface.c
36
 
===================================================================
37
 
RCS file: /cvs/cairo/rcairo/src/rb_cairo_surface.c,v
38
 
retrieving revision 1.36
39
 
retrieving revision 1.37
40
 
diff -u -p -r1.36 -r1.37
41
 
--- src/rb_cairo_surface.c      20 Jun 2008 02:01:53 -0000      1.36
42
 
+++ src/rb_cairo_surface.c      2 Aug 2008 01:29:08 -0000       1.37
43
 
@@ -3,7 +3,7 @@
44
 
  * Ruby Cairo Binding
45
 
  *
46
 
  * $Author: kou $
47
 
- * $Date: 2008-06-20 02:01:53 $
48
 
+ * $Date: 2008-08-02 01:29:08 $
49
 
  *
50
 
  * Copyright 2005 �yvind Kol�s <pippin@freedesktop.org>
51
 
  * Copyright 2004-2005 MenTaLguY <mental@rydia.com>
52
 
@@ -15,7 +15,11 @@
53
 
 #include "rb_cairo.h"
54
 
 #include "rb_cairo_private.h"
55
 
 
56
 
-#include <st.h>
57
 
+#ifdef HAVE_RUBY_ST_H
58
 
+#  include <ruby/st.h>
59
 
+#else
60
 
+#  include <st.h>
61
 
+#endif
62
 
 
63
 
 #ifdef CAIRO_HAS_WIN32_SURFACE
64
 
 #  define OpenFile OpenFile_win32
65
 
 
66
 
 
67
 
Thanks,
68
 
--
69
 
kou
70