~ubuntu-branches/ubuntu/karmic/libsdl1.2/karmic

« back to all changes in this revision

Viewing changes to debian/patches/020_libcaca_new_api.diff

  • Committer: Bazaar Package Importer
  • Author(s): Steve Kowalik
  • Date: 2008-01-05 14:10:45 UTC
  • mfrom: (1.1.7 upstream)
  • Revision ID: james.westby@ubuntu.com-20080105141045-letjq81gx5olnxre
Tags: 1.2.13-1ubuntu1
* Merge from Debian unstable.
* Remaining Ubuntu changes:
  - Remove svgalib support.
  - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
  - Build for lpia as for i386.
  - Link using -Wl,-Bsymbolic-functions.
  - Munge Maintainer field as per spec.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- libsdl1.2-1.2.12.orig/configure.in
2
 
+++ libsdl1.2-1.2.12/configure.in
3
 
@@ -1432,6 +1432,38 @@
 
1
Index: libsdl1.2-1.2.13/configure.in
 
2
===================================================================
 
3
--- libsdl1.2-1.2.13.orig/configure.in  2008-01-02 03:19:59.000000000 +0100
 
4
+++ libsdl1.2-1.2.13/configure.in       2008-01-02 03:45:14.000000000 +0100
 
5
@@ -1428,6 +1428,38 @@
4
6
     fi
5
7
 }
6
8
 
39
41
 dnl Set up the QTopia video driver if enabled
40
42
 CheckQtopia()
41
43
 {
42
 
@@ -2253,6 +2285,7 @@
 
44
@@ -2249,6 +2281,7 @@
43
45
         CheckVGL
44
46
         CheckWscons
45
47
         CheckAAlib
47
49
         CheckQtopia
48
50
         CheckPicoGUI
49
51
         CheckOpenGLX11
50
 
--- libsdl1.2-1.2.12.orig/src/video/SDL_video.c
51
 
+++ libsdl1.2-1.2.12/src/video/SDL_video.c
 
52
Index: libsdl1.2-1.2.13/src/video/SDL_video.c
 
53
===================================================================
 
54
--- libsdl1.2-1.2.13.orig/src/video/SDL_video.c 2007-12-31 05:48:14.000000000 +0100
 
55
+++ libsdl1.2-1.2.13/src/video/SDL_video.c      2008-01-02 03:19:59.000000000 +0100
52
56
@@ -120,6 +120,9 @@
53
57
 #if SDL_VIDEO_DRIVER_AALIB
54
58
        &AALIB_bootstrap,
59
63
 #if SDL_VIDEO_DRIVER_DUMMY
60
64
        &DUMMY_bootstrap,
61
65
 #endif
62
 
--- libsdl1.2-1.2.12.orig/src/video/SDL_sysvideo.h
63
 
+++ libsdl1.2-1.2.12/src/video/SDL_sysvideo.h
 
66
Index: libsdl1.2-1.2.13/src/video/SDL_sysvideo.h
 
67
===================================================================
 
68
--- libsdl1.2-1.2.13.orig/src/video/SDL_sysvideo.h      2007-12-31 05:48:14.000000000 +0100
 
69
+++ libsdl1.2-1.2.13/src/video/SDL_sysvideo.h   2008-01-02 03:19:59.000000000 +0100
64
70
@@ -404,6 +404,9 @@
65
71
 #if SDL_VIDEO_DRIVER_AALIB
66
72
 extern VideoBootStrap AALIB_bootstrap;
71
77
 #if SDL_VIDEO_DRIVER_DUMMY
72
78
 extern VideoBootStrap DUMMY_bootstrap;
73
79
 #endif
74
 
--- libsdl1.2-1.2.12.orig/src/video/caca/SDL_cacaevents_c.h
75
 
+++ libsdl1.2-1.2.12/src/video/caca/SDL_cacaevents_c.h
 
80
Index: libsdl1.2-1.2.13/src/video/caca/SDL_cacaevents_c.h
 
81
===================================================================
 
82
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
83
+++ libsdl1.2-1.2.13/src/video/caca/SDL_cacaevents_c.h  2008-01-02 03:19:59.000000000 +0100
76
84
@@ -0,0 +1,35 @@
77
85
+/*
78
86
+    SDL - Simple DirectMedia Layer
109
117
+extern void Caca_PumpEvents(_THIS);
110
118
+extern void Caca_InitOSKeymap(_THIS);
111
119
+
112
 
--- libsdl1.2-1.2.12.orig/src/video/caca/SDL_cacaevents.c
113
 
+++ libsdl1.2-1.2.12/src/video/caca/SDL_cacaevents.c
 
120
Index: libsdl1.2-1.2.13/src/video/caca/SDL_cacaevents.c
 
121
===================================================================
 
122
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
123
+++ libsdl1.2-1.2.13/src/video/caca/SDL_cacaevents.c    2008-01-02 03:19:59.000000000 +0100
114
124
@@ -0,0 +1,101 @@
115
125
+/*
116
126
+    SDL - Simple DirectMedia Layer
213
223
+}
214
224
+
215
225
+
216
 
--- libsdl1.2-1.2.12.orig/src/video/caca/SDL_cacavideo.h
217
 
+++ libsdl1.2-1.2.12/src/video/caca/SDL_cacavideo.h
 
226
Index: libsdl1.2-1.2.13/src/video/caca/SDL_cacavideo.h
 
227
===================================================================
 
228
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
229
+++ libsdl1.2-1.2.13/src/video/caca/SDL_cacavideo.h     2008-01-02 03:19:59.000000000 +0100
218
230
@@ -0,0 +1,76 @@
219
231
+/*
220
232
+    SDL - Simple DirectMedia Layer
292
304
+
293
305
+#endif /* _SDL_cacavideo_h */
294
306
+
295
 
--- libsdl1.2-1.2.12.orig/src/video/caca/SDL_cacavideo.c
296
 
+++ libsdl1.2-1.2.12/src/video/caca/SDL_cacavideo.c
 
307
Index: libsdl1.2-1.2.13/src/video/caca/SDL_cacavideo.c
 
308
===================================================================
 
309
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
310
+++ libsdl1.2-1.2.13/src/video/caca/SDL_cacavideo.c     2008-01-02 03:19:59.000000000 +0100
297
311
@@ -0,0 +1,304 @@
298
312
+/*
299
313
+    SDL - Simple DirectMedia Layer
599
613
+       SDL_DestroyMutex(Caca_mutex);
600
614
+}
601
615
+
602
 
--- libsdl1.2-1.2.12.orig/include/SDL_config.h.in
603
 
+++ libsdl1.2-1.2.12/include/SDL_config.h.in
 
616
Index: libsdl1.2-1.2.13/include/SDL_config.h.in
 
617
===================================================================
 
618
--- libsdl1.2-1.2.13.orig/include/SDL_config.h.in       2008-01-02 03:19:45.000000000 +0100
 
619
+++ libsdl1.2-1.2.13/include/SDL_config.h.in    2008-01-02 03:19:59.000000000 +0100
604
620
@@ -252,6 +252,7 @@
605
621
 /* Enable various video drivers */
606
622
 #undef SDL_VIDEO_DRIVER_AALIB