~ubuntu-branches/ubuntu/karmic/lightning-sunbird/karmic

« back to all changes in this revision

Viewing changes to debian/patches/18_arm_xpcom_unused_attribute.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): John Vivirito, John Vivirito
  • Date: 2009-08-21 10:57:02 UTC
  • Revision ID: james.westby@ubuntu.com-20090821105702-o3rcdj86jhq8e655
Tags: 0.9+nobinonly-0ubuntu3
[ John Vivirito ]
* Fixes (LP: #178785)
  - debian/rules: Added build option --enable-official-branding to build with official branding 
  - debian/patches: Removed deb299697-lp42559-use-FC_ANY_METRICS.patch to fix build errors
  - debian/patches: Updated series
* Fixes (LP: #399400)
  - debian/rules: Removed the convert icon section
  - debian/sunbird.links: Adjusted link to use the 128 icon
* Fixes (LP: #401165)
  - debian/control: Removed GCC and GCC++ from build-deps
  - debian/rules: Commented out GCC and GCC++ lines to build using default
  - debian/patches: Added ftbfs_gcc44_elif.patch to fix FTBFS
  - debian/patches/series: Updated
* Fixes (LP: #385325) crash in JS due to usage of wrong floating point number$
  - debian/patches: Added bz322806_arm-vfp-2538:3f78d5e894bc
  - debian/patches/series: Updated
* Fixes (LP: #378754)
  - debian/control: Fixed typo in calendar-google-provider description.
* Fixes (LP: #358084): add arm(el) xpcom patches from thunderbird package
  - add debian/patches/18_arm_xpcom_unused_attribute.dpatch
  - add debian/patches/38_arm_xpcom_optim.dpatch
  - add debian/patches/bz339782_cvs_xptcinvoke_arm_backport_1.13.patch
  - update debian/patches/series
* debian/patches:
  - Add debian/patches/412610_attachment_309958.patch: to prevent crash on MAX_PATH
  - update debian/patches/series

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 18_arm_xpcom_unused_attribute.dpatch by Mike Hommey <glandium@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Patch from Steve Langasek to fix unused vs. used gcc attribute on arm.
 
6
## DP: bz#307418
 
7
 
 
8
@DPATCH@
 
9
 
 
10
=== xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
 
11
==================================================================
 
12
--- xulrunner/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp       (revision 22)
 
13
+++ xulrunner/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp       (local)
 
14
@@ -45,7 +45,8 @@
 
15
 #endif
 
16
 
 
17
 /* Specify explicitly a symbol for this function, don't try to guess the c++ mangled symbol.  */
 
18
-static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch");
 
19
+static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch")
 
20
+__attribute__((used));
 
21
 
 
22
 static nsresult
 
23
 PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args)