~ubuntu-branches/ubuntu/karmic/motion/karmic-proposed

« back to all changes in this revision

Viewing changes to debian/patches/05_configure.in_added-LIBS.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Juan Angulo Moreno
  • Date: 2008-06-10 09:15:47 UTC
  • mfrom: (4.1.4 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080610091547-2dcuzqpznlivgvxl
Tags: 3.2.9-4
* Fixed errors in the file debian/rules that affected the non-apply of 
  two patches (01_ffmpeg_creation_update_API.dpatch and 
  02_webhttpd_security_video2_backport.dpatch) (Closes: #484566).
* Bumped Standards-Version to 3.8.0. No changes to package necessary.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 05_configure.in_added-LIBS.dpatch by Frederik Dannemare <frederik@dannemare.net>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Add -lvorbis -lvorbisenc -ldts -la52 to LIBS
6
 
 
7
 
@DPATCH@
8
 
 
9
 
--- motion-3.1.19/configure.in.orig     2005-03-14 12:09:58.712691480 +0100
10
 
+++ motion-3.1.19/configure.in  2005-03-14 12:12:43.752601600 +0100
11
 
@@ -144,7 +144,7 @@
12
 
                echo ""
13
 
        fi
14
 
        CFLAGS="${CFLAGS} -DHAVE_FFMPEG"
15
 
-       LIBS="$LIBS -L${FFMPEG} -lavformat -lavcodec -lm -lz"
16
 
+       LIBS="$LIBS -L${FFMPEG} -lavformat -lavcodec -lvorbis -lvorbisenc -ldts -la52 -lm -lz"
17
 
        FFMPEG_OBJ="ffmpeg.o"
18
 
        AC_SUBST(FFMPEG_OBJ)
19
 
        LDFLAGS="-Wl,-rpath,${FFMPEG}"