~ubuntu-branches/ubuntu/karmic/nss/karmic-security

« back to all changes in this revision

Viewing changes to debian/patches/38_mips64_build.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mike Hommey
  • Date: 2007-04-09 20:37:25 UTC
  • Revision ID: james.westby@ubuntu.com-20070409203725-ey44fgcayqdb01qs
Tags: 3.11.5-3
Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 38_mips64_build.dpatch by Mike Hommey <glandium@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Patch from Martin Michlmayr for mips64 builds. bz#330626
 
6
 
 
7
@DPATCH@
 
8
 
 
9
--- nss/mozilla/security/coreconf/Linux.mk
 
10
+++ nss/mozilla/security/coreconf/Linux.mk
 
11
@@ -78,6 +78,9 @@
 
12
 ifeq ($(OS_TEST),parisc64)
 
13
        CPU_ARCH        = hppa
 
14
 else
 
15
+ifeq ($(OS_TEST),mips64)
 
16
+       CPU_ARCH        = mips
 
17
+else
 
18
 ifeq (,$(filter-out i686 i586 i486 i386,$(OS_TEST)))
 
19
        OS_REL_CFLAGS   += -Di386
 
20
        CPU_ARCH        = x86
 
21
@@ -87,6 +90,7 @@
 
22
 endif
 
23
 endif
 
24
 endif
 
25
+endif
 
26
 
 
27
 
 
28
 LIBC_TAG               = _glibc