~ubuntu-branches/ubuntu/karmic/pyca/karmic

« back to all changes in this revision

Viewing changes to debian/patches/02_pep0263

  • Committer: Bazaar Package Importer
  • Author(s): Lars Bahner
  • Date: 2003-12-02 19:39:35 UTC
  • Revision ID: james.westby@ubuntu.com-20031202193935-a2izk0amdo1gre1e
Tags: 20031118-1
* New upstream release
* conversion to dpatch
* Significantly reworked debian/rules
* Added patch for encoding type utf-8 to pylib/openssl/cnf.py
  io. to avoid croak from ca2ldif.py. My system
  is utf-8 an so I trust are many others.
* New frontpage
* Typos in man-pages ... which are also UTF-8 :|
* Cascade the manpages to actual files shut lintian up. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh -e
 
2
## DP: Debian conformance patch for the Debian pyca-package
 
3
## DP: This patch consists mainly of FHS (2.2) stuff
 
4
## Copyright @ 2003  by Lars Bahner <bahner@debian.org>
 
5
 
 
6
if [ $# -ne 1 ]; then
 
7
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
8
        exit 1
 
9
fi
 
10
 
 
11
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
12
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
13
 
 
14
case "$1" in
 
15
       -patch) patch $patch_opts -p1 < $0;;
 
16
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
17
        *)
 
18
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
19
                exit 1;;
 
20
esac
 
21
 
 
22
exit 0
 
23
 
 
24
@DPATCH@
 
25
--- tmp/pyca-20031118/pylib/openssl/cnf.py      2001-05-17 19:23:49.000000000 +0200
 
26
+++ pyca-20031118/pylib/openssl/cnf.py  2003-12-01 17:59:06.000000000 +0100
 
27
@@ -1,3 +1,4 @@
 
28
+# -*- coding: utf-8 -*-
 
29
 #######################################################################
 
30
 # openssl.cnf.py
 
31
 # (c) by Michael Stroeder, michael.stroeder@propack-data.de