~ubuntu-branches/ubuntu/karmic/sl-modem/karmic

« back to all changes in this revision

Viewing changes to debian/patches/autoload.diff

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-03-05 20:27:30 UTC
  • Revision ID: james.westby@ubuntu.com-20090305202730-rfiuhpu2fooqqv18
Tags: 2.9.11~20080817-3ubuntu2
* debian/patches/autoload.diff: Patch drivers to export the right aliases
  for auto-load on open.
* debian/sl-modem-daemon.modutils: so we don't need this file anymore, the
  rest is done by udev anyway
* debian/rules: so we don't need to install the modprobe.d file
* debian/sl-modem-daemon.dirs: so we don't need the directory
* debian/sl-modem-daemon.preinst: so remove the file on upgrade

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: sl-modem-2.9.11~20080817/drivers/old_st7554.c
 
2
===================================================================
 
3
--- sl-modem-2.9.11~20080817.orig/drivers/old_st7554.c  2009-03-05 20:24:32.000000000 +0000
 
4
+++ sl-modem-2.9.11~20080817/drivers/old_st7554.c       2009-03-05 20:26:28.000000000 +0000
 
5
@@ -1386,4 +1386,5 @@
 
6
 MODULE_AUTHOR("Smart Link Ltd.");
 
7
 MODULE_DESCRIPTION("ST7554 USB Smart Link Soft Modem driver.");
 
8
 MODULE_LICENSE("Smart Link Ltd.");
 
9
+MODULE_ALIAS_CHARDEV_MAJOR(MY_MAJOR);
 
10
 
 
11
Index: sl-modem-2.9.11~20080817/drivers/st7554.c
 
12
===================================================================
 
13
--- sl-modem-2.9.11~20080817.orig/drivers/st7554.c      2009-03-05 20:24:35.000000000 +0000
 
14
+++ sl-modem-2.9.11~20080817/drivers/st7554.c   2009-03-05 20:26:15.000000000 +0000
 
15
@@ -1434,4 +1434,5 @@
 
16
 MODULE_DESCRIPTION("ST7554 USB Smart Link Soft Modem driver.");
 
17
 //MODULE_LICENSE("Smart Link Ltd.");
 
18
 MODULE_LICENSE("Dual BSD/GPL");
 
19
+MODULE_ALIAS_CHARDEV_MAJOR(243);
 
20
 
 
21
Index: sl-modem-2.9.11~20080817/drivers/amrmo_init.c
 
22
===================================================================
 
23
--- sl-modem-2.9.11~20080817.orig/drivers/amrmo_init.c  2009-03-05 20:27:09.000000000 +0000
 
24
+++ sl-modem-2.9.11~20080817/drivers/amrmo_init.c       2009-03-05 20:26:54.000000000 +0000
 
25
@@ -733,6 +733,7 @@
 
26
 MODULE_AUTHOR("Smart Link Ltd.");
 
27
 MODULE_DESCRIPTION("SmartLink HAMR5600,SmartPCI56/561 based modem driver");
 
28
 MODULE_LICENSE("Smart Link Ltd.");
 
29
+MODULE_ALIAS_CHARDEV_MAJOR(AMRMO_MAJOR);
 
30
 
 
31
 
 
32
 static int __init amrmo_init(void)