~ubuntu-branches/ubuntu/karmic/tcpdump/karmic

« back to all changes in this revision

Viewing changes to debian/patches/10_man_install.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Romain Francoise
  • Date: 2008-03-08 19:24:02 UTC
  • mfrom: (6.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080308192402-9n7erk2yyyd5mpt3
Tags: 3.9.8-4
debian/control: Build-Depend on libpcap0.8-dev (>= 0.9.3),
not (>= 0.9.3-1).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 10_man_install.dpatch by Romain Francoise <rfrancoise@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Change man page install paths for Debian.
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
    -patch) patch -p1 ${patch_opts} < $0;;
17
 
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
18
 
    *)
19
 
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
diff -urNad /home/romain/Work/Debian/tcpdump/tcpdump-3.8.3/Makefile.in tcpdump-3.8.3/Makefile.in
27
 
--- /home/romain/Work/Debian/tcpdump/tcpdump-3.8.3/Makefile.in  2004-05-08 09:12:28.000000000 +0200
28
 
+++ tcpdump-3.8.3/Makefile.in   2004-05-08 09:13:23.000000000 +0200
29
 
@@ -157,13 +157,13 @@
30
 
        [ -d $(DESTDIR)$(sbindir) ] || \
31
 
            (mkdir -p $(DESTDIR)$(sbindir); chmod 755 $(DESTDIR)$(sbindir))
32
 
        $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(sbindir)/$(PROG)
33
 
-       [ -d $(DESTDIR)$(mandir)/man1 ] || \
34
 
-           (mkdir -p $(DESTDIR)$(mandir)/man1; chmod 755 $(DESTDIR)$(mandir)/man1)
35
 
-       $(INSTALL_DATA) $(srcdir)/$(PROG).1 $(DESTDIR)$(mandir)/man1/$(PROG).1
36
 
+       [ -d $(DESTDIR)$(mandir)/man8 ] || \
37
 
+           (mkdir -p $(DESTDIR)$(mandir)/man8; chmod 755 $(DESTDIR)$(mandir)/man8)
38
 
+       $(INSTALL_DATA) $(srcdir)/$(PROG).1 $(DESTDIR)$(mandir)/man8/$(PROG).8
39
 
 
40
 
 uninstall:
41
 
        rm -f $(DESTDIR)$(sbindir)/$(PROG)
42
 
-       rm -f $(DESTDIR)$(mandir)/man1/$(PROG).1
43
 
+       rm -f $(DESTDIR)$(mandir)/man8/$(PROG).8
44
 
 
45
 
 lint: $(GENSRC)
46
 
        lint -hbxn $(SRC) | \