~ubuntu-branches/ubuntu/lucid/altermime/lucid

« back to all changes in this revision

Viewing changes to debian/patches/01_makefile_destdir.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Julien Valroff
  • Date: 2010-01-01 18:49:00 UTC
  • Revision ID: james.westby@ubuntu.com-20100101184900-wfqqwv1wqqhx11xm
Tags: 0.3.10-3
* Bump Standards-Version to 3.8.3 - no further changes
* Converted source package to 3.0 (quilt) format
* Switched to GIT - updated VCS-* fields accordingly
* Added misc:Depends to control file
* Removed XS- prefix for DM-Upload-Allowed field
* Fixed doc-base installation file

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_makefile_destdir.dpatch by  <julien@kirya.net>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Adds ${DESTDIR} variable to Makefile
6
 
 
7
 
@DPATCH@
8
 
 
9
 
diff -ur altermime-0.3.6/Makefile.old altermime-0.3.6/Makefile
10
 
--- altermime-0.3.6/Makefile.old        2005-08-04 22:15:58.000000000 +0200
11
 
+++ altermime-0.3.6/Makefile    2005-08-04 22:16:27.000000000 +0200
12
 
@@ -19,11 +19,11 @@
13
 
 # Build Install
14
 
 install: altermime
15
 
        strip altermime
16
 
-       cp altermime /usr/local/bin
17
 
-       chmod a+rx /usr/local/bin/altermime
18
 
+       cp altermime ${DESTDIR}
19
 
+       chmod a+rx ${DESTDIR}/altermime
20
 
 
21
 
 uninstall:
22
 
-       rm -f /usr/local/bin/altermime
23
 
+       rm -f ${DESTDIR}/altermime
24
 
 
25
 
 clean:
26
 
        rm -f *.o altermime