~ubuntu-branches/ubuntu/lucid/awstats/lucid-security

« back to all changes in this revision

Viewing changes to debian/patches/0001_awstats69beta_xss.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard, Sergey B Kirpichev, Jonas Smedegaard
  • Date: 2009-03-03 18:19:24 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20090303181924-szfwaw0qmfdg7m6b
Tags: 6.9~dfsg-1
[ Sergey B Kirpichev ]
* New upstream release (Closes: #494676).
* Add myself to Uploaders field. 
* Drop patches 0001 and 1005 (applied upstream).
* Unfuzz patches 1002-1004.
* Add new patch 1007 updating Russian translation. Thanks to Sergey
  Kirpichev at upstream tracker #2540486.
* Add new patch 1008 enhancing the ExtraSection headings to include
  the words (Top XXX) for consistency with all other section headings.
* Add new patch 1009 fixing URL to Hurd (Closes: #408086).
* Add new patch 1010 fixing dirdata permissions (Closes: #299148).
* Add new patch 1011 fixing Geo::IPfree warnings (Closes: #512373).
* Add new patch 2001 hiding charts in days of month statistics.
* Use debian defaults for geoip data files.

[ Jonas Smedegaard ]
* Repackage upstream tarball.
* Packaging moved to Git (from Subversion). Update debian/control and
  git-buildpackage configfile, enabling pristine-tar support.
* Use new local CDBS snippet package-relations.mk to resolve, cleanup
  and apply CDBS-declared (build-)dependencies.
* Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis).
* Update local CDBS snippets:
  + upstream-tarball.mk: internal restructuring
  + buildinfo.mk: fix copyright years
  + copyright-check.mk: major rewrite, now generating hint file more
    readily usable as template for new proposed copyright format
  + Update README.cdbs-tweaks to also cover newly added package-
    relations.mk.
* Rewrite debian/copyright using new proposed syntax (v440). Update
  copyright-hints.
* Unfuzz patch 1006.
* Depend on misc:depends (thanks to lintian) and cdbs:depends
  (currently unused, and drop superfluous dependencies (fulfilled by
  perl even in oldstable).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/wwwroot/cgi-bin/awstats.pl        2008/04/21 21:13:28     1.910
2
 
+++ b/wwwroot/cgi-bin/awstats.pl        2008/07/27 17:41:57     1.911
3
 
@@ -4380,6 +4380,7 @@
4
 
 sub DecodeEncodedString {
5
 
        my $stringtodecode=shift;
6
 
        $stringtodecode =~ tr/\+/ /s;
7
 
+       $stringtodecode =~ s/%22//g;
8
 
        $stringtodecode =~ s/%([A-F0-9][A-F0-9])/pack("C", hex($1))/ieg;
9
 
        return $stringtodecode;
10
 
 }
11
 
@@ -4432,9 +4433,12 @@
12
 
 #------------------------------------------------------------------------------
13
 
 sub CleanXSS {
14
 
        my $stringtoclean=shift;
15
 
+       # To avoid html tags and javascript
16
 
        $stringtoclean =~ s/</&lt;/g;
17
 
        $stringtoclean =~ s/>/&gt;/g;
18
 
        $stringtoclean =~ s/|//g;
19
 
+       # To avoid onload="
20
 
+       $stringtoclean =~ s/onload//g;
21
 
        return $stringtoclean;
22
 
 }
23