~ubuntu-branches/ubuntu/lucid/blender/lucid

« back to all changes in this revision

Viewing changes to debian/patches/50_debian_build_config

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Hahler
  • Date: 2009-02-28 15:08:47 UTC
  • Revision ID: james.westby@ubuntu.com-20090228150847-ntsgu9q557dg6vtf
Tags: 2.48a+dfsg-1ubuntu2
* Build with Python 2.6
  - debian/control: s/python-2.5/python-2.6/
  - debian/pyversions: 2.6
  - Update debian/patches/50_debian_build_config:
    - BF_PYTHON_VERSION = '2.6'

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/config/linux2-config.py
2
 
+++ b/config/linux2-config.py
3
 
@@ -1,4 +1,7 @@
 
1
Index: blender-2.48a+dfsg/config/linux2-config.py
 
2
===================================================================
 
3
--- blender-2.48a+dfsg.orig/config/linux2-config.py     2009-02-28 16:01:41.745325023 +0100
 
4
+++ blender-2.48a+dfsg/config/linux2-config.py  2009-02-28 16:03:02.033324624 +0100
 
5
@@ -1,11 +1,14 @@
4
6
-LCGDIR = '../lib/linux2'
5
7
+# Needed for pkg-config calls.
6
8
+import commands
8
10
+LCGDIR = './lib/linux2'
9
11
 LIBDIR = "${LCGDIR}"
10
12
 
11
 
 WITH_BF_VERSE = 'false'
12
 
@@ -60,15 +63,17 @@
 
13
 WITH_BF_VERSE = False
 
14
 BF_VERSE_INCLUDE = "#extern/verse/dist"
 
15
 
 
16
 BF_PYTHON = '/usr'
 
17
-BF_PYTHON_VERSION = '2.5'
 
18
+BF_PYTHON_VERSION = '2.6'
 
19
 WITH_BF_STATICPYTHON = False
 
20
 BF_PYTHON_INC = '${BF_PYTHON}/include/python${BF_PYTHON_VERSION}'
 
21
 BF_PYTHON_BINARY = '${BF_PYTHON}/bin/python${BF_PYTHON_VERSION}'
 
22
@@ -73,15 +76,17 @@
13
23
 
14
24
 BF_GETTEXT = '/usr'
15
25
 BF_GETTEXT_INC = '${BF_GETTEXT}/include'
30
40
-WITH_BF_GAMEENGINE=False
31
41
+WITH_BF_GAMEENGINE=True
32
42
 
33
 
 WITH_BF_ODE = 'false'
 
43
 WITH_BF_ODE = False
34
44
 BF_ODE = LIBDIR + '/ode'
35
 
@@ -130,6 +135,12 @@
36
 
 BF_FFMPEG_INC = '${BF_FFMPEG}/include'
37
 
 BF_FFMPEG_LIBPATH='${BF_FFMPEG}/lib'
 
45
@@ -161,6 +166,12 @@
 
46
 BF_REDCODE_INC = '${BF_REDCODE}/include'
 
47
 BF_REDCODE_LIBPATH='${BF_REDCODE}/lib'
38
48
 
39
49
+BF_FFMPEG_LIB = commands.getoutput('pkg-config --libs libavformat vorbisenc libswscale') + ' -lgsm'
40
50
+
43
53
+    BF_FFMPEG_LIB += ' ' + commands.getoutput('pkg-config --libs libdc1394-2')
44
54
+
45
55
 # Mesa Libs should go here if your using them as well....
46
 
 WITH_BF_STATICOPENGL = 'false'
 
56
 WITH_BF_STATICOPENGL = False
47
57
 BF_OPENGL = '/usr'
48
 
@@ -156,13 +167,14 @@
 
58
@@ -187,13 +198,14 @@
49
59
 ##ARFLAGS = ruv
50
60
 ##ARFLAGSQUIET = ru
51
61
 ##
62
72
 ##LOPTS = --dynamic
63
73
 ##DYNLDFLAGS = -shared $(LDFLAGS)
64
74
 
65
 
@@ -172,9 +184,9 @@
 
75
@@ -203,9 +215,9 @@
66
76
 BF_DEBUG = False
67
77
 BF_DEBUG_FLAGS = '-g'
68
78