~ubuntu-branches/ubuntu/lucid/clamav/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/0018-llvm-don-t-use-system-libs.patch

  • Committer: Package Import Robot
  • Author(s): Chris, Marc Deslauriers, Chris Pollock
  • Date: 2015-02-08 07:54:07 UTC
  • mfrom: (81.1.10 lucid-security)
  • Revision ID: package-import@ubuntu.com-20150208075407-sjpyx5pb5emtexcl
Tags: 0.98.6+dfsg-0ubuntu0.10.04.1
[ Marc Deslauriers ]
* Updated to 0.98.6 to fix security issues, including CVE-2014-9328.
  (LP: #1420819)
* Removed upstreamed patches:
  - d/p/0002-Add-an-additional-n-after-the-number-in-the-pidfile.patch
  - d/p/0017-Bump-.so-version-number.patch

[ Chris Pollock ]
* Drop dh_autoreconf from build-depends
* Remove use of dh_autoreconf from debian/rules
* Adjust list of no LLVM architectures in debian/rules to include powerpc
  to avoid FTBFS on lucid

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 1e6bc6dd2b0b8eaf78e7dadf47790f97daf9b110 Mon Sep 17 00:00:00 2001
 
2
From: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
 
3
Date: Wed, 19 Nov 2014 23:04:32 +0100
 
4
Subject: llvm: don't use --system-libs
 
5
 
 
6
this continues the saga of not linking the .a files so we don't care
 
7
about the libs llvm links against (like -ledit)
 
8
 
 
9
Signed-off-by: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
 
10
---
 
11
 libclamav/c++/configure.ac | 2 +-
 
12
 1 file changed, 1 insertion(+), 1 deletion(-)
 
13
 
 
14
diff --git a/libclamav/c++/configure.ac b/libclamav/c++/configure.ac
 
15
index 43e187ff1f56..2d2d47b9d24c 100644
 
16
--- a/libclamav/c++/configure.ac
 
17
+++ b/libclamav/c++/configure.ac
 
18
@@ -115,7 +115,7 @@ if test "x$llvmconfig" != "x"; then
 
19
     if test $llvmver_test -ge 350; then
 
20
         dnl LLVM 3.5.0 and after splits linker flags into two sets
 
21
         ldflags=`$llvmconfig --ldflags`
 
22
-        syslibs=`$llvmconfig --system-libs`
 
23
+        syslibs=
 
24
         AC_SUBST(LLVMCONFIG_LDFLAGS, ["$ldflags $syslibs"])
 
25
     else
 
26
         AC_SUBST(LLVMCONFIG_LDFLAGS, [`$llvmconfig --ldflags`])