~ubuntu-branches/ubuntu/lucid/curl/lucid-security

« back to all changes in this revision

Viewing changes to debian/gnutls-soname.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2005-12-12 15:04:52 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20051212150452-2ymlra67b2p7kjyy
Tags: 7.15.1-1ubuntu1
Resynchronise with Debian to get URL parser overflow fix from 7.15.1
(CVE-2005-4077).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ur curl/lib/Makefile.am curl-gnutls/lib/Makefile.am
 
2
--- curl/lib/Makefile.am        2005-09-28 16:48:25.000000000 +0200
 
3
+++ curl-gnutls/lib/Makefile.am 2005-09-28 16:49:37.000000000 +0200
 
4
@@ -34,7 +34,7 @@
 
5
 
 
6
 CLEANFILES = $(DSP)
 
7
 
 
8
-lib_LTLIBRARIES = libcurl.la
 
9
+lib_LTLIBRARIES = libcurl-gnutls.la
 
10
 
 
11
 # we use srcdir/include for the static global include files
 
12
 # we use builddir/lib for the generated lib/config.h file to get found
 
13
@@ -86,12 +86,12 @@
 
14
 VERSIONED_SYMBOLS = -Wl,--version-script=libcurl.vers
 
15
 endif
 
16
 
 
17
-libcurl_la_LDFLAGS = $(UNDEF) $(VERSION) $(MIMPURE) $(VERSIONED_SYMBOLS)
 
18
+libcurl_gnutls_la_LDFLAGS = $(UNDEF) $(VERSION) $(MIMPURE) $(VERSIONED_SYMBOLS)
 
19
 
 
20
 # Makefile.inc provides the CSOURCES and HHEADERS defines
 
21
 include Makefile.inc
 
22
 
 
23
-libcurl_la_SOURCES = $(CSOURCES) $(HHEADERS)
 
24
+libcurl_gnutls_la_SOURCES = $(CSOURCES) $(HHEADERS)
 
25
 
 
26
 WIN32SOURCES = $(CSOURCES)
 
27
 WIN32HEADERS = $(HHEADERS) config-win32.h
 
28
diff -ur curl/src/Makefile.am curl-gnutls/src/Makefile.am
 
29
--- curl/src/Makefile.am        2005-09-28 16:48:25.000000000 +0200
 
30
+++ curl-gnutls/src/Makefile.am 2005-09-28 16:49:51.000000000 +0200
 
31
@@ -33,8 +33,8 @@
 
32
 
 
33
 include Makefile.inc
 
34
 
 
35
-curl_LDADD = ../lib/libcurl.la
 
36
-curl_DEPENDENCIES = ../lib/libcurl.la
 
37
+curl_LDADD = ../lib/libcurl-gnutls.la
 
38
+curl_DEPENDENCIES = ../lib/libcurl-gnutls.la
 
39
 BUILT_SOURCES = hugehelp.c
 
40
 CLEANFILES = hugehelp.c
 
41
 NROFF=@NROFF@ @MANOPT@ # figured out by the configure script