~ubuntu-branches/ubuntu/lucid/dbus/lucid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/30_rt-as-needed.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2009-12-07 17:47:06 UTC
  • mfrom: (1.3.2 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091207174706-ylf9r1y180xgw3bt
Tags: 1.2.16-2ubuntu1
* Merge with Debian testing; Remaining Ubuntu changes:
  - Install into / rather than /usr.
  - debian/control: Depend on ConsoleKit for "at_console" policy stanza.
  - debian/dbus.postinst: Do not restart dbus on upgrades, since it breaks
    too many applications. Instead, trigger a "reboot required" notification.
  - debian/dbus.postinst: Create /var/run/dbus in postinst to handle system
    being rebooted before package is configured.  LP: #275229.
  - Add debian/dbus.upstart and bump debhelper b-dep to ensure that it is
    properly installed.
  - 11_timeout_handling.patch: Fix timeout accounting. The
    elapsed_milliseconds contains the time from the start, so subtracting it
    on every iteration means that the timeout is much less than what is
    requested. Instead compare the absolute values, but pass the difference
    to calls which want a timeout so that the correct remaining time is
    used. (LP #376145)
  - 20_system_conf_limit.patch: Increase max_match_rules_per_connection for
    the system bus to 5000 (LP #454093)
  - 81-session.conf-timeout.patch: Raise the service startup timeout from 25
    to 60 seconds. It may be too short on the live CD with slow machines.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/bus/Makefile.am b/bus/Makefile.am
 
2
index 3b4f69d..ad49e6d 100644
 
3
--- a/bus/Makefile.am
 
4
+++ b/bus/Makefile.am
 
5
@@ -78,8 +78,8 @@ dbus_daemon_SOURCES=                          \
 
6
 
 
7
 dbus_daemon_LDADD=                                     \
 
8
        $(EFENCE)                                       \
 
9
-       $(DBUS_BUS_LIBS)                                \
 
10
-       $(top_builddir)/dbus/libdbus-convenience.la
 
11
+       $(top_builddir)/dbus/libdbus-convenience.la     \
 
12
+       $(DBUS_BUS_LIBS)
 
13
 
 
14
 dbus_daemon_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@ @PIE_LDFLAGS@
 
15
 
 
16
@@ -103,8 +103,8 @@ dbus_daemon_launch_helper_SOURCES=          \
 
17
        $(LAUNCH_HELPER_SOURCES)
 
18
 
 
19
 dbus_daemon_launch_helper_LDADD=               \
 
20
-       $(DBUS_LAUNCHER_LIBS)                   \
 
21
-       $(top_builddir)/dbus/libdbus-convenience.la
 
22
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
23
+       $(DBUS_LAUNCHER_LIBS)
 
24
 
 
25
 dbus_daemon_launch_helper_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
26
 
 
27
@@ -115,8 +115,8 @@ dbus_daemon_launch_helper_test_SOURCES=             \
 
28
        $(LAUNCH_HELPER_SOURCES)
 
29
 
 
30
 dbus_daemon_launch_helper_test_LDADD=          \
 
31
-       $(DBUS_LAUNCHER_LIBS)                   \
 
32
-       $(top_builddir)/dbus/libdbus-convenience.la
 
33
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
34
+       $(DBUS_LAUNCHER_LIBS)
 
35
 
 
36
 dbus_daemon_launch_helper_test_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
37
 dbus_daemon_launch_helper_test_CPPFLAGS=       \
 
38
@@ -129,8 +129,8 @@ bus_test_launch_helper_SOURCES=             \
 
39
        $(LAUNCH_HELPER_SOURCES)
 
40
 
 
41
 bus_test_launch_helper_LDADD=          \
 
42
-       $(DBUS_LAUNCHER_LIBS)                   \
 
43
-       $(top_builddir)/dbus/libdbus-convenience.la
 
44
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
45
+       $(DBUS_LAUNCHER_LIBS)
 
46
 
 
47
 bus_test_launch_helper_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
48
 bus_test_launch_helper_CPPFLAGS=       \
 
49
diff --git a/bus/Makefile.in b/bus/Makefile.in
 
50
index fde3829..02520b6 100644
 
51
--- a/bus/Makefile.in
 
52
+++ b/bus/Makefile.in
 
53
@@ -111,8 +111,9 @@ am_bus_test_launch_helper_OBJECTS =  \
 
54
        bus_test_launch_helper-test-launch-helper.$(OBJEXT) \
 
55
        $(am__objects_5)
 
56
 bus_test_launch_helper_OBJECTS = $(am_bus_test_launch_helper_OBJECTS)
 
57
-bus_test_launch_helper_DEPENDENCIES = $(am__DEPENDENCIES_1) \
 
58
-       $(top_builddir)/dbus/libdbus-convenience.la
 
59
+bus_test_launch_helper_DEPENDENCIES =  \
 
60
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
61
+       $(am__DEPENDENCIES_1)
 
62
 bus_test_launch_helper_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
 
63
        $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
 
64
        $(bus_test_launch_helper_LDFLAGS) $(LDFLAGS) -o $@
 
65
@@ -142,8 +143,9 @@ am__dbus_daemon_SOURCES_DIST = activation.c activation.h \
 
66
        config-loader-libxml.c main.c
 
67
 am_dbus_daemon_OBJECTS = $(am__objects_3) main.$(OBJEXT)
 
68
 dbus_daemon_OBJECTS = $(am_dbus_daemon_OBJECTS)
 
69
-dbus_daemon_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
 
70
-       $(top_builddir)/dbus/libdbus-convenience.la
 
71
+dbus_daemon_DEPENDENCIES = $(am__DEPENDENCIES_1) \
 
72
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
73
+       $(am__DEPENDENCIES_1)
 
74
 dbus_daemon_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
 
75
        $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
 
76
        $(dbus_daemon_LDFLAGS) $(LDFLAGS) -o $@
 
77
@@ -160,8 +162,9 @@ am_dbus_daemon_launch_helper_OBJECTS =  \
 
78
        activation-helper-bin.$(OBJEXT) $(am__objects_6)
 
79
 dbus_daemon_launch_helper_OBJECTS =  \
 
80
        $(am_dbus_daemon_launch_helper_OBJECTS)
 
81
-dbus_daemon_launch_helper_DEPENDENCIES = $(am__DEPENDENCIES_1) \
 
82
-       $(top_builddir)/dbus/libdbus-convenience.la
 
83
+dbus_daemon_launch_helper_DEPENDENCIES =  \
 
84
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
85
+       $(am__DEPENDENCIES_1)
 
86
 dbus_daemon_launch_helper_LINK = $(LIBTOOL) --tag=CC \
 
87
        $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
 
88
        $(AM_CFLAGS) $(CFLAGS) $(dbus_daemon_launch_helper_LDFLAGS) \
 
89
@@ -185,8 +188,9 @@ am_dbus_daemon_launch_helper_test_OBJECTS = dbus_daemon_launch_helper_test-activ
 
90
        $(am__objects_8)
 
91
 dbus_daemon_launch_helper_test_OBJECTS =  \
 
92
        $(am_dbus_daemon_launch_helper_test_OBJECTS)
 
93
-dbus_daemon_launch_helper_test_DEPENDENCIES = $(am__DEPENDENCIES_1) \
 
94
-       $(top_builddir)/dbus/libdbus-convenience.la
 
95
+dbus_daemon_launch_helper_test_DEPENDENCIES =  \
 
96
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
97
+       $(am__DEPENDENCIES_1)
 
98
 dbus_daemon_launch_helper_test_LINK = $(LIBTOOL) --tag=CC \
 
99
        $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
 
100
        $(AM_CFLAGS) $(CFLAGS) \
 
101
@@ -497,8 +501,8 @@ dbus_daemon_SOURCES = \
 
102
 
 
103
 dbus_daemon_LDADD = \
 
104
        $(EFENCE)                                       \
 
105
-       $(DBUS_BUS_LIBS)                                \
 
106
-       $(top_builddir)/dbus/libdbus-convenience.la
 
107
+       $(top_builddir)/dbus/libdbus-convenience.la     \
 
108
+       $(DBUS_BUS_LIBS)
 
109
 
 
110
 dbus_daemon_LDFLAGS = @R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@ @PIE_LDFLAGS@
 
111
 LAUNCH_HELPER_SOURCES = \
 
112
@@ -520,8 +524,8 @@ dbus_daemon_launch_helper_SOURCES = \
 
113
        $(LAUNCH_HELPER_SOURCES)
 
114
 
 
115
 dbus_daemon_launch_helper_LDADD = \
 
116
-       $(DBUS_LAUNCHER_LIBS)                   \
 
117
-       $(top_builddir)/dbus/libdbus-convenience.la
 
118
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
119
+       $(DBUS_LAUNCHER_LIBS)
 
120
 
 
121
 dbus_daemon_launch_helper_LDFLAGS = @R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
122
 dbus_daemon_launch_helper_test_SOURCES = \
 
123
@@ -529,8 +533,8 @@ dbus_daemon_launch_helper_test_SOURCES = \
 
124
        $(LAUNCH_HELPER_SOURCES)
 
125
 
 
126
 dbus_daemon_launch_helper_test_LDADD = \
 
127
-       $(DBUS_LAUNCHER_LIBS)                   \
 
128
-       $(top_builddir)/dbus/libdbus-convenience.la
 
129
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
130
+       $(DBUS_LAUNCHER_LIBS)
 
131
 
 
132
 dbus_daemon_launch_helper_test_LDFLAGS = @R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
133
 dbus_daemon_launch_helper_test_CPPFLAGS = \
 
134
@@ -541,8 +545,8 @@ bus_test_launch_helper_SOURCES = \
 
135
        $(LAUNCH_HELPER_SOURCES)
 
136
 
 
137
 bus_test_launch_helper_LDADD = \
 
138
-       $(DBUS_LAUNCHER_LIBS)                   \
 
139
-       $(top_builddir)/dbus/libdbus-convenience.la
 
140
+       $(top_builddir)/dbus/libdbus-convenience.la \
 
141
+       $(DBUS_LAUNCHER_LIBS)
 
142
 
 
143
 bus_test_launch_helper_LDFLAGS = @R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
 
144
 bus_test_launch_helper_CPPFLAGS = \