~ubuntu-branches/ubuntu/lucid/dovecot/lucid-security

« back to all changes in this revision

Viewing changes to debian/patches/fix-message-parser.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mathias Gug, Ante Karamatic, Mathias Gug
  • Date: 2009-02-12 21:45:09 UTC
  • mfrom: (1.10.17 upstream)
  • Revision ID: james.westby@ubuntu.com-20090212214509-8fp69kpkzf03j5xg
Tags: 1:1.1.11-0ubuntu1
[ Ante Karamatic ]
  Add new binary pkg dovecot-postfix that integrates postfix and dovecot
  automatically: (LP: #164837)
  - debian/control:
    + add new binary with short description.
  - debian/dovecot-postfix.postinst:
    + create initial certificate symlinks to snakeoil.
    + set up postfix with postconf to:
      - use Maildir/ as the default mailbox.
      - use dovecot as the sasl authentication  server.
      - use dovecot LDA (deliver).
      - use tls for smtp{d} services.
    + restart postfix and dovecot.
  - debian/dovecot-postfix.postrm:
    + remove all dovecot related configuration from postfix.
    + restart postfix and dovecot.
  - debian/dovecot-common.init:
    + check if /etc/dovecot/dovecot-postfix.conf exists and use it
      as the configuration file if so.
  - debian/patches/warning-ubuntu-postfix.dpatch
    + add warning about dovecot-postfix.conf in dovecot default 
      configuration file.
  - debian/patches/dovecot-postfix.conf.diff:
    + Ubuntu server custom changes to the default dovecot configuration for
      better integration with postfix:
      - enable imap, pop3, imaps, pop3s and managesieve by default.
      - enable dovecot LDA (deliver).
      - enable SASL auth socket in postfix private directory.
  - debian/rules:
    + copy, patch and install dovecot-postfix.conf in /etc/dovecot/.
  
[ Mathias Gug ]
* New upstream release:
* Update dovecot-managesieve to 0.10.5. Fixes:
  - check if names of sieve scripts contain '/' (LP: #307291)
* Update dovecot-managesieve patch for 1.1.11 and 0.10.5.
* Update dovecot-sieve plugin to 1.1.6.
* Merge from debian experimental, remaining changes:
  - Use Snakeoil SSL certificates by default.
    + debian/control: Depend on ssl-cert
    + debian/paptches/ssl-cert-snakeoil.dpatch: Change default SSL cert 
      paths to snakeoil.
    + debian/dovecot-common.postinst: Relax grep for SSL_* a bit.
  - Add autopkgtest in debian/tests/*.
  - debian/dovecot-common.init: Check to see if there is an /etc/inetd.conf.
    (LP: #208411)
  - Fast TearDown: Update lsb init header to not stop in level 6.
  - Add status action to the init script:
    + debian/control: Depend on lsb >= 3.2.12ubuntu3.
    + debian/dovecot-common-init: Add the 'status' action (LP: #247096).
  - debian/rules:
    - Copy config.{guess,sub} after running libtoolize.
    - Clean dovecot-managesieve directory.
  - Add ufw integration: 
    - Created debian/dovecot-common.ufw.profile
    - debian/rules:
      + install profile
    - debian/control
      + Suggest ufw
  - debian/{control,rules}: enable PIE hardening.
  - Updated dovecot.common.README.Debian with information on what has changed 
    between 1.0 and 1.1.1. Fixes (LP: #257625) 
  - dovecot-imapd, dovecot-pop3: Replaces dovecot-common (<< 1:1.1). LP: #254721.
  - debian/control:
    + Update Vcs-* headers.
* debian/rules:
  - Create emtpy stamp.h.in files in dovecot-sieve/ and dovecot-managesieve/
    if they're not there since empty files are not included in the diff.gz 
    file.
* Dropped:
  - debian/patches/fix-message-parser.dpatch: Parsing an invalid message
    address like "From: (" caused an assert-crash. (LP: #290901).
    (CVE-2008-4907 - fixed in 1.1.6)
  - debian/patches/login-max-process-count-warning.dpatch: Tell the user 
    that they have reached the maximum number of processes count.
    (LP: #189616) - Different implementation from upstream.
  - debian/patches/fix-dovecot-sieve.dpatch: Fixes assertion error
    when a header string ends with a LF (LP: #264306). Implemented upstream.
  - Don't fail in postinst if dovecot-{sql,ldap} is missing. (LP: #153161)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
#
3
 
# Ubuntu: https://bugs.launchpad.net/bugs/290901
4
 
# Upstream VCS: http://hg.dovecot.org/dovecot-1.1/raw-rev/48840b2d4b18
5
 
# Description: Fixed message address assert-crashing if the entire input 
6
 
# was invalid. Patch by Richard Platel.
7
 
#
8
 
# HG changeset patch
9
 
# User Timo Sirainen <tss@iki.fi>
10
 
# Date 1224802573 -10800
11
 
# Node ID 48840b2d4b1830ccc3cdc49e8c6da4d9f5dd3c74
12
 
# Parent 25b0cf7c62d3f3fccd8c352824a8ce04a6c57d54
13
 
14
 
#
15
 
#
16
 
--- a/src/lib-mail/message-address.c    Thu Oct 23 18:58:22 2008 +0300
17
 
+++ b/src/lib-mail/message-address.c    Fri Oct 24 01:56:13 2008 +0300
18
 
@@ -314,8 +314,7 @@ message_address_parse_real(pool_t pool, 
19
 
        ctx.str = t_str_new(128);
20
 
        ctx.fill_missing = fill_missing;
21
 
 
22
 
-       ret = rfc822_skip_lwsp(&ctx.parser);
23
 
-       if (ret == 0) {
24
 
+       if (rfc822_skip_lwsp(&ctx.parser) <= 0) {
25
 
                /* no addresses */
26
 
                return NULL;
27
 
        }
28