~ubuntu-branches/ubuntu/lucid/firefox/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/distro-locale-searchplugins.patch

  • Committer: Package Import Robot
  • Author(s): Chris Coulson, Chris Coulson, Jamie Strandboge
  • Date: 2012-06-01 18:33:36 UTC
  • mfrom: (1.1.43)
  • Revision ID: package-import@ubuntu.com-20120601183336-bamdjl485ei371rz
Tags: 13.0+build1-0ubuntu0.10.04.1
* New upstream stable release (FIREFOX_13_0_BUILD1)
  - see LP: #1007495 for USN information

[ Chris Coulson <chris.coulson@canonical.com> ]
* Refresh build-depends:
  - Bump minimum GTK version to 2.14 as we build with GIO support
  - Add minimum requirement for glib (2.18)
  - Drop libidl-dev, this doesn't appear to be needed now
  - Bump minimum NSPR version to 4.9.0 for --enable-system-nspr builds
  - Bump minimum sqlite version to 3.7.10 for --enable-system-sqlite
    builds
  - Bump minimum NSS version to 3.13.2 for --enable-system-nss builds
* Refresh patches:
  - update debian/patches/ubuntu-ua-string-changes.patch
  - update debian/patches/ubuntu-codes-google.patch
  - update debian/patches/use-new-yasm-in-lucid.patch
  - update debian/patches/firefox-kde.patch
  - update debian/patches/mozilla-kde.patch
  - update debian/patches/dont-include-hyphenation-patterns.patch
* Clean up the file exclude list and add comments for excluded files
  - update debian/build/create-tarball.py
* Make it easy to run Firefox in valgrind for builds that are compiled
  with explicit valgrind support
  - update debian/firefox.sh.in
* Don't build with gnomevfs anymore
  - update debian/firefox-gnome-support.install.in
  - update debian/config/mozconfig.in
  - update debian/control.in
  - update debian/rules
* Bump debhelper compat to 7
  - update debian/apport/blacklist.in
  - update debian/apport/source_firefox.py.in
  - update debian/compat
  - update debian/config/mozconfig.in
  - update debian/control.in
  - update debian/firefox-dev.install.in
  - update debian/firefox-dev.links.in
  - update debian/firefox-gnome-support.install.in
  - update debian/firefox.dirs.in
  - update debian/firefox.install.in
  - update debian/firefox.links.in
  - update debian/firefox.postinst.in
  - update debian/firefox.preinst.in
  - update debian/firefox.sh.in
  - update debian/pkgconfig/libxul.pc.in
  - update debian/pkgconfig/mozilla-nspr.pc.in
  - update debian/pkgconfig/mozilla-plugin.pc.in
  - update debian/rules
  - update debian/usr.bin.firefox.apparmor.10.04
  - update debian/usr.bin.firefox.apparmor.9.10
* Override 2 embedded-library lintian errors
  - update debian/firefox.lintian-overrides.in
* Drop debian/patches/distro-locale-searchplugins after landing of
  bmo: #515232
* Don't hardcode general.useragent.locale to en-US, now that it's used
  for searchplugin localization. This means we can drop this pref from
  ubufox
  - add debian/patches/dont-override-general-useragent-locale.patch
  - update debian/patches/series
* Drop patches fixed upstream
  - remove debian/patches/no-sps-profiler-on-unsupported-archs.patch
  - remove debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
  - update debian/patches/series
* Apport hook improvements:
  - Add support for reporting preference defaults that are set by extensions
  - When reporting preferences, record the source of each preference
  - Report plugin packages for plugins that are installed with the
    package manager
  - Add some addon manager related prefs to the whitelist
  - Display additional metadata in the extensions report
  - Take "default-to-compatible" in to account when determining whether
    the user is running incompatible addons
  - Attach submitted crash ID's to bug reports
  - Report if files in the profile folder have broken permissions
* Update compare-locales to 0.9.5
* Fix make-makefile test failure when the build directory contains
  perl regexp control characters
  - add debian/patches/make-makefile-test-fix.patch
  - update debian/patches/series
* Fix for NSS libs not being signed, breaking FIPS
  - update debian/rules

[ Jamie Strandboge <jamie@ubuntu.com> ]
* adjust apparmor profile to deny reads to @{PROC}/[0-9]*/net/dev. Patch 
  thanks to James Troup (LP: #955066)
* adjust apparmor profile to deny reads to @{PROC}/[0-9]*/net/wireless.
  Patch thanks to James Troup (LP: #974141)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Add support for localized distribution searchplugins
2
 
Author: Alexander Sack <asac@ubuntu.com>
3
 
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=515232
4
 
Forwarded: https://bugzilla.mozilla.org/attachment.cgi?id=399338
5
 
 
6
 
Index: mozilla/browser/components/dirprovider/DirectoryProvider.cpp
7
 
===================================================================
8
 
--- mozilla.orig/browser/components/dirprovider/DirectoryProvider.cpp   2012-03-07 19:47:01.707413688 +0000
9
 
+++ mozilla/browser/components/dirprovider/DirectoryProvider.cpp        2012-03-07 19:56:03.147404067 +0000
10
 
@@ -35,6 +35,7 @@
11
 
  *
12
 
  * ***** END LICENSE BLOCK ***** */
13
 
 
14
 
+#include "nsIChromeRegistry.h"
15
 
 #include "nsIDirectoryService.h"
16
 
 #include "DirectoryProvider.h"
17
 
 
18
 
@@ -189,18 +190,17 @@
19
 
         array.AppendObject(commonPlugins);
20
 
   }
21
 
 
22
 
-  nsCOMPtr<nsIPrefBranch> prefs(do_GetService(NS_PREFSERVICE_CONTRACTID));
23
 
-  if (prefs) {
24
 
-
25
 
-    nsCOMPtr<nsIFile> localePlugins;
26
 
-    rv = searchPlugins->Clone(getter_AddRefs(localePlugins));
27
 
-    if (NS_FAILED(rv))
28
 
-      return;
29
 
+  nsCOMPtr<nsIFile> localePlugins;
30
 
+  rv = searchPlugins->Clone(getter_AddRefs(localePlugins));
31
 
+  if (NS_FAILED(rv))
32
 
+    return;
33
 
 
34
 
-    localePlugins->AppendNative(NS_LITERAL_CSTRING("locale"));
35
 
+  localePlugins->AppendNative(NS_LITERAL_CSTRING("locale"));
36
 
 
37
 
-    nsCString locale;
38
 
-    rv = prefs->GetCharPref("general.useragent.locale", getter_Copies(locale));
39
 
+  nsCOMPtr<nsIXULChromeRegistry> chromeReg(do_GetService(NS_CHROMEREGISTRY_CONTRACTID));
40
 
+  if (chromeReg) {
41
 
+    nsCAutoString locale;
42
 
+    chromeReg->GetSelectedLocale(NS_LITERAL_CSTRING("global"), locale);
43
 
     if (NS_SUCCEEDED(rv)) {
44
 
 
45
 
       nsCOMPtr<nsIFile> curLocalePlugins;
46
 
@@ -213,9 +213,12 @@
47
 
           array.AppendObject(curLocalePlugins);
48
 
           return; // all done
49
 
         }
50
 
-      }
51
 
+      } 
52
 
     }
53
 
+  }
54
 
 
55
 
+  nsCOMPtr<nsIPrefBranch> prefs(do_GetService(NS_PREFSERVICE_CONTRACTID));
56
 
+  if (prefs) {
57
 
     // we didn't append the locale dir - try the default one
58
 
     nsCString defLocale;
59
 
     rv = prefs->GetCharPref("distribution.searchplugins.defaultLocale",