~ubuntu-branches/ubuntu/lucid/foomatic-filters/lucid

« back to all changes in this revision

Viewing changes to debian/patches/13_foomatic-rip-ps-reader-buffer-overflow.patch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2009-06-24 13:59:37 UTC
  • mfrom: (1.1.30 upstream)
  • Revision ID: james.westby@ubuntu.com-20090624135937-ti93e4gt0mxpzhq1
Tags: 4.0.2-0ubuntu1
* New upstream release
   - Use cups-config in the ./configure script to find CUPS-related
     directories
   - Bug fixes
* 01-foomatic-rip-segfault-on-jcl-merging.patch,
  02-foomatic-rip-binary-data-after-pjl-options-corrupted.patch,
  10_config-file-param-reading-gs-command-line-massaging.patch,
  13_foomatic-rip-ps-reader-buffer-overflow.patch,
  15_foomatic-rip-renderer-command-line-massaging.patch,
  17_foomatic-rip-man-page-typos.patch,
  20_foomatic-rip-jcl-segmentation-fault.patch,
  23_prioritize-ppd-options-over-cups-options-on-command-line-fix-custom-options.patch:
  Removed patches with upstream fixes.
* debian/control: Added build dependency on libcups2-dev, as now cups-config
  is used by the ./configure script to find CUPS-related directories.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' foomatic-filters-4.0.0/foomaticrip.c foomatic-filters-4.0.0.new/foomaticrip.c
2
 
--- foomatic-filters-4.0.0/foomaticrip.c        2009-03-08 01:06:19.000000000 +0100
3
 
+++ foomatic-filters-4.0.0.new/foomaticrip.c    2009-03-08 01:06:54.000000000 +0100
4
 
@@ -937,7 +937,7 @@
5
 
         }
6
 
     }
7
 
 
8
 
-    n = fread(buf, 1, sizeof(buf), file);
9
 
+    n = fread(buf, 1, sizeof(buf) - 1, file);
10
 
     buf[n] = '\0';
11
 
     type = guess_file_type(buf, n, &startpos);
12
 
     if (startpos > 0) {