~ubuntu-branches/ubuntu/lucid/freetype/lucid

« back to all changes in this revision

Viewing changes to debian/patches-freetype/no-segfault-on-load_mac_face

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2009-03-13 23:09:50 UTC
  • mfrom: (9.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20090313230950-19s53x3l1q5qutmp
Tags: 2.3.9-3
* Drop spurious Suggests: on libfreetype6-dev.  Closes: #363937.
* debian/patches-freetype/enable-subpixel-rendering.patch: enable subpixel
  rendering features, used by libcairo and xft to provide LCD colour
  filtering.  This is considered no more or less evil than the bytecode
  interpreter which we also enable.
* Move debian/libfreetype6.copyright to debian/copyright, and selectively
  install it to the single binary package in debian/rules; the same
  copyright file is used for all the binaries anyway via symlinks, so
  there's no reason it shouldn't ship as debian/copyright.
  Closes: #381228.
* Clip redundant LICENSE.TXT and GPL.TXT files from the
  libfreetype6-dev package.  Closes: #459802.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
2008-08-19  suzuki toshiya <mpsuzuki@hiroshima-u.ac.jp>
2
 
 
3
 
        * src/base/ftobjs.c (FT_Stream_New): Initialize *astream
4
 
        always, even if passed library or arguments are invalid.
5
 
        This fixes a bug that uninitialized stream is freed when
6
 
        an invalid library handle is passed. Originally proposed
7
 
        by Mike Fabian, 2008/08/18 on freetype-devel.
8
 
        (FT_Open_Face): Ditto (stream).
9
 
        (load_face_in_embedded_rfork): Ditto (stream2).
10
 
 
11
 
Fixes Debian bug #487101.
12
 
 
13
 
Index: freetype-2.3.7/src/base/ftobjs.c
14
 
===================================================================
15
 
--- freetype-2.3.7.orig/src/base/ftobjs.c
16
 
+++ freetype-2.3.7/src/base/ftobjs.c
17
 
@@ -128,13 +128,14 @@
18
 
     FT_Stream  stream;
19
 
 
20
 
 
21
 
+    *astream = 0;
22
 
+
23
 
     if ( !library )
24
 
       return FT_Err_Invalid_Library_Handle;
25
 
 
26
 
     if ( !args )
27
 
       return FT_Err_Invalid_Argument;
28
 
 
29
 
-    *astream = 0;
30
 
     memory   = library->memory;
31
 
 
32
 
     if ( FT_NEW( stream ) )
33
 
@@ -1600,7 +1601,7 @@
34
 
     FT_Error   errors[FT_RACCESS_N_RULES];
35
 
 
36
 
     FT_Open_Args  args2;
37
 
-    FT_Stream     stream2;
38
 
+    FT_Stream     stream2 = 0;
39
 
 
40
 
 
41
 
     FT_Raccess_Guess( library, stream,
42
 
@@ -1713,7 +1714,7 @@
43
 
     FT_Error     error;
44
 
     FT_Driver    driver;
45
 
     FT_Memory    memory;
46
 
-    FT_Stream    stream;
47
 
+    FT_Stream    stream = 0;
48
 
     FT_Face      face = 0;
49
 
     FT_ListNode  node = 0;
50
 
     FT_Bool      external_stream;