~ubuntu-branches/ubuntu/lucid/graphviz/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/2_ocaml_tweaks

  • Committer: Bazaar Package Importer
  • Author(s): Bryce Harrington
  • Date: 2008-06-19 20:23:23 UTC
  • mfrom: (1.2.5 upstream)
  • Revision ID: james.westby@ubuntu.com-20080619202323-ls23h96ntj9ny94m
Tags: 2.18-1ubuntu1
* Merge from debian unstable, remaining changes:
  - Build depend on liblualib50-dev instead of liblua5.1-0-dev.
  - Drop libttf-dev (libttf-dev is in universe) (LP: #174749).
  - Replace gs-common with ghostscript.
  - Build-depend on python-dev instead of python2.4-dev or python2.5-dev.
  - Mention the correct python version for the python bindings in the
    package description.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: graphviz.git/tclpkg/gv/Makefile.am
2
 
===================================================================
3
 
--- graphviz.git.orig/tclpkg/gv/Makefile.am     2007-11-19 01:37:27.000000000 +0100
4
 
+++ graphviz.git/tclpkg/gv/Makefile.am  2007-11-19 01:47:27.000000000 +0100
5
 
@@ -69,7 +69,10 @@
6
 
        $(SWIG) -c++ -lua -o gv_lua.cpp $(srcdir)/gv.i
7
 
 
8
 
 pkgocamldir = $(pkglibdir)/ocaml
9
 
-OCAML_data = gv.cma gv.cmi gv.cma gv.cmi gv.a gv.cmx gv.cmxa gv.mli META.gv
10
 
+OCAML_data = gv.cmo gv.cma gv.cmi gv.mli META.gv
11
 
+if WITH_OCAMLOPT
12
 
+OCAML_data += gv.a gv.cmx gv.cmxa
13
 
+endif
14
 
 nodist_libgv_ocaml_la_SOURCES = gv_ocaml.cpp $(OCAML_data)
15
 
 libgv_ocaml_la_SOURCES = $(BASESOURCES)
16
 
 libgv_ocaml_la_LIBADD = $(BASELIBS) @OCAML_LIBS@
17
 
Index: graphviz.git/configure.ac
18
 
===================================================================
19
 
--- graphviz.git.orig/configure.ac      2007-11-19 01:37:27.000000000 +0100
20
 
+++ graphviz.git/configure.ac   2007-11-19 01:38:02.000000000 +0100
21
 
@@ -721,6 +721,7 @@
22
 
        AC_MSG_WARN([swig does not support ocaml. The OCAML packages will not be built])
23
 
 else
24
 
 AC_CHECK_PROG(OCAML,ocaml,ocaml)
25
 
+AC_CHECK_PROG(OCAML_OPT,ocamlopt,ocamlopt)
26
 
 OCAML_INCLUDES=-I/usr/lib$LIBPOSTFIX/ocaml
27
 
 OCAML_LIBS=-L/usr/lib$LIBPOSTFIX/ocaml
28
 
 save_CPPFLAGS=$CPPFLAGS
29
 
@@ -736,6 +737,7 @@
30
 
 fi
31
 
 fi
32
 
 AM_CONDITIONAL(WITH_OCAML, [test "x$OCAML" != "x"])
33
 
+AM_CONDITIONAL(WITH_OCAMLOPT, [test "x$OCAML_OPT" != "x"])
34
 
 
35
 
 dnl -----------------------------------
36
 
 dnl INCLUDES and LIBS for PERL