~ubuntu-branches/ubuntu/lucid/hal/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/00git_cpufreq_warning_message_fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek, Steve Langasek, Martin Pitt
  • Date: 2009-08-27 15:54:42 UTC
  • Revision ID: james.westby@ubuntu.com-20090827155442-1baea8tmo8a66r5h
Tags: 0.5.13-1ubuntu2
[ Steve Langasek ]
* debian/patches/series: add debian/patches/04_nvidia_brightness.patch so
  it actually gets applied.
* debian/patches/04_nvidia_brightness.patch: copy logic from
  /usr/share/hal/fdi/policy/10osvendor/10-laptop-panel-mgmt-policy.fdi to
  apply the correct methods as well, in place of
  hald-addon-generic-backlight.  LP: #277589.

[ Martin Pitt ]
* debian/control: Add back smartdimmer recommends for above patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/hald/linux/addons/addon-cpufreq.c b/hald/linux/addons/addon-cpufreq.c
 
2
index f8d29ab..977ee08 100644
 
3
--- a/hald/linux/addons/addon-cpufreq.c
 
4
+++ b/hald/linux/addons/addon-cpufreq.c
 
5
@@ -408,7 +408,7 @@ static gboolean ondemand_set_consider_nice(void *data, gboolean consider)
 
6
        consider_file = g_strdup_printf(ONDEMAND_IGNORE_NICE_LOAD_FILE, iface->base_cpu); 
 
7
 
 
8
         if(!write_line(consider_file, "%u", !consider)){
 
9
-                HAL_WARNING(("Could not set ignore_nice_load to: %u kHz; %s", consider,
 
10
+                HAL_WARNING(("Could not set ignore_nice_load to: %u; %s", consider,
 
11
                             strerror(errno)));
 
12
                g_free(consider_file);
 
13
                 return FALSE;