~ubuntu-branches/ubuntu/lucid/kde4libs/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_70_dbusmenu.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Thomas
  • Date: 2010-01-19 20:32:41 UTC
  • mfrom: (1.1.42 upstream)
  • Revision ID: james.westby@ubuntu.com-20100119203241-6qlz4p6emiawose6
Tags: 4:4.3.95-0ubuntu1
* New upstream release candidate:
  - Remove kubuntu_71_knewstuff_crashes.diff, applied upstream
  - Remove kubuntu_72_popupapplet_crash_fix.diff, applied upstream
  - Refresh kubuntu_70_dbusmenu.diff
  - Bump RUNTIME_DEPS value in debian/rules to 4.3.90
  - Update .install files

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/CMakeLists.txt b/CMakeLists.txt
2
 
index 56eb24f..2ce2478 100644
3
 
--- a/CMakeLists.txt
4
 
+++ b/CMakeLists.txt
5
 
@@ -105,6 +105,8 @@ macro_log_feature(SHAREDDESKTOPONTOLOGIES_FOUND "Shared desktop ontologies" "Des
 
1
Index: kde4libs-4.3.95/CMakeLists.txt
 
2
===================================================================
 
3
--- kde4libs-4.3.95.orig/CMakeLists.txt 2010-01-19 20:33:29.533739599 -0500
 
4
+++ kde4libs-4.3.95/CMakeLists.txt      2010-01-19 20:34:44.585738837 -0500
 
5
@@ -105,6 +105,8 @@
6
6
 macro_optional_find_package(QCA2)
7
7
 macro_log_feature(QCA2_FOUND "QCA2" "Qt Cryptographic Architecture" "http://delta.affinix.com/qca" FALSE "2.0.0" "Needed for the plasma remote widgets functionality.")
8
8
 
11
11
 ################# Disallow in-source build #################
12
12
 
13
13
 macro_ensure_out_of_source_build("kdelibs requires an out of source build. Please create a separate build directory and run 'cmake path_to_kdelibs [options]' there.")
14
 
diff --git a/cmake/modules/CMakeLists.txt b/cmake/modules/CMakeLists.txt
15
 
index 587a289..6f70eec 100644
16
 
--- a/cmake/modules/CMakeLists.txt
17
 
+++ b/cmake/modules/CMakeLists.txt
18
 
@@ -32,6 +32,7 @@ set(cmakeFiles CheckCXXSourceCompiles.cmake
 
14
Index: kde4libs-4.3.95/cmake/modules/CMakeLists.txt
 
15
===================================================================
 
16
--- kde4libs-4.3.95.orig/cmake/modules/CMakeLists.txt   2010-01-19 20:33:29.713749086 -0500
 
17
+++ kde4libs-4.3.95/cmake/modules/CMakeLists.txt        2010-01-19 20:34:44.585738837 -0500
 
18
@@ -32,6 +32,7 @@
19
19
                FindBlueZ.cmake
20
20
                FindBoost.cmake
21
21
                FindCarbon.cmake
23
23
                FindDNSSD.cmake
24
24
                FindENCHANT.cmake
25
25
                FindEigen.cmake
26
 
diff --git a/cmake/modules/FindDBusMenuQt.cmake b/cmake/modules/FindDBusMenuQt.cmake
27
 
new file mode 100644
28
 
index 0000000..fb95da1
29
 
--- /dev/null
30
 
+++ b/cmake/modules/FindDBusMenuQt.cmake
 
26
Index: kde4libs-4.3.95/cmake/modules/FindDBusMenuQt.cmake
 
27
===================================================================
 
28
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
29
+++ kde4libs-4.3.95/cmake/modules/FindDBusMenuQt.cmake  2010-01-19 20:34:44.585738837 -0500
31
30
@@ -0,0 +1,46 @@
32
31
+# - Try to find dbusmenu-qt
33
32
+# Once done this will define
75
74
+
76
75
+    mark_as_advanced(DBUSMENUQT_INCLUDE_DIR DBUSMENUQT_LIBRARIES)
77
76
+endif (DBUSMENUQT_INCLUDE_DIR AND DBUSMENUQT_LIBRARIES)
78
 
diff --git a/kdeui/CMakeLists.txt b/kdeui/CMakeLists.txt
79
 
index 898481a..4ddadde 100644
80
 
--- a/kdeui/CMakeLists.txt
81
 
+++ b/kdeui/CMakeLists.txt
82
 
@@ -26,6 +26,7 @@ include_directories(
 
77
Index: kde4libs-4.3.95/kdeui/CMakeLists.txt
 
78
===================================================================
 
79
--- kde4libs-4.3.95.orig/kdeui/CMakeLists.txt   2010-01-19 20:33:29.545758447 -0500
 
80
+++ kde4libs-4.3.95/kdeui/CMakeLists.txt        2010-01-19 20:34:44.589737879 -0500
 
81
@@ -26,6 +26,7 @@
83
82
  ${CMAKE_CURRENT_SOURCE_DIR}/widgets
84
83
  ${CMAKE_CURRENT_SOURCE_DIR}/windowmanagement
85
84
  ${CMAKE_CURRENT_SOURCE_DIR}/xmlgui
87
86
 )
88
87
 
89
88
 add_subdirectory( about )
90
 
@@ -319,12 +320,12 @@ qt4_add_dbus_interface( kdeui_LIB_SRCS ${kwallet_xml} kwallet_interface )
 
89
@@ -319,12 +320,12 @@
91
90
 qt4_add_dbus_interfaces(kdeui_LIB_SRCS ${CMAKE_CURRENT_SOURCE_DIR}/jobs/org.kde.JobViewServer.xml )
92
91
 qt4_add_dbus_interface(kdeui_LIB_SRCS ${CMAKE_CURRENT_SOURCE_DIR}/jobs/org.kde.JobView.xml jobviewiface )
93
92
 
102
101
                      ${CMAKE_CURRENT_SOURCE_DIR}/notifications/kstatusnotifieritemdbus_p.h KStatusNotifierItemDBus)
103
102
 
104
103
 set(kglobalaccel_xml ${CMAKE_CURRENT_SOURCE_DIR}/shortcuts/org.kde.KGlobalAccel.xml)
105
 
@@ -339,7 +340,7 @@ install(FILES ${kglobalaccel_component_xml} DESTINATION ${DBUS_INTERFACES_INSTAL
 
104
@@ -339,7 +340,7 @@
106
105
 
107
106
 kde4_add_library(kdeui SHARED ${kdeui_LIB_SRCS})
108
107
 
111
110
 
112
111
 if(MINGW)
113
112
    target_link_libraries(kdeui gdi32 oleaut32)
114
 
@@ -612,8 +613,8 @@ install( FILES
 
113
@@ -612,8 +613,8 @@
115
114
   DESTINATION ${DBUS_INTERFACES_INSTALL_DIR})
116
115
 
117
116
 install(FILES
122
121
     DESTINATION ${DBUS_INTERFACES_INSTALL_DIR})
123
122
 
124
123
 if (NOT Q_WS_X11)
125
 
diff --git a/kdeui/icons/kicon.cpp b/kdeui/icons/kicon.cpp
126
 
index 98bf97a..21b6415 100644
127
 
--- a/kdeui/icons/kicon.cpp
128
 
+++ b/kdeui/icons/kicon.cpp
 
124
Index: kde4libs-4.3.95/kdeui/icons/kicon.cpp
 
125
===================================================================
 
126
--- kde4libs-4.3.95.orig/kdeui/icons/kicon.cpp  2010-01-19 20:33:29.685737984 -0500
 
127
+++ kde4libs-4.3.95/kdeui/icons/kicon.cpp       2010-01-19 20:34:44.589737879 -0500
129
128
@@ -18,27 +18,36 @@
130
129
 
131
130
 #include "kicon.h"
163
162
 }
164
163
 
165
164
 KIcon::KIcon()
166
 
@@ -66,3 +75,8 @@ KIcon& KIcon::operator=( const KIcon &other )
 
165
@@ -66,3 +75,8 @@
167
166
 
168
167
     return *this;
169
168
 }
172
171
+{
173
172
+    return sIconNameForCacheKey->value(cacheKey());
174
173
+}
175
 
diff --git a/kdeui/icons/kicon.h b/kdeui/icons/kicon.h
176
 
index f2cd132..83af389 100644
177
 
--- a/kdeui/icons/kicon.h
178
 
+++ b/kdeui/icons/kicon.h
179
 
@@ -84,6 +84,11 @@ public:
 
174
Index: kde4libs-4.3.95/kdeui/icons/kicon.h
 
175
===================================================================
 
176
--- kde4libs-4.3.95.orig/kdeui/icons/kicon.h    2010-01-19 20:33:29.701739459 -0500
 
177
+++ kde4libs-4.3.95/kdeui/icons/kicon.h 2010-01-19 20:34:44.589737879 -0500
 
178
@@ -84,6 +84,11 @@
180
179
 
181
180
     KIcon& operator=( const KIcon &other );
182
181
 
188
187
 private:
189
188
     class Private;
190
189
     Private* const d;
191
 
diff --git a/kdeui/icons/kicontheme.cpp b/kdeui/icons/kicontheme.cpp
192
 
index 5ef6ef3..b0974de 100644
193
 
--- a/kdeui/icons/kicontheme.cpp
194
 
+++ b/kdeui/icons/kicontheme.cpp
195
 
@@ -155,6 +155,7 @@ KIconTheme::KIconTheme(const QString& name, const QString& appName)
 
190
Index: kde4libs-4.3.95/kdeui/icons/kicontheme.cpp
 
191
===================================================================
 
192
--- kde4libs-4.3.95.orig/kdeui/icons/kicontheme.cpp     2010-01-19 20:33:29.673738204 -0500
 
193
+++ kde4libs-4.3.95/kdeui/icons/kicontheme.cpp  2010-01-19 20:34:44.593747746 -0500
 
194
@@ -155,6 +155,7 @@
196
195
         << "/usr/share/pixmaps"
197
196
         // These are not in the icon spec, but e.g. GNOME puts some icons there anyway.
198
197
         << KGlobal::dirs()->resourceDirs("xdgdata-pixmap");
200
199
     for (it=icnlibs.constBegin(); it!=icnlibs.constEnd(); ++it) {
201
200
         cDir = *it + name + '/';
202
201
         if (KStandardDirs::exists(cDir)) {
203
 
diff --git a/kdeui/notifications/kstatusnotifieritem.cpp b/kdeui/notifications/kstatusnotifieritem.cpp
204
 
index 04eca93..3beac99 100644
205
 
--- a/kdeui/notifications/kstatusnotifieritem.cpp
206
 
+++ b/kdeui/notifications/kstatusnotifieritem.cpp
 
202
Index: kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritem.cpp
 
203
===================================================================
 
204
--- kde4libs-4.3.95.orig/kdeui/notifications/kstatusnotifieritem.cpp    2010-01-19 20:33:29.613757182 -0500
 
205
+++ kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritem.cpp 2010-01-19 20:34:44.593747746 -0500
207
206
@@ -43,8 +43,18 @@
208
207
 
209
208
 #include <netinet/in.h>
223
222
 KStatusNotifierItem::KStatusNotifierItem(QObject *parent)
224
223
       : QObject(parent),
225
224
         d(new KStatusNotifierItemPrivate(this))
226
 
@@ -315,8 +325,13 @@ void KStatusNotifierItem::setContextMenu(KMenu *menu)
 
225
@@ -315,8 +325,13 @@
227
226
     d->menu = menu;
228
227
 
229
228
     if (d->menu) {
237
236
     }
238
237
 
239
238
     if (d->systemTrayIcon) {
240
 
@@ -620,8 +635,8 @@ void KStatusNotifierItemPrivate::registerToDaemon()
 
239
@@ -620,8 +635,8 @@
241
240
 {
242
241
     kDebug(299) << "Registering a client interface to the KStatusNotifierWatcher";
243
242
     if (!statusNotifierWatcher) {
248
247
                                                                         QDBusConnection::sessionBus());
249
248
     }
250
249
 
251
 
@@ -639,7 +654,7 @@ void KStatusNotifierItemPrivate::registerToDaemon()
 
250
@@ -639,7 +654,7 @@
252
251
 void KStatusNotifierItemPrivate::serviceChange(const QString& name, const QString& oldOwner, const QString& newOwner)
253
252
 {
254
253
     bool legacy = false;
257
256
         if (newOwner.isEmpty()) {
258
257
             //unregistered
259
258
             kDebug(299) << "Connection to the KStatusNotifierWatcher lost";
260
 
@@ -648,7 +663,7 @@ void KStatusNotifierItemPrivate::serviceChange(const QString& name, const QStrin
 
259
@@ -648,7 +663,7 @@
261
260
             //registered
262
261
             legacy = false;
263
262
         }
266
265
         if (newOwner.isEmpty() && (!statusNotifierWatcher ||
267
266
                                    !statusNotifierWatcher->property("IsStatusNotifierHostRegistered").toBool())) {
268
267
             kDebug(299)<<"Connection to the last KStatusNotifierHost lost";
269
 
diff --git a/kdeui/notifications/kstatusnotifieritemdbus_p.cpp b/kdeui/notifications/kstatusnotifieritemdbus_p.cpp
270
 
index c038e35..534c060 100644
271
 
--- a/kdeui/notifications/kstatusnotifieritemdbus_p.cpp
272
 
+++ b/kdeui/notifications/kstatusnotifieritemdbus_p.cpp
273
 
@@ -147,7 +147,7 @@ int KStatusNotifierItemDBus::s_serviceCount = 0;
 
268
Index: kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemdbus_p.cpp
 
269
===================================================================
 
270
--- kde4libs-4.3.95.orig/kdeui/notifications/kstatusnotifieritemdbus_p.cpp      2010-01-19 20:33:29.625757731 -0500
 
271
+++ kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemdbus_p.cpp   2010-01-19 20:34:44.593747746 -0500
 
272
@@ -147,7 +147,7 @@
274
273
 KStatusNotifierItemDBus::KStatusNotifierItemDBus(KStatusNotifierItem *parent)
275
274
   : QObject(parent),
276
275
     m_statusNotifierItem(parent),
279
278
                       .arg(QCoreApplication::applicationPid())
280
279
                       .arg(++s_serviceCount)),
281
280
     m_dbus(QDBusConnection::connectToBus(QDBusConnection::SessionBus, m_service))
282
 
@@ -253,6 +253,12 @@ KDbusToolTipStruct KStatusNotifierItemDBus::ToolTip() const
 
281
@@ -253,6 +253,12 @@
283
282
     return toolTip;
284
283
 }
285
284
 
292
291
 //Interaction
293
292
 
294
293
 void KStatusNotifierItemDBus::ContextMenu(int x, int y)
295
 
diff --git a/kdeui/notifications/kstatusnotifieritemdbus_p.h b/kdeui/notifications/kstatusnotifieritemdbus_p.h
296
 
index 1d03d6f..c25cc68 100644
297
 
--- a/kdeui/notifications/kstatusnotifieritemdbus_p.h
298
 
+++ b/kdeui/notifications/kstatusnotifieritemdbus_p.h
 
294
Index: kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemdbus_p.h
 
295
===================================================================
 
296
--- kde4libs-4.3.95.orig/kdeui/notifications/kstatusnotifieritemdbus_p.h        2010-01-19 20:33:29.581738375 -0500
 
297
+++ kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemdbus_p.h     2010-01-19 20:34:44.593747746 -0500
299
298
@@ -27,6 +27,7 @@
300
299
 #include <QString>
301
300
 #include <QDBusArgument>
304
303
 #include <QPixmap>
305
304
 
306
305
 //Custom message type for DBus
307
 
@@ -64,6 +65,7 @@ class KStatusNotifierItemDBus : public QObject
 
306
@@ -64,6 +65,7 @@
308
307
     Q_PROPERTY(KDbusImageVector AttentionIconPixmap READ AttentionIconPixmap)
309
308
     Q_PROPERTY(QString AttentionMovieName READ AttentionMovieName)
310
309
     Q_PROPERTY(KDbusToolTipStruct ToolTip READ ToolTip)
312
311
 
313
312
     friend class KStatusNotifierItem;
314
313
 public:
315
 
@@ -146,6 +148,10 @@ public:
 
314
@@ -146,6 +148,10 @@
316
315
      */
317
316
     KDbusToolTipStruct ToolTip() const;
318
317
 
323
322
 
324
323
 public Q_SLOTS:
325
324
     //interaction
326
 
diff --git a/kdeui/notifications/kstatusnotifieritemprivate_p.h b/kdeui/notifications/kstatusnotifieritemprivate_p.h
327
 
index 212b2ef..7ee87cb 100644
328
 
--- a/kdeui/notifications/kstatusnotifieritemprivate_p.h
329
 
+++ b/kdeui/notifications/kstatusnotifieritemprivate_p.h
330
 
@@ -120,12 +120,13 @@ public:
 
325
Index: kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemprivate_p.h
 
326
===================================================================
 
327
--- kde4libs-4.3.95.orig/kdeui/notifications/kstatusnotifieritemprivate_p.h     2010-01-19 20:33:29.593738574 -0500
 
328
+++ kde4libs-4.3.95/kdeui/notifications/kstatusnotifieritemprivate_p.h  2010-01-19 20:34:44.593747746 -0500
 
329
@@ -120,12 +120,13 @@
331
330
     QIcon toolTipIcon;
332
331
     QString toolTipTitle;
333
332
     QString toolTipSubTitle;
342
341
     org::freedesktop::Notifications *notificationsClient;
343
342
 
344
343
     KSystemTrayIcon *systemTrayIcon;
345
 
diff --git a/kdeui/notifications/org.ayatana.dbusmenu.xml b/kdeui/notifications/org.ayatana.dbusmenu.xml
346
 
new file mode 100644
347
 
index 0000000..aa5d28f
348
 
--- /dev/null
349
 
+++ b/kdeui/notifications/org.ayatana.dbusmenu.xml
 
344
Index: kde4libs-4.3.95/kdeui/notifications/org.ayatana.dbusmenu.xml
 
345
===================================================================
 
346
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
347
+++ kde4libs-4.3.95/kdeui/notifications/org.ayatana.dbusmenu.xml        2010-01-19 20:34:44.597756077 -0500
350
348
@@ -0,0 +1,177 @@
351
349
+<?xml version="1.0" encoding="UTF-8"?>
352
350
+<!--
525
523
+
526
524
+    </interface>
527
525
+</node>
528
 
diff --git a/kdeui/notifications/org.freedesktop.StatusNotifierItem.xml b/kdeui/notifications/org.freedesktop.StatusNotifierItem.xml
529
 
new file mode 100644
530
 
index 0000000..cd2c878
531
 
--- /dev/null
532
 
+++ b/kdeui/notifications/org.freedesktop.StatusNotifierItem.xml
 
526
Index: kde4libs-4.3.95/kdeui/notifications/org.freedesktop.StatusNotifierItem.xml
 
527
===================================================================
 
528
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
529
+++ kde4libs-4.3.95/kdeui/notifications/org.freedesktop.StatusNotifierItem.xml  2010-01-19 20:34:44.597756077 -0500
533
530
@@ -0,0 +1,92 @@
534
531
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
535
532
+<node>
623
620
+
624
621
+  </interface>
625
622
+</node>
626
 
diff --git a/kdeui/notifications/org.freedesktop.StatusNotifierWatcher.xml b/kdeui/notifications/org.freedesktop.StatusNotifierWatcher.xml
627
 
new file mode 100644
628
 
index 0000000..c5a9efa
629
 
--- /dev/null
630
 
+++ b/kdeui/notifications/org.freedesktop.StatusNotifierWatcher.xml
 
623
Index: kde4libs-4.3.95/kdeui/notifications/org.freedesktop.StatusNotifierWatcher.xml
 
624
===================================================================
 
625
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
626
+++ kde4libs-4.3.95/kdeui/notifications/org.freedesktop.StatusNotifierWatcher.xml       2010-01-19 20:34:44.597756077 -0500
631
627
@@ -0,0 +1,39 @@
632
628
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
633
629
+<node>
668
664
+    </signal>
669
665
+  </interface>
670
666
+</node>
671
 
diff --git a/kdeui/notifications/org.kde.StatusNotifierItem.xml b/kdeui/notifications/org.kde.StatusNotifierItem.xml
672
 
deleted file mode 100644
673
 
index 16d48ab..0000000
674
 
--- a/kdeui/notifications/org.kde.StatusNotifierItem.xml
675
 
+++ /dev/null
 
667
Index: kde4libs-4.3.95/kdeui/notifications/org.kde.StatusNotifierItem.xml
 
668
===================================================================
 
669
--- kde4libs-4.3.95.orig/kdeui/notifications/org.kde.StatusNotifierItem.xml     2010-01-19 20:33:29.633756095 -0500
 
670
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
676
671
@@ -1,91 +0,0 @@
677
672
-<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
678
673
-<node>
765
760
-
766
761
-  </interface>
767
762
-</node>
768
 
diff --git a/kdeui/notifications/org.kde.StatusNotifierWatcher.xml b/kdeui/notifications/org.kde.StatusNotifierWatcher.xml
769
 
deleted file mode 100644
770
 
index 5e043dc..0000000
771
 
--- a/kdeui/notifications/org.kde.StatusNotifierWatcher.xml
772
 
+++ /dev/null
 
763
Index: kde4libs-4.3.95/kdeui/notifications/org.kde.StatusNotifierWatcher.xml
 
764
===================================================================
 
765
--- kde4libs-4.3.95.orig/kdeui/notifications/org.kde.StatusNotifierWatcher.xml  2010-01-19 20:33:29.649740250 -0500
 
766
+++ /dev/null   1970-01-01 00:00:00.000000000 +0000
773
767
@@ -1,39 +0,0 @@
774
768
-<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
775
769
-<node>
810
804
-    </signal>
811
805
-  </interface>
812
806
-</node>
813
 
diff --git a/kdeui/tests/kstatusnotifieritemtest.cpp b/kdeui/tests/kstatusnotifieritemtest.cpp
814
 
index 656cfad..a6a06e0 100644
815
 
--- a/kdeui/tests/kstatusnotifieritemtest.cpp
816
 
+++ b/kdeui/tests/kstatusnotifieritemtest.cpp
 
807
Index: kde4libs-4.3.95/kdeui/tests/kstatusnotifieritemtest.cpp
 
808
===================================================================
 
809
--- kde4libs-4.3.95.orig/kdeui/tests/kstatusnotifieritemtest.cpp        2010-01-19 20:33:29.569740340 -0500
 
810
+++ kde4libs-4.3.95/kdeui/tests/kstatusnotifieritemtest.cpp     2010-01-19 20:34:44.601751208 -0500
817
811
@@ -33,6 +33,21 @@
818
812
 #include <kmenu.h>
819
813
 #include <kicon.h>
836
830
 KStatusNotifierItemTest::KStatusNotifierItemTest(QObject *parent, KStatusNotifierItem *tray)
837
831
   : QObject(parent)
838
832
 {
839
 
@@ -43,15 +58,64 @@ KStatusNotifierItemTest::KStatusNotifierItemTest(QObject *parent, KStatusNotifie
 
833
@@ -43,15 +58,64 @@
840
834
     QAction *active = new QAction("Set active", menu);
841
835
     QAction *passive = new QAction("Set passive", menu);
842
836
 
901
895
 void KStatusNotifierItemTest::setNeedsAttention()
902
896
 {
903
897
     kDebug()<<"Asking for attention";
904
 
@@ -71,16 +135,36 @@ void KStatusNotifierItemTest::setPassive()
 
898
@@ -71,16 +135,36 @@
905
899
     m_tray->setStatus(KStatusNotifierItem::Passive);
906
900
 }
907
901
 
939
933
 
940
934
     tray->setTitle("DBus System tray test");
941
935
     tray->setIconByName("konqueror");
942
 
diff --git a/kdeui/tests/kstatusnotifieritemtest.h b/kdeui/tests/kstatusnotifieritemtest.h
943
 
index 38a1e1a..6839f12 100644
944
 
--- a/kdeui/tests/kstatusnotifieritemtest.h
945
 
+++ b/kdeui/tests/kstatusnotifieritemtest.h
 
936
Index: kde4libs-4.3.95/kdeui/tests/kstatusnotifieritemtest.h
 
937
===================================================================
 
938
--- kde4libs-4.3.95.orig/kdeui/tests/kstatusnotifieritemtest.h  2010-01-19 20:33:29.557738114 -0500
 
939
+++ kde4libs-4.3.95/kdeui/tests/kstatusnotifieritemtest.h       2010-01-19 20:34:44.601751208 -0500
946
940
@@ -23,6 +23,7 @@
947
941
 
948
942
 #include <QObject>
951
945
 class KStatusNotifierItem;
952
946
 
953
947
 class KStatusNotifierItemTest : public QObject
954
 
@@ -33,12 +34,20 @@ public:
 
948
@@ -33,12 +34,20 @@
955
949
     KStatusNotifierItemTest(QObject *parent, KStatusNotifierItem *tray);
956
950
     //~KStatusNotifierItemTest();
957
951
 
972
966
 };
973
967
 
974
968
 #endif
975
 
diff --git a/plasma/plasma.cpp b/plasma/plasma.cpp
976
 
index b9d14e9..34f5cce 100644
977
 
--- a/plasma/plasma.cpp
978
 
+++ b/plasma/plasma.cpp
 
969
Index: kde4libs-4.3.95/plasma/plasma.cpp
 
970
===================================================================
 
971
--- kde4libs-4.3.95.orig/plasma/plasma.cpp      2010-01-19 20:33:29.789742611 -0500
 
972
+++ kde4libs-4.3.95/plasma/plasma.cpp   2010-01-19 20:34:44.601751208 -0500
979
973
@@ -27,6 +27,8 @@
980
974
 #include <plasma/containment.h>
981
975
 #include <plasma/view.h>
985
979
 namespace Plasma
986
980
 {
987
981
 
988
 
@@ -142,4 +144,16 @@ QList<QAction*> actionsFromMenu(QMenu *menu, const QString &prefix, QObject *par
 
982
@@ -142,4 +144,16 @@
989
983
     return ret;
990
984
 }
991
985
 
1002
996
+}
1003
997
+
1004
998
 } // Plasma namespace
1005
 
diff --git a/plasma/plasma.h b/plasma/plasma.h
1006
 
index ca6d8b4..3780418 100644
1007
 
--- a/plasma/plasma.h
1008
 
+++ b/plasma/plasma.h
1009
 
@@ -342,6 +342,24 @@ PLASMA_EXPORT QList<QAction*> actionsFromMenu(QMenu *menu,
 
999
Index: kde4libs-4.3.95/plasma/plasma.h
 
1000
===================================================================
 
1001
--- kde4libs-4.3.95.orig/plasma/plasma.h        2010-01-19 20:33:29.765737536 -0500
 
1002
+++ kde4libs-4.3.95/plasma/plasma.h     2010-01-19 20:34:44.601751208 -0500
 
1003
@@ -328,6 +328,24 @@
1010
1004
                                               const QString &prefix = QString(),
1011
1005
                                               QObject *parent = 0);
1012
1006
 
1031
1025
 } // Plasma namespace
1032
1026
 
1033
1027
 Q_DECLARE_OPERATORS_FOR_FLAGS(Plasma::Constraints)
1034
 
diff --git a/plasma/private/style.cpp b/plasma/private/style.cpp
1035
 
index 1e01302..c5c574e 100644
1036
 
--- a/plasma/private/style.cpp
1037
 
+++ b/plasma/private/style.cpp
 
1028
Index: kde4libs-4.3.95/plasma/private/style.cpp
 
1029
===================================================================
 
1030
--- kde4libs-4.3.95.orig/plasma/private/style.cpp       2010-01-19 20:33:29.749738855 -0500
 
1031
+++ kde4libs-4.3.95/plasma/private/style.cpp    2010-01-19 20:34:44.604738320 -0500
1038
1032
@@ -25,11 +25,13 @@
1039
1033
 #include <QSpinBox>
1040
1034
 #include <QComboBox>
1049
1043
 
1050
1044
 namespace Plasma {
1051
1045
 
1052
 
@@ -39,7 +41,9 @@ public:
 
1046
@@ -39,7 +41,9 @@
1053
1047
     StylePrivate(Style *style)
1054
1048
         : q(style),
1055
1049
           scrollbar(0),
1060
1054
     {
1061
1055
     }
1062
1056
 
1063
 
@@ -65,9 +69,58 @@ public:
 
1057
@@ -65,9 +69,58 @@
1064
1058
         }
1065
1059
     }
1066
1060
 
1119
1113
     static Plasma::Style::Ptr s_sharedStyle;
1120
1114
 };
1121
1115
 
1122
 
@@ -100,6 +153,180 @@ Style::~Style()
 
1116
@@ -100,6 +153,180 @@
1123
1117
     delete d;
1124
1118
 }
1125
1119
 
1300
1294
 void Style::drawComplexControl(ComplexControl control,
1301
1295
                                const QStyleOptionComplex *option,
1302
1296
                                QPainter *painter,
1303
 
@@ -276,6 +503,13 @@ void Style::drawPrimitive(PrimitiveElement element, const QStyleOption *option,
 
1297
@@ -276,6 +503,13 @@
1304
1298
     }
1305
1299
 
1306
1300
     switch (element) {
1314
1308
     case PE_PanelLineEdit:
1315
1309
         //comboboxes draws their own frame
1316
1310
         if (qobject_cast<QComboBox *>(widget->parent())) {
1317
 
@@ -321,6 +555,18 @@ int Style::pixelMetric(PixelMetric metric, const QStyleOption *option, const QWi
 
1311
@@ -321,6 +555,18 @@
1318
1312
     }
1319
1313
 
1320
1314
     switch (metric) {
1333
1327
     case PM_ScrollBarExtent: {
1334
1328
         d->createScrollbar();
1335
1329
         const QStyleOptionSlider *scrollOption = qstyleoption_cast<const QStyleOptionSlider *>(option);
1336
 
@@ -355,6 +601,35 @@ QSize Style::sizeFromContents(ContentsType type, const QStyleOption *option,
 
1330
@@ -355,6 +601,35 @@
1337
1331
                               const QSize &contentsSize, const QWidget *widget) const
1338
1332
 {
1339
1333
     switch (type) {
1369
1363
     case CT_LineEdit: {
1370
1364
         d->createTextBox();
1371
1365
         d->textBox->setElementPrefix("base");
1372
 
@@ -369,6 +644,34 @@ QSize Style::sizeFromContents(ContentsType type, const QStyleOption *option,
 
1366
@@ -369,6 +644,34 @@
1373
1367
     
1374
1368
 }
1375
1369
 
1404
1398
 }
1405
1399
 
1406
1400
 #include "style_p.moc"
1407
 
diff --git a/plasma/private/style_p.h b/plasma/private/style_p.h
1408
 
index 7f88ec8..b43dbff 100644
1409
 
--- a/plasma/private/style_p.h
1410
 
+++ b/plasma/private/style_p.h
1411
 
@@ -44,9 +44,14 @@ public:
 
1401
Index: kde4libs-4.3.95/plasma/private/style_p.h
 
1402
===================================================================
 
1403
--- kde4libs-4.3.95.orig/plasma/private/style_p.h       2010-01-19 20:33:29.733738429 -0500
 
1404
+++ kde4libs-4.3.95/plasma/private/style_p.h    2010-01-19 20:34:44.604738320 -0500
 
1405
@@ -44,9 +44,14 @@
1412
1406
     explicit Style();
1413
1407
     ~Style();
1414
1408
 
1424
1418
     void drawComplexControl(ComplexControl control,
1425
1419
                             const QStyleOptionComplex *option,
1426
1420
                             QPainter *painter,
1427
 
@@ -59,6 +64,9 @@ protected:
 
1421
@@ -59,6 +64,9 @@
1428
1422
     QRect subElementRect(SubElement element, const QStyleOption * option, const QWidget *widget = 0) const;
1429
1423
     QSize sizeFromContents(ContentsType, const QStyleOption *option, const QSize &contentsSize,
1430
1424
                            const QWidget *widget = 0) const;