~ubuntu-branches/ubuntu/lucid/kdelibs/lucid

« back to all changes in this revision

Viewing changes to debian/patches/63_fixed-layout-table.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Riddell
  • Date: 2009-11-09 17:43:28 UTC
  • mfrom: (1.1.16 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091109174328-3kvjg00vi07n1dvg
Tags: 4:3.5.10.dfsg.1-2.1ubuntu1
* Merge with Debian, remaining changes
 - make sure control and control.in are in sync
 - --with-distribution="Kubuntu (`lsb_release --codename --short`) $(DEB_VERSION)"
 - binary-install/kdelibs-data installs aboutkde-kubuntu.png.uu and cr*-device-system.png.uu
 - don't build-dep on libgamin-dev, libfam-dev
 - stop kdelibs4-dev depending on gamin/fam
 - don't install .svgz icons, docs or all_languages in kdelibs-data.install
 - rosetta support in rules common-install-prehook-impl:: [and common-post-build-arch:: ?] and include debian/kubuntu-desktop-i18n/
 - build-dep on: gettext-kde, kdesdk-scripts, lsb-release, base-files, sudo
 - cdbs build-dep 0.4.41ubuntu2
 - kdelibs4-dev depends on gettext-kde, kdesdk-scripts
 - copy debian/icons over
 - Make kdelibs4c2a depend on launchpad-integration, sudo.  Recommends on xdg-user-dirs
 - Remove 19_debianize_useragent.diff (changed to kubuntu_19_debianize_useragent.diff) s/Debian/Kubuntu
 - remove kdelibs4c2a depends on menu-xdg
 - include kubuntu_01_kdepot.diff and kde.pot in debian/patches/common
 - use a local copy of kde.mk without the common-install-prehook-impl:: rule; edit debian-qt-kde.mk to include debian/cdbs/kde.mk
 - build with --with-sudo-kdesu-backend and build-dep on sudo and make kdelibs4c2a depend on sudo
 - kdelibs-data.install : Add nzb mimetype
 - Make kdelibs4-dev replace more recent kdelibs4c2a for overlapping files
 - remove /usr/bin/preparetips, arts files and ksvntopng from kdelibs4-dev.install
 - Drop the package kdelibs4-doc completely. It contained API documentation  which is now obsolete, but still available via api.kde.org.
 - make sure control and control.in are in sync
 - in debian/rule remove .pot files outside .po directory
 - 97_automake_cleanup.diff becomes kubuntu_97_automake_cleanup.diff

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: kdelibs/khtml/rendering/table_layout.cpp
2
 
===================================================================
3
 
--- kdelibs/khtml/rendering/table_layout.cpp    (revisión: 874967)
4
 
+++ kdelibs/khtml/rendering/table_layout.cpp    (revisión: 874968)
5
 
@@ -297,7 +297,8 @@
 
1
--- a/khtml/rendering/table_layout.cpp
 
2
+++ b/khtml/rendering/table_layout.cpp
 
3
@@ -297,7 +297,8 @@ void FixedTableLayout::layout()
6
4
 #endif
7
5
         for ( int i = 0; available > 0 && i < nEffCols; i++ ) {
8
6
             if ( width[i].isPercent() ) {
12
10
                 available -= w;
13
11
                 calcWidth[i] = w;
14
12
             }
15
 
@@ -313,7 +314,8 @@
 
13
@@ -313,7 +314,8 @@ void FixedTableLayout::layout()
16
14
 
17
15
         for ( int i = 0; available > 0 && i < nEffCols; i++ ) {
18
16
             if ( width[i].isVariable() ) {